Bug 1262104 - [RFE] Configure Ceph RGW as Cinder Backup target in RHEL-OSP director
[RFE] Configure Ceph RGW as Cinder Backup target in RHEL-OSP director
Status: CLOSED ERRATA
Product: Red Hat OpenStack
Classification: Red Hat
Component: puppet-tripleo (Show other bugs)
7.0 (Kilo)
Unspecified Unspecified
unspecified Severity unspecified
: rc
: 10.0 (Newton)
Assigned To: Keith Schincke
Yogev Rabl
: FutureFeature, Triaged
Depends On: 1262106 1309460 1404199
Blocks: 1412014 1387471
  Show dependency treegraph
 
Reported: 2015-09-10 15:54 EDT by Sean Cohen
Modified: 2017-08-15 15:33 EDT (History)
13 users (show)

See Also:
Fixed In Version: puppet-tripleo-5.0.0-0.20160907223204.488fb91.el7ost
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
: 1387471 (view as bug list)
Environment:
Last Closed: 2016-12-14 10:15:30 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
OpenStack gerrit 311218 None None None 2016-09-07 17:38 EDT

  None (edit)
Description Sean Cohen 2015-09-10 15:54:11 EDT
Allow backup of Cinder volumes to a Ceph object store in RHEL-OSP direc
Comment 5 Mike Burns 2016-04-07 16:50:54 EDT
This bug did not make the OSP 8.0 release.  It is being deferred to OSP 10.
Comment 7 Keith Schincke 2016-09-07 20:49:07 EDT
I think the BZ is possible once the RGW patch (0) is merged.

puppet-tripleo (1) and puppet-cinder (2) supports configuring Ceph backups to use swift.


0: https://review.openstack.org/#/c/289027/
1: https://github.com/openstack/puppet-tripleo/blob/master/manifests/profile/base/cinder/backup/swift.pp
2: https://github.com/openstack/puppet-cinder/blob/master/manifests/backup/swift.pp
Comment 8 Giulio Fidente 2016-09-14 11:32:56 EDT
We can enable cinder-backup in OSPd10 deploying with:

  -e environments/cinder-backup.yaml

it defaults to the swift backend, we need to test if by deploying rgw as a drop-in replacement for swift, cinder-backup works as expected.
Comment 9 Keith Schincke 2016-09-21 16:04:23 EDT
With the merging of (1), this should be ready for testing in the next puddle. 

1) https://review.openstack.org/#/c/289027/
Comment 10 Keith Schincke 2016-09-26 20:41:53 EDT
I have used the upstream bits and have verified Cinder backup working working with Ceph RGW providing object storage services.

This should be verified and (if successful) closed when the next stable puddle is available.
Comment 14 Yogev Rabl 2016-11-13 20:44:04 EST
Verified on puppet-tripleo-5.3.0-7.el7ost.noarch

with the following environment file:
resource_registry:
  OS::TripleO::Services::CephMon: ../puppet/services/ceph-mon.yaml
  OS::TripleO::Services::CephOSD: ../puppet/services/ceph-osd.yaml
  OS::TripleO::Services::CephClient: ../puppet/services/ceph-client.yaml
  OS::TripleO::Services::CephRgw: ../puppet/services/ceph-rgw.yaml
  OS::TripleO::Services::SwiftProxy: OS::Heat::None
  OS::TripleO::Services::SwiftStorage: OS::Heat::None
  OS::TripleO::Services::SwiftRingBuilder: OS::Heat::None


parameter_defaults:
  CinderEnableIscsiBackend: false
  CinderEnableRbdBackend: true
  CinderBackupBackend: swift
  NovaEnableRbdBackend: true
  GlanceBackend: swift
  GnocchiBackend: rbd
  CephPools:
    volumes:
      size: 3
      pg_num: 128
      pgp_num: 128
    vms:
      size: 1
      pg_num: 128
      pgp_num: 128
    images:
      size: 5
      pg_num: 128
      pgp_num: 128
    metrics:
      size: 1
      pg_num: 128
      pgp_num: 128

  ExtraConfig:
    ceph::profile::params::osds:
      '/dev/vdb':
         journal: '/dev/vdf1'
      '/dev/vdc':
         journal: '/dev/vdf2'
      '/dev/vdd':
         journal: '/dev/vdf3'
      '/dev/vde':
         journal: '/dev/vdf4'
    ceph::profile::params::osd_max_object_name_len: 256
    ceph::profile::params::osd_max_object_namespace_len: 64
Comment 16 errata-xmlrpc 2016-12-14 10:15:30 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHEA-2016-2948.html

Note You need to log in before you can comment on or make changes to this bug.