Bug 1309460 - [RFE] Heat template to configure RGW
[RFE] Heat template to configure RGW
Status: CLOSED ERRATA
Product: Red Hat OpenStack
Classification: Red Hat
Component: openstack-tripleo-heat-templates (Show other bugs)
10.0 (Newton)
All Linux
high Severity high
: rc
: 10.0 (Newton)
Assigned To: Keith Schincke
Yogev Rabl
: FutureFeature, Triaged
: 1262112 1287189 (view as bug list)
Depends On: 1309455
Blocks: 1291943 1335593 1356451 1412014 1413723 1262104 1262112 1387433 1387471 1404199
  Show dependency treegraph
 
Reported: 2016-02-17 16:32 EST by Kyle Bader
Modified: 2017-08-18 05:52 EDT (History)
30 users (show)

See Also:
Fixed In Version: openstack-tripleo-heat-templates-5.0.0-0.20160929150845.4cdc4fc.el7ost
Doc Type: Enhancement
Doc Text:
You can now use the director to deploy Ceph RadosGW as your object storage gateway. To do so, include /usr/share/openstack-tripleo-heat-templates/environmens/ceph-radosgw.yaml in your overcloud deployment. When you use this heat template, the default Object Storage service (swift) will not be deployed.
Story Points: ---
Clone Of:
: 1404199 (view as bug list)
Environment:
Last Closed: 2016-12-14 10:23:51 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
scohen: needinfo+


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Red Hat Knowledge Base (Solution) 2993871 None None None 2017-08-18 05:52 EDT
OpenStack gerrit 289027 None None None 2016-09-13 16:23 EDT

  None (edit)
Description Kyle Bader 2016-02-17 16:32:16 EST
Description of problem:

Jetstream is deploying/configuring RGW on OSP controller nodes using custom scripting. This needs to be moved into Heat.

Expected results:

Heat will configure a civetweb RGW on each controller.
Comment 2 Kyle Bader 2016-02-17 16:34:26 EST
Heat will *optionally* configure a civetweb RGW on each controller.
Comment 3 Kyle Bader 2016-02-17 22:49:44 EST
Currently ceph-deploy supports deploying a Civetweb based RGW, we also have documentation around switching from apache to Civetweb based RGW:

https://access.redhat.com/documentation/en/red-hat-ceph-storage/version-1.3/red-hat-ceph-storage-13-ceph-object-gateway-for-rhel-x86-64/chapter-4-create-a-gateway-instance
Comment 4 Kyle Bader 2016-02-18 10:33:16 EST
Relevant upstream work

https://review.openstack.org/#/c/254548/
Comment 5 Alan Bishop 2016-04-13 16:00:07 EDT
We have been coordinating with Keith Schincke and as of Beta 9 we still have to apply patches to both the undercloud and overcloud in order to get RGW functionality working correctly. To that end, I'm not sure whether the target release for this BZ is correct. However, I'm removing this as a js5.0 blocker because we have workarounds.
Comment 7 Keith Schincke 2016-07-12 08:39:13 EDT
This patch is being upstream with (1) and is being targeted for inclusion. Dell JS has internal patches to achieve the same functionality. 

1: https://review.openstack.org/#/c/334081/
Comment 8 Karl Hastings 2016-07-14 21:02:35 EDT
resetting tracker and releases to match rhos-10.0? flag.
Comment 9 Keith Schincke 2016-09-13 16:23:50 EDT
This BZ depends on upstream patch (1) and BZ 1309455

1: https://review.openstack.org/#/c/289027/
Comment 10 Keith Schincke 2016-09-21 16:07:31 EDT
This should be testable in the next puddle with (1) merged.

1: https://review.openstack.org/#/c/289027/
Comment 14 jomurphy 2016-10-27 16:12:12 EDT
*** Bug 1287189 has been marked as a duplicate of this bug. ***
Comment 16 Yogev Rabl 2016-11-06 07:05:35 EST
verified on openstack-tripleo-heat-templates-5.0.0-1.2.el7ost.noarch
Comment 18 errata-xmlrpc 2016-12-14 10:23:51 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHEA-2016-2948.html
Comment 19 Giulio Fidente 2017-01-16 11:16:10 EST
*** Bug 1262112 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.