Bug 1266219 - RFE: EQL: tripleo-heat-template
RFE: EQL: tripleo-heat-template
Status: CLOSED ERRATA
Product: Red Hat OpenStack
Classification: Red Hat
Component: openstack-tripleo-heat-templates (Show other bugs)
8.0 (Liberty)
Unspecified Unspecified
unspecified Severity unspecified
: ga
: 8.0 (Liberty)
Assigned To: Jiri Stransky
yeylon@redhat.com
: FutureFeature, OtherQA, Triaged
Depends On:
Blocks: 1261979 1266220 1280005 1310828
  Show dependency treegraph
 
Reported: 2015-09-24 15:48 EDT by Rajini Ram
Modified: 2016-04-18 03:13 EDT (History)
17 users (show)

See Also:
Fixed In Version: openstack-tripleo-heat-templates-0.8.7-11.el7ost
Doc Type: Enhancement
Doc Text:
The Director can now deploy the Block Storage service with a Dell EqualLogic or Dell Storage Center appliance as a back end. For more information, see: https://access.redhat.com/documentation/en/red-hat-openstack-platform/version-8/dell-equallogic-back-end-guide/ https://access.redhat.com/documentation/en/red-hat-openstack-platform/8/dell-storage-center-back-end-guide/dell-storage-center-back-end-guide
Story Points: ---
Clone Of:
: 1266220 1280005 (view as bug list)
Environment:
Last Closed: 2016-04-07 17:40:28 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
OpenStack gerrit 264871 None None None 2016-02-11 15:47 EST
OpenStack gerrit 278990 None None None 2016-02-11 15:47 EST

  None (edit)
Description Rajini Ram 2015-09-24 15:48:41 EDT
Description of problem:
An example of enabling an alternative cinder backend that was accepted upstream [1] in the hopes that this gives you a starting point for integration of EQL & Comp drivers.
[1] https://review.openstack.org/#/c/187700/

Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.

Actual results:


Expected results:


Additional info:
Comment 3 arkady kanevsky 2015-10-08 13:43:34 EDT
need to support our current solution:
Support for multiple Dell PS arrays.
Proper support for current EQL options that are in OSP7
Comment 4 Rajini Ram 2015-11-11 12:19:28 EST
Can you review and vote?

https://review.openstack.org/#/c/242640/
Comment 5 Rajini Ram 2016-01-21 14:20:12 EST
Looks like they are not yet available in the osp8(beta3) builds we are receiving. 

Eql and cmpl templates under the folder in the director are missing /../openstack-tripleo-heat-templates/puppet/extraconfig/pre_deploy

1.	These have been cherry picked for liberty but not yet merged. Is that why?
https://review.openstack.org/#/c/264872/
https://review.openstack.org/#/c/264871/
2.	Now that we don’t have a foreman UI or director UI, can you give us some information on how to deploy/configure cinder using these templates?
Comment 6 Mike Burns 2016-01-21 15:28:13 EST
The problem with the patches missing is actually a broken build.  The patches were in the right place and the spec file said the right things, but the build process didn't actually apply the patches.  I'm working on resolving this now.  

This problem will go away when they merge into stable/liberty and we rebase on that.
Comment 7 Rajini Ram 2016-02-03 11:49:18 EST
Still don't see it in Beta 5 build
Comment 8 Mike Burns 2016-02-03 11:54:29 EST
(In reply to Rajini Ram from comment #7)
> Still don't see it in Beta 5 build

Beta 5 did not include any updates to director builds.
Comment 9 Rajini Ram 2016-02-03 12:19:58 EST
Do you expect to include this in Beta-6?
Comment 10 Rajini Ram 2016-02-08 10:46:05 EST
There is a syntax error. The pool name is not getting passed. Typo "eqlx_lpool" should be "eqlx_pool"

Will submit a patch


openstack-tripleo-heat-templates/puppet/manifests/overcloud_controller_pacemaker.pp:      eqlx_pool           => hiera('cinder::backend::eqlx::eqlx_lpool',
 undef),
openstack-tripleo-heat-templates/puppet/manifests/overcloud_controller.pp:      eqlx_pool           => hiera('cinder::backend::eqlx::eqlx_lpool', undef),
Comment 11 Rajini Ram 2016-02-08 11:26:25 EST
Posted a patch https://review.openstack.org/#/c/277470/
Comment 12 Rajini Ram 2016-02-11 14:49:12 EST
Mitaka 
1.	Equal Logic
a.	https://review.openstack.org/#/c/242640/ - Merged
b.	https://review.openstack.org/#/c/277470/ -  Merged


Stable/Liberty – Cherry picks
1.	Equal Logic
a.	https://review.openstack.org/#/c/264871/1 - Merged
b.	https://review.openstack.org/#/c/278990/1 - Pending Merge
Comment 13 Rajini Ram 2016-02-23 16:13:44 EST
Everything merged. Ready to be included into Beta OSP
Comment 15 Rajini Ram 2016-03-03 10:00:36 EST
Verified to be working, with a minor bug ( has workaround)

https://bugzilla.redhat.com/show_bug.cgi?id=1314073
Comment 16 Rajini Ram 2016-03-03 10:00:54 EST
Tested on OSP Beta7
Comment 18 errata-xmlrpc 2016-04-07 17:40:28 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHEA-2016-0604.html

Note You need to log in before you can comment on or make changes to this bug.