Bug 1280005 - RFE: EQL: Update tripleo-heat-template to support multiple EQL arrays
RFE: EQL: Update tripleo-heat-template to support multiple EQL arrays
Status: CLOSED DUPLICATE of bug 1269990
Product: Red Hat OpenStack
Classification: Red Hat
Component: rhosp-director (Show other bugs)
8.0 (Liberty)
Unspecified Unspecified
unspecified Severity unspecified
: ---
: 8.0 (Liberty)
Assigned To: Angus Thomas
yeylon@redhat.com
: FutureFeature, OtherQA, Triaged
Depends On: 1266219
Blocks: 1261979 1266220
  Show dependency treegraph
 
Reported: 2015-11-10 12:16 EST by Rajini Karthik
Modified: 2016-04-18 03:12 EDT (History)
16 users (show)

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of: 1266219
Environment:
Last Closed: 2016-03-04 09:56:51 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Rajini Karthik 2015-11-10 12:16:14 EST
Description of problem:
The cinder backend should support mutiple sections of EQL arrays

Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.

Actual results:


Expected results:


Additional info:
Comment 4 Mike Orazi 2016-02-17 14:35:33 EST
Is this different than:  https://bugzilla.redhat.com/show_bug.cgi?id=1269990 ?
Comment 5 arkady kanevsky 2016-02-17 23:32:23 EST
Yes they are different.
This one is to support multiple EQL arrays for a single deployment.
The https://bugzilla.redhat.com/show_bug.cgi?id=1269990 is for support multiple different backends (EQL, CMPL, Ceph, NFS) for a single deployment.
Two are orthogonal. In reality we want support for heterogeneous back ends and with multiple instances of arrays of some types, like EQL. 
Do not know if we have the requirement for multiple CMPL or multiple Cephs in a single deployment. Till we know, only requesting multiple EQL support.
By the way this is supported functionality for JS-3x and 4x.

Providing answer for Rajini's request
Comment 6 arkady kanevsky 2016-02-17 23:32:35 EST
Yes they are different.
This one is to support multiple EQL arrays for a single deployment.
The https://bugzilla.redhat.com/show_bug.cgi?id=1269990 is for support multiple different backends (EQL, CMPL, Ceph, NFS) for a single deployment.
Two are orthogonal. In reality we want support for heterogeneous back ends and with multiple instances of arrays of some types, like EQL. 
Do not know if we have the requirement for multiple CMPL or multiple Cephs in a single deployment. Till we know, only requesting multiple EQL support.
By the way this is supported functionality for JS-3x and 4x.

Providing answer for Rajini's request
Comment 7 Kyle Bader 2016-02-17 23:36:08 EST
We probably do want to support multiple cinder backends for Ceph as well, so customers can have different Volume Types associated with pools that take root at branch of a CRUSH hierarchy (eg. Spinning, Dense SSD, Fast SSD). Should I open another RFE?
Comment 8 Mike Burns 2016-03-04 09:56:51 EST
Bug 1269990 is a generic "support multiple instances of any backend type".  The fix there will resolve this bug as well.

*** This bug has been marked as a duplicate of bug 1269990 ***

Note You need to log in before you can comment on or make changes to this bug.