Bug 1266220 - RFE: CMPL: tripleo-heat-template
RFE: CMPL: tripleo-heat-template
Status: CLOSED ERRATA
Product: Red Hat OpenStack
Classification: Red Hat
Component: openstack-tripleo-heat-templates (Show other bugs)
8.0 (Liberty)
Unspecified Unspecified
urgent Severity unspecified
: ga
: 8.0 (Liberty)
Assigned To: Mike Burns
yeylon@redhat.com
: FutureFeature, OtherQA, Triaged
Depends On: 1266219 1269990 1280005 1334519 1339836
Blocks: 1261979 1310828
  Show dependency treegraph
 
Reported: 2015-09-24 15:51 EDT by Rajini Karthik
Modified: 2016-05-25 19:49 EDT (History)
19 users (show)

See Also:
Fixed In Version: openstack-tripleo-heat-templates-0.8.8-1.el7ost
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of: 1266219
Environment:
Last Closed: 2016-04-07 17:40:48 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
OpenStack gerrit 264872 None None None 2016-02-11 15:48 EST
OpenStack gerrit 277888 None None None 2016-02-11 15:49 EST

  None (edit)
Description Rajini Karthik 2015-09-24 15:51:16 EDT
Description of problem:
An example of enabling an alternative cinder backend that was accepted upstream [1] in the hopes that this gives you a starting point for integration of EQL & Comp drivers.
[1] https://review.openstack.org/#/c/187700/

Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.

Actual results:


Expected results:


Additional info:
Comment 1 Rajini Karthik 2015-11-13 18:08:03 EST
Change review submitted https://review.openstack.org/#/c/244923/
Please vote/review/merge...
Comment 2 Rajini Karthik 2016-01-21 14:21:24 EST
Looks like they are not yet available in the osp8(beta3) builds we are receiving. 

Eql and cmpl templates under the folder in the director are missing /../openstack-tripleo-heat-templates/puppet/extraconfig/pre_deploy

1.	These have been cherry picked for liberty but not yet merged. Is that why?
https://review.openstack.org/#/c/264872/
https://review.openstack.org/#/c/264871/
2.	Now that we don’t have a foreman UI or director UI, can you give us some information on how to deploy/configure cinder using these templates?
Comment 3 Mike Burns 2016-01-21 15:28:18 EST
The problem with the patches missing is actually a broken build.  The patches were in the right place and the spec file said the right things, but the build process didn't actually apply the patches.  I'm working on resolving this now.  

This problem will go away when they merge into stable/liberty and we rebase on that.
Comment 4 Rajini Karthik 2016-02-03 11:49:55 EST
Still don't see it in Beta -5 build
Comment 5 Mike Burns 2016-02-03 11:54:42 EST
Beta 5 did not include any updates to director builds.
Comment 6 Rajini Karthik 2016-02-09 11:15:50 EST
I have a new review that will be needed for this feature to work
 https://review.openstack.org/277888
Comment 7 Rajini Karthik 2016-02-11 14:49:50 EST
Mitaka 

1.	Storage Center
a.	https://review.openstack.org/#/c/244923/ -  Merged
b.	https://review.openstack.org/#/c/277888/ -  Pending Merge

Stable/Liberty – Cherry picks
1.	Storage Center
a.	https://review.openstack.org/#/c/264872/ - Pending Merge
b.	https://review.openstack.org/#/c/277888/ - Pending Cherry pick to liberty
Comment 8 Rajini Karthik 2016-02-23 16:12:34 EST
Mitaka and Liberty merged.
Comment 9 Rajini Karthik 2016-02-23 16:12:56 EST
Please include in next Beta Build
Comment 12 errata-xmlrpc 2016-04-07 17:40:48 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHEA-2016-0604.html

Note You need to log in before you can comment on or make changes to this bug.