Bug 1269953 - Console Client Resources page - cannot scroll
Console Client Resources page - cannot scroll
Status: CLOSED ERRATA
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: rhevm-branding-rhev (Show other bugs)
3.6.0
x86_64 Windows
medium Severity medium
: ovirt-4.0.0-alpha
: 4.0.0
Assigned To: Alexander Wels
Pavel Novotny
:
Depends On:
Blocks: 1308577
  Show dependency treegraph
 
Reported: 2015-10-08 10:51 EDT by Andrei Stepanov
Modified: 2016-08-23 17:13 EDT (History)
12 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-08-23 17:13:32 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: UX
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
"Console Client Resources" page screenshot. (128.97 KB, image/jpeg)
2016-02-01 07:42 EST, Andrei Stepanov
no flags Details


External Trackers
Tracker ID Priority Status Summary Last Updated
oVirt gerrit 54562 master MERGED engine: fix login-pf abuse 2016-03-10 13:18 EST

  None (edit)
Description Andrei Stepanov 2015-10-08 10:51:52 EDT
* Go to "Administration portal"
* Select VM
* Right click -> Console options
* Click link "Console Client Resources" 
* Should appear new window with useful information.

User cannot scroll page in appeared above window.
As a result, user cannot read provided information or download clients.

Client is : IE11
Comment 1 Red Hat Bugzilla Rules Engine 2015-11-30 17:37:34 EST
Bug tickets must have version flags set prior to targeting them to a release. Please ask maintainer to set the correct version flags and only then set the target milestone.
Comment 2 Martin Betak 2015-12-02 07:27:15 EST
After discussion with Vojtech, this seems to be a PatternFly related CSS issue. Switching whiteboard to UX.
Comment 3 vszocs 2015-12-07 12:00:07 EST
(In reply to Martin Betak from comment #2)
> After discussion with Vojtech, this seems to be a PatternFly related CSS
> issue. Switching whiteboard to UX.

As discussed, the "Console Client Resources" page seems to use the same styling as SSO interactive login page [1] so I'd say it's not an issue of PatternFly CSS itself but our usage of it.

[1] backend/manager/modules/enginesso/src/main/webapp/WEB-INF/login.jsp
Comment 4 Andrei Stepanov 2016-02-01 07:42 EST
Created attachment 1120093 [details]
"Console Client Resources" page screenshot.

Version 3.6.2.5-0.1.el6
The bug is still persist. See attached screenshot. User cannot scroll "Console Client Resources" page.
Comment 5 Andrei Stepanov 2016-02-01 07:47:34 EST
"Console Client Resources" page holds essential tools that are quite important for client side. Users are not able to download them due this bug.
Comment 6 Alexander Wels 2016-02-15 09:41:41 EST
The welcome page has the same issue as well, its just not as noticeable due to the narrow nature of the links.
Comment 8 Alexander Wels 2016-03-02 16:13:40 EST
The example patternfly login page [1] actually has the exact same issue. If you make that one smaller you will notice no scroll bar will appear either. The problem is the absolute position in combination with the 'bottom: 13%' forcing the 'darker' area to be positioned 13% above the bottom.

The solution would be not the use the darker area pattern like we do in all the pages. That would be a UX issue to decide on how to solve this. We could make it not use the darker area and be a simple container instead of a 'login-pf container'


[1] https://rawgit.com/patternfly/patternfly/master/tests/login.html
Comment 9 Pavel Novotny 2016-06-17 12:47:08 EDT
Verified in rhevm-4.0.0.5-0.1.el7ev.noarch (build 4.0.0-17).

Console Client Resources page now offers scrollbars
in case the content does not fit the browser window.
Comment 11 errata-xmlrpc 2016-08-23 17:13:32 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2016-1687.html

Note You need to log in before you can comment on or make changes to this bug.