Bug 1270706 - [DOC][CSAT] Virt-who description is wrong
[DOC][CSAT] Virt-who description is wrong
Status: CLOSED CURRENTRELEASE
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: doc-Virtualization_Deployment_and_Administration_Guide (Show other bugs)
7.2
Unspecified Unspecified
medium Severity unspecified
: rc
: ---
Assigned To: Jiri Herrmann
: Documentation
: 1285599 (view as bug list)
Depends On: 1219074 1219084 1270707
Blocks: 1219080 1286552 1289999 1297764
  Show dependency treegraph
 
Reported: 2015-10-12 04:29 EDT by Laura Novich
Modified: 2016-11-08 12:26 EST (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: 1219084
: 1289999 (view as bug list)
Environment:
Last Closed: 2016-11-08 12:26:51 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Comment 2 Laura Novich 2015-11-15 10:59:48 EST
Hello,
Can you please look at the following section and let me know if anything is incorrect?

http://jenkinscat.gsslab.pnq.redhat.com:8080/job/doc-Red_Hat_Enterprise_Linux-7-Virtualization_Deployment_and_Administration_Guide%20%28html-single%29/lastStableBuild/artifact/tmp/en-US/html-single/index.html#reg-virt-machine

Thank you
Laura Novich
Comment 3 Radek Novacek 2015-11-16 02:23:03 EST
Laura, it looks good from virt-who perspective, but I'm not familiar with subscription-manager that well. It would be better if someone from Satellite6 team recheck it. Chris, can you take a look?
Comment 4 Chris Snyder 2015-11-17 15:49:17 EST
On the step "Create a virt-who configuration file", there should be an opening bracket ('[') in front of "libvirt]".

Everything looks good as far as subscription-manager goes.
Comment 5 Chris Snyder 2015-11-17 17:03:25 EST
It might be worth mentioning somewhere in there that running subscription-manager remove --all followed by subscription-manager attach --auto will not necessarily result in attaching to the same pools (the ones that were removed).
Comment 11 Laura Novich 2015-11-30 03:01:07 EST
add to this BZ1285599
Comment 12 Laura Novich 2015-11-30 03:01:54 EST
*** Bug 1285599 has been marked as a duplicate of this bug. ***
Comment 22 Chris Snyder 2015-12-17 18:22:19 EST
To list available subscriptions for system type virtual:
`subscription-manager list --avail --match-installed | grep 'Virtual' -B12'

The subscriptions listed here are those that match the installed products, are available, and are for virtual systems only.

Choose from those listed and attach using the pool id:
`subscription-manager attach --<POOL_ID_HERE>`
Comment 23 Laura Novich 2015-12-20 03:21:35 EST
Chris can you supply me with some sample output?
Laura
Comment 24 Chris Snyder 2016-01-04 17:28:23 EST
Output for the first command:
"
Subscription Name: Red Hat Enterprise Linux ES (Basic for Virtualization)
Provides:          Red Hat Beta
                   Oracle Java (for RHEL Server)
                   Red Hat Enterprise Linux Server
SKU:               -------
Pool ID:           ------------------------------
Available:         40
Suggested:         1
Service Level:     Basic
Service Type:      L1-L3
Multi-Entitlement: No
Ends:              01/02/2017
System Type:       Virtual
"

I have removed the SKU number and the Pool ID from the above output.

Output for the second command:
"
Successfully attached a subscription for: Red Hat Enterprise Linux ES (Basic for Virtualization)
"
Comment 25 Laura Novich 2016-01-11 03:34:13 EST
Excellent! Thank you Chris!
Comment 29 Laura Novich 2016-01-11 10:52:33 EST
With all changes requested made and all content now verified, changing status to verified. This content will be republished by the end of the month.
Laura

Note You need to log in before you can comment on or make changes to this bug.