Bug 1272137 - Can't view bug with malformed UTF8 in comments
Can't view bug with malformed UTF8 in comments
Status: CLOSED CURRENTRELEASE
Product: Bugzilla
Classification: Community
Component: User Interface (Show other bugs)
4.4
Unspecified Unspecified
urgent Severity urgent (vote)
: ---
: ---
Assigned To: Jeff Fearn
Rony Gong
:
: 1272133 1272685 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-10-15 10:39 EDT by James Boyle
Modified: 2015-12-04 00:19 EST (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-10-21 02:27:25 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
virt-manager.log that has the offending product string (3.10 KB, text/plain)
2015-10-15 10:40 EDT, James Boyle
no flags Details

  None (edit)
Description James Boyle 2015-10-15 10:39:33 EDT
Description of problem:
I was trying to submit a bug related to libvirt and virt-manager.  A USB KVM device our company uses has a product description with malformed UTF characters.  When pasting the virt-manager.log output, which contains the offending string, bugzilla also crashes (500 Internal Server Error).

Version-Release number of selected component (if applicable):
The current version of bugzilla in use by RedHat


How reproducible:
100%

Steps to Reproduce:
1.  Include the USB product description from the attached file.  click submit.  

Actual results:
500 Internal Server Error.  Could not submit bug with the offending text in the Description field.

Expected results:
Should be able to submit the bug


Additional info:
see bugs 1272125 and 1272121
Comment 1 James Boyle 2015-10-15 10:40 EDT
Created attachment 1083297 [details]
virt-manager.log that has the offending product string

i think this bug may have forked into two like my previous failed submission attempt.  Neat-o.
Comment 2 Rony Gong 2015-10-15 21:39:32 EDT
This bug also exist in upstream 5.0 and also exist in Bugzill which based on mysql.

undef error - Malformed UTF-8 character (fatal) at /var/www/html/bugzilla/Bugzilla/Util.pm line 81.
Comment 5 Jeff Fearn 2015-10-18 21:06:25 EDT
The bug gets submitted, it can't be viewed though.
Comment 6 Jeff Fearn 2015-10-18 23:25:46 EDT
*** Bug 1272685 has been marked as a duplicate of this bug. ***
Comment 9 Muhammad Tahir 2015-10-21 02:25:17 EDT
*** Bug 1272133 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.