Bug 1272572 - Error: Unable to retrieve volume limit information when accessing System Defaults in Horizon
Error: Unable to retrieve volume limit information when accessing System Defa...
Status: CLOSED ERRATA
Product: Red Hat OpenStack
Classification: Red Hat
Component: openstack-cinder (Show other bugs)
8.0 (Liberty)
Unspecified Unspecified
urgent Severity high
: ga
: 8.0 (Liberty)
Assigned To: Eric Harney
nlevinki
: TestOnly, Triaged
: 1282253 1282776 (view as bug list)
Depends On:
Blocks: 1261979 1282253 1290415 1310828
  Show dependency treegraph
 
Reported: 2015-10-16 15:07 EDT by Marius Cornea
Modified: 2016-04-26 17:43 EDT (History)
30 users (show)

See Also:
Fixed In Version: python-cinder-7.0.1-6.el7ost.noarch
Doc Type: Bug Fix
Doc Text:
Previously, a bug in the Block Storage component caused it to be incompatible with the Identity API v2 when working with quotas, resulting in failures when managing information on quotas in Block Storage. With this update, Block Storage has now been updated to be compatible with the Identity API v2, and the dashboard can now correctly retrieve information on volume quotas.
Story Points: ---
Clone Of:
: 1282253 1290415 (view as bug list)
Environment:
Last Closed: 2016-04-07 17:10:52 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
OpenStack gerrit 239109 None None None Never

  None (edit)
Description Marius Cornea 2015-10-16 15:07:02 EDT
Description of problem:
When going to System->Defaults in Horizon an 'Error: Unable to retrieve volume limit information.' shows up. 
Cinder logs show the following:
2015-10-16 19:00:05.262 25704 ERROR cinder.api.middleware.fault [req-79120e7c-360e-4694-a132-e409c4edc2cb 81711f9c9eb24da292ed59647041c422 741b6051f5064e17a3418be64e6a3fcd - - -] Caught error: Authorization failed: Unable to establish connection to http://localhost:5000/v3/auth/tokens
 

Version-Release number of selected component (if applicable):
openstack-dashboard-8.0.0.0-rc1.el7.centos.noarch
python-django-horizon-8.0.0.0-rc1.el7.centos.noarch

How reproducible:
100%

Steps to Reproduce:
1. Deploy one controller + one compute overcloud
2. Log in to Horizon
3. Go to System->Defaults

Actual results:
Error: Unable to retrieve volume limit information.

Expected results:
No error gets returned.
Comment 1 AliRezaTaleghani 2015-10-18 06:00:01 EDT
I think I figure this out:

file: /usr/lib/python2.7/site-packages/cinder/keymgr/key_mgr.py
Line: 27


The default param on cinder key manager which was:
FROM :=> default='http://localhost:5000/v3',
TO:   => default='http://10.20.30.26:5000/v3',
and that was all....

but it's the default library value I thinks, and it should be possible to be overwrite on some configuration files i hope... (ex: /etc/cinder/api-paste.ini)
Comment 2 Dan Radez 2015-10-23 15:33:24 EDT
I added:

[keymgr]
encryption_auth_url=http://192.0.2.6:5000/v3

to the end of /etc/cinder/cinder.conf and bounced the cinder-api service

This resolved the issue for me.
Comment 4 Jaromir Coufal 2016-01-27 05:42:54 EST
*** Bug 1282253 has been marked as a duplicate of this bug. ***
Comment 5 Jaromir Coufal 2016-01-27 05:42:57 EST
*** Bug 1282776 has been marked as a duplicate of this bug. ***
Comment 6 Jaromir Coufal 2016-01-27 05:45:41 EST
Can we backport the fix to OSP-d 8 (if not part of rebase)?
Comment 7 cappetta 2016-01-31 10:39:30 EST
I'm seeing this same error and tried Dan's suggestion yet it yeilded no improvement.  In the cinder api logs I am seeing the following msgs generated as a result:


2016-01-31 10:38:23.698 26454 INFO cinder.api.openstack.wsgi [req-9a19f330-5695-43dd-9441-2049673494a0 c90fb9dad30e4fc2aad0fd634f0a683e cd6612229b15486f9fa43051310178dc - - -] GET http://192.168.1.55:8776/v2/cd6612229b15486f9fa43051310178dc/os-quota-sets/cd6612229b15486f9fa43051310178dc?usage=False


2016-01-31 10:38:23.700 26454 ERROR cinder.api.middleware.fault [req-9a19f330-5695-43dd-9441-2049673494a0 c90fb9dad30e4fc2aad0fd634f0a683e cd6612229b15486f9fa43051310178dc - - -] Caught error: Not enough information to determine URL. Provide either auth_url or endpoint


2016-01-31 10:38:23.701 26454 INFO cinder.api.middleware.fault [req-9a19f330-5695-43dd-9441-2049673494a0 c90fb9dad30e4fc2aad0fd634f0a683e cd6612229b15486f9fa43051310178dc - - -] http://192.168.1.55:8776/v2/cd6612229b15486f9fa43051310178dc/os-quota-sets/cd6612229b15486f9fa43051310178dc?usage=False returned with HTTP 500


2016-01-31 10:38:23.702 26454 INFO eventlet.wsgi.server [req-9a19f330-5695-43dd-9441-2049673494a0 c90fb9dad30e4fc2aad0fd634f0a683e cd6612229b15486f9fa43051310178dc - - -] 192.168.1.55 - - [31/Jan/2016 10:38:23] "GET /v2/cd6612229b15486f9fa43051310178dc/os-quota-sets/cd6612229b15486f9fa43051310178dc?usage=False HTTP/1.1" 500 425 0.425243
Comment 8 cappetta 2016-01-31 10:51:10 EST
(In reply to cappetta from comment #7)
> I'm seeing this same error and tried Dan's suggestion yet it yeilded no
> improvement.  In the cinder api logs I am seeing the following msgs
> generated as a result:
> 
> 
> 2016-01-31 10:38:23.698 26454 INFO cinder.api.openstack.wsgi
> [req-9a19f330-5695-43dd-9441-2049673494a0 c90fb9dad30e4fc2aad0fd634f0a683e
> cd6612229b15486f9fa43051310178dc - - -] GET
> http://192.168.1.55:8776/v2/cd6612229b15486f9fa43051310178dc/os-quota-sets/
> cd6612229b15486f9fa43051310178dc?usage=False
> 
> 
> 2016-01-31 10:38:23.700 26454 ERROR cinder.api.middleware.fault
> [req-9a19f330-5695-43dd-9441-2049673494a0 c90fb9dad30e4fc2aad0fd634f0a683e
> cd6612229b15486f9fa43051310178dc - - -] Caught error: Not enough information
> to determine URL. Provide either auth_url or endpoint
> 
> 
> 2016-01-31 10:38:23.701 26454 INFO cinder.api.middleware.fault
> [req-9a19f330-5695-43dd-9441-2049673494a0 c90fb9dad30e4fc2aad0fd634f0a683e
> cd6612229b15486f9fa43051310178dc - - -]
> http://192.168.1.55:8776/v2/cd6612229b15486f9fa43051310178dc/os-quota-sets/
> cd6612229b15486f9fa43051310178dc?usage=False returned with HTTP 500
> 
> 
> 2016-01-31 10:38:23.702 26454 INFO eventlet.wsgi.server
> [req-9a19f330-5695-43dd-9441-2049673494a0 c90fb9dad30e4fc2aad0fd634f0a683e
> cd6612229b15486f9fa43051310178dc - - -] 192.168.1.55 - - [31/Jan/2016
> 10:38:23] "GET
> /v2/cd6612229b15486f9fa43051310178dc/os-quota-sets/
> cd6612229b15486f9fa43051310178dc?usage=False HTTP/1.1" 500 425 0.425243

Initial tests of the the config solution from bcollins appears to fix the issue.  Testing...

https://ask.openstack.org/en/question/87045/error-unable-to-retrieve-volume-limit-information/

[quote]

Add this to your cinder.conf under the keystone_auth 
[keystone_authtoken] auth_uri = http://keystone_ip:5000 
auth_url = http://keystone_ip:35357 
auth_plugin = password 
project_domain_id = default 
user_domain_id = default 
project_name = services 
username = cinder 
password = [cinder password]
[/quote]
Comment 9 Marius Cornea 2016-01-31 11:03:25 EST
(In reply to cappetta from comment #8)
> (In reply to cappetta from comment #7)
> > I'm seeing this same error and tried Dan's suggestion yet it yeilded no
> > improvement.  In the cinder api logs I am seeing the following msgs
> > generated as a result:
> > 
> > 
> > 2016-01-31 10:38:23.698 26454 INFO cinder.api.openstack.wsgi
> > [req-9a19f330-5695-43dd-9441-2049673494a0 c90fb9dad30e4fc2aad0fd634f0a683e
> > cd6612229b15486f9fa43051310178dc - - -] GET
> > http://192.168.1.55:8776/v2/cd6612229b15486f9fa43051310178dc/os-quota-sets/
> > cd6612229b15486f9fa43051310178dc?usage=False
> > 
> > 
> > 2016-01-31 10:38:23.700 26454 ERROR cinder.api.middleware.fault
> > [req-9a19f330-5695-43dd-9441-2049673494a0 c90fb9dad30e4fc2aad0fd634f0a683e
> > cd6612229b15486f9fa43051310178dc - - -] Caught error: Not enough information
> > to determine URL. Provide either auth_url or endpoint
> > 
> > 
> > 2016-01-31 10:38:23.701 26454 INFO cinder.api.middleware.fault
> > [req-9a19f330-5695-43dd-9441-2049673494a0 c90fb9dad30e4fc2aad0fd634f0a683e
> > cd6612229b15486f9fa43051310178dc - - -]
> > http://192.168.1.55:8776/v2/cd6612229b15486f9fa43051310178dc/os-quota-sets/
> > cd6612229b15486f9fa43051310178dc?usage=False returned with HTTP 500
> > 
> > 
> > 2016-01-31 10:38:23.702 26454 INFO eventlet.wsgi.server
> > [req-9a19f330-5695-43dd-9441-2049673494a0 c90fb9dad30e4fc2aad0fd634f0a683e
> > cd6612229b15486f9fa43051310178dc - - -] 192.168.1.55 - - [31/Jan/2016
> > 10:38:23] "GET
> > /v2/cd6612229b15486f9fa43051310178dc/os-quota-sets/
> > cd6612229b15486f9fa43051310178dc?usage=False HTTP/1.1" 500 425 0.425243
> 
> Initial tests of the the config solution from bcollins appears to fix the
> issue.  Testing...
> 
> https://ask.openstack.org/en/question/87045/error-unable-to-retrieve-volume-
> limit-information/
> 
> [quote]
> 
> Add this to your cinder.conf under the keystone_auth 
> [keystone_authtoken] auth_uri = http://keystone_ip:5000 
> auth_url = http://keystone_ip:35357 
> auth_plugin = password 
> project_domain_id = default 
> user_domain_id = default 
> project_name = services 
> username = cinder 
> password = [cinder password]
> [/quote]

Hello,

What installer did you use for the deployment? Thanks
Comment 10 cappetta 2016-01-31 12:58:56 EST
(In reply to Marius Cornea from comment #9)
> (In reply to cappetta from comment #8)
> > (In reply to cappetta from comment #7)
> > > I'm seeing this same error and tried Dan's suggestion yet it yeilded no
> > > improvement.  In the cinder api logs I am seeing the following msgs
> > > generated as a result:
> > > 
> > > 
> > > 2016-01-31 10:38:23.698 26454 INFO cinder.api.openstack.wsgi
> > > [req-9a19f330-5695-43dd-9441-2049673494a0 c90fb9dad30e4fc2aad0fd634f0a683e
> > > cd6612229b15486f9fa43051310178dc - - -] GET
> > > http://192.168.1.55:8776/v2/cd6612229b15486f9fa43051310178dc/os-quota-sets/
> > > cd6612229b15486f9fa43051310178dc?usage=False
> > > 
> > > 
> > > 2016-01-31 10:38:23.700 26454 ERROR cinder.api.middleware.fault
> > > [req-9a19f330-5695-43dd-9441-2049673494a0 c90fb9dad30e4fc2aad0fd634f0a683e
> > > cd6612229b15486f9fa43051310178dc - - -] Caught error: Not enough information
> > > to determine URL. Provide either auth_url or endpoint
> > > 
> > > 
> > > 2016-01-31 10:38:23.701 26454 INFO cinder.api.middleware.fault
> > > [req-9a19f330-5695-43dd-9441-2049673494a0 c90fb9dad30e4fc2aad0fd634f0a683e
> > > cd6612229b15486f9fa43051310178dc - - -]
> > > http://192.168.1.55:8776/v2/cd6612229b15486f9fa43051310178dc/os-quota-sets/
> > > cd6612229b15486f9fa43051310178dc?usage=False returned with HTTP 500
> > > 
> > > 
> > > 2016-01-31 10:38:23.702 26454 INFO eventlet.wsgi.server
> > > [req-9a19f330-5695-43dd-9441-2049673494a0 c90fb9dad30e4fc2aad0fd634f0a683e
> > > cd6612229b15486f9fa43051310178dc - - -] 192.168.1.55 - - [31/Jan/2016
> > > 10:38:23] "GET
> > > /v2/cd6612229b15486f9fa43051310178dc/os-quota-sets/
> > > cd6612229b15486f9fa43051310178dc?usage=False HTTP/1.1" 500 425 0.425243
> > 
> > Initial tests of the the config solution from bcollins appears to fix the
> > issue.  Testing...
> > 
> > https://ask.openstack.org/en/question/87045/error-unable-to-retrieve-volume-
> > limit-information/
> > 
> > [quote]
> > 
> > Add this to your cinder.conf under the keystone_auth 
> > [keystone_authtoken] auth_uri = http://keystone_ip:5000 
> > auth_url = http://keystone_ip:35357 
> > auth_plugin = password 
> > project_domain_id = default 
> > user_domain_id = default 
> > project_name = services 
> > username = cinder 
> > password = [cinder password]
> > [/quote]
> 
> Hello,
> 
> What installer did you use for the deployment? Thanks

Packstack installer on CentOS-7.  Fresh install completed 24hrs ago using the generic all-in-one option
Comment 11 Marius Cornea 2016-01-31 13:12:20 EST
Please check BZ#1290415, the issue you are seeing is different than the initial report in this one.
Comment 12 Chris Dearborn 2016-02-03 16:14:13 EST
We're hitting this too.  Seen in OSP 8 Beta 4 & 5.  The workaround listed above of adding the additional config parameter to cinder.conf does seem to work.
Comment 13 Javier Peña 2016-02-23 07:32:06 EST
Maybe https://bugzilla.redhat.com/show_bug.cgi?id=1290415#c2 can be of help here. The latest stable/liberty packages from Delorean for Cinder fixed the issue in RDO.
Comment 14 Mike Burns 2016-02-26 13:52:57 EST
The belief is that this is fixed in the latest cinder packages (7.0.1-6 or later).
Comment 15 cappetta 2016-02-26 16:33:33 EST
@Mike -- good to know; I've performed a fresh install on 2/20 and see RDO packstack is installing cinder v7.0.1-1.  Just wanted to highlight the install is using an older package & there might be an repo/package update dependency.
Comment 16 Ido Ovadia 2016-03-10 11:34:26 EST
Verified
========
python-cinder-7.0.1-6.el7ost.noarch
Comment 17 John Trowbridge 2016-03-31 09:36:10 EDT
This was actually a Cinder bug resolved by:
https://github.com/openstack/cinder/commit/bd3b972e72bb17b0a0f08f972a7bcdb39c6dd35f
Comment 20 errata-xmlrpc 2016-04-07 17:10:52 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHEA-2016-0603.html

Note You need to log in before you can comment on or make changes to this bug.