Bug 1282776 - In OSP 8 when opening the network topology in horizon you get Error: Unable to retrieve volume limit information.
Summary: In OSP 8 when opening the network topology in horizon you get Error: Unable t...
Keywords:
Status: CLOSED DUPLICATE of bug 1272572
Alias: None
Product: Red Hat OpenStack
Classification: Red Hat
Component: rhosp-director
Version: 8.0 (Liberty)
Hardware: Unspecified
OS: Unspecified
urgent
high
Target Milestone: ga
: 8.0 (Liberty)
Assignee: chris alfonso
QA Contact: yeylon@redhat.com
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2015-11-17 11:42 UTC by Udi
Modified: 2016-04-18 07:13 UTC (History)
10 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2016-01-27 10:42:57 UTC
Target Upstream Version:


Attachments (Terms of Use)

Description Udi 2015-11-17 11:42:05 UTC
Description of problem:
The network topology page shows an error: 
Error: Unable to retrieve volume limit information.


Version-Release number of selected component (if applicable):
python-django-horizon-8.0.0-1.el7ost.noarch


How reproducible:
100%


Steps to Reproduce:
1. Navigate to the network topology page

Comment 2 Udi 2015-11-17 11:52:41 UTC
I also get the same error when launching an instance

Comment 3 Matthias Runge 2015-11-17 11:53:49 UTC
how did you install?

Comment 4 Udi 2015-11-17 12:28:30 UTC
This is an HA deployment with network isolation. I didn't install it but I will be able to get you more details if you need.

Comment 5 Matthias Runge 2015-11-17 12:36:16 UTC
yes, I will need more details, as I haven't seen this behaviour, e.g. on my AIO install with RDO.
I think we had this issue with RHOS 7 and installs made by director already.

Do you have something like a stack-trace?

Comment 6 Ido Ovadia 2015-11-17 17:57:22 UTC
Could be relate to https://bugzilla.redhat.com/show_bug.cgi?id=1282253

Comment 7 Udi 2015-11-18 09:10:23 UTC
I see this in horizon.log:
2015-11-18 08:58:20,717 5183 WARNING horizon.exceptions Recoverable error: The server has either erred or is incapable of performing the requested operation. (HTTP 500) (Request-ID: req-b5f310e7-20bb-439c-8d13-cc3765250b77)

I don't see anything further in the httpd logs. This is a director installation of OSP 8 beta (I think there is no more packstack?).

Let me know where I might be able to find more logs if you need more info. The setup should be available for another day if you want access to it (contact me separately for details).

Comment 8 Matthias Runge 2015-11-18 10:32:36 UTC
Udi, 

Ido mentioned a cinder setup issue in https://bugzilla.redhat.com/show_bug.cgi?id=1282253, which could be related to this. 
Could you please check cinder logs?

Comment 9 Udi 2015-11-18 11:40:58 UTC
I can see the same error in the cinder log, as reported in bug 1282253. However, cinder is working despite the failure:

2015-11-18 04:49:24.079 17637 ERROR cinder.api.middleware.fault [req-8537daca-0f81-408c-842d-fa8e519266d7 7e0a816f34f946b989f0c7a0f53fd88e a34dc5a8154f422f850a11270a06ec2d - - -] Caught error: Authorization failed: Unable to establish connection to http://localhost:5000/v3/auth/tokens

Comment 10 Matthias Runge 2015-11-24 11:02:31 UTC
on the install, I querying for cinder quota, I'm getting the following:
[stack@undercloud72 ~]$ cinder quota-show af04585c344b442f820df9f88f9a4f90
ERROR: publicURL endpoint for volumev2 service not found

oops. That explains, why horizon reports this error.

af04585c344b442f820df9f88f9a4f90 is the demo tenant on that installation.

Comment 11 Matthias Runge 2015-11-26 14:56:44 UTC
I think this is an installer issue.

Comment 12 Udi 2016-01-25 17:37:39 UTC
Duplicate of https://bugzilla.redhat.com/show_bug.cgi?id=1272572

Comment 13 Jaromir Coufal 2016-01-27 10:42:57 UTC

*** This bug has been marked as a duplicate of bug 1272572 ***


Note You need to log in before you can comment on or make changes to this bug.