Bug 1272924 - Windows 10 Guest OS Support - UI
Windows 10 Guest OS Support - UI
Status: CLOSED CURRENTRELEASE
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: ovirt-engine (Show other bugs)
3.6.0
Unspecified Unspecified
high Severity medium
: ovirt-3.5.7
: 3.5.7
Assigned To: jniederm
Nisim Simsolo
virt
: FutureFeature, Tracking, ZStream
Depends On: 1232586 1277214 1278442 1288090
Blocks:
  Show dependency treegraph
 
Reported: 2015-10-19 04:49 EDT by rhev-integ
Modified: 2016-02-24 05:04 EST (History)
16 users (show)

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Feature: Windows 10 and Windows 10 x64 added to list of possible guest operating systems. Reason: Result:
Story Points: ---
Clone Of: 1232586
Environment:
Last Closed: 2016-01-18 08:36:10 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: Virt
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
oVirt gerrit 42492 master MERGED core: Windows 10 Guest OS Support - UI Never

  None (edit)
Comment 2 Nisim Simsolo 2015-10-21 06:57:18 EDT
Verified: 
rhevm-3.6.0.1-0.1.el6
vdsm-4.17.9-1.el7ev.noarch
sanlock-3.2.4-1.el7.x86_64
qemu-kvm-rhev-2.3.0-31.el7.x86_64
libvirt-client-1.2.17-5.el7.x86_64

Verification scenario: 
sysprep: 
1. Seal VM. 
2. Run once VM with [sysprep] floppy attached and set initial run sysprep configuration (hostname, organization name, timezone and costume locale).
   Verify VM is reflected with sysprep configuration.
3. Power off VM and rerun VM (not in run once mode).
   Verify sysprep configuration kept.

Icon: 
1. from webadmin > edit VM > icon tab, verify windows 10 icon is displayed by default.
2. Create user with supruser role and login to user portal.
   basic tab - Verify windows 10 icon displayed for windows 10 VM.
   Extended tab - Verify windows 10 icon displayed for windows 10 VM.

Test case added to Polarion (see external tracker).
Comment 3 Nisim Simsolo 2015-11-08 07:21:05 EST
please ignore https://bugzilla.redhat.com/show_bug.cgi?id=1272924#c2 (Verified by mistake instead of 3.6 corresponding bug).
Bug reassigning reason: VM OS type cannot be set on AMD architecture which is lower than Opteron_g5 (opteron_g4, opteron_g3, opteron_g5, opteron_g2, opteron_g1, penryn, nehalem, conroe).
Although Windows 10 VM can be run using "other" OS type configuration, this issue affect on guest agent, console protocol and OS repositories (values taken from engine osinfo.conf.d).
Related bug: https://bugzilla.redhat.com/show_bug.cgi?id=1278442
Comment 4 Michal Skrivanek 2015-11-09 04:03:45 EST
This change was intentional due to lack of testing on AMD. See bug 1277214 which would be ok to include in 3.5.z if the testing can be done in time
Comment 7 Nisim Simsolo 2015-12-23 07:13:41 EST
Verified: 
rhevm-3.5.7-0.1.el6ev
vdsm-4.16.31-1.el7ev.x86_64
libvirt-client-1.2.17-13.el7_2.2.x86_64
qemu-kvm-rhev-2.3.0-31.el7_2.5.x86_64
sanlock-3.2.4-1.el7.x86_64

RHEV-toolsSetup_3.5_11.iso

Verification scenario:
1. Create Windows 10 VM, select VM OS type Windows 10 x64
2. install VM from win10 ISO -> seal VM -> power off VM.
3. run VM with sysprep floppy and rhev tools CD (from run once).
4. install rhev tools and restart VM.
5. Verify rhev tools installed properly, verify VM reflected with sysprep configuration.
6. From user portal verify Windows 10 icon displayed from basic/extended view.
Comment 9 Eyal Edri 2016-01-18 08:36:10 EST
3.5.7 was released.

Note You need to log in before you can comment on or make changes to this bug.