Bug 1278442 - VM OS type cannot be set to windows 10 when using host with AMD CPUs.
VM OS type cannot be set to windows 10 when using host with AMD CPUs.
Status: CLOSED DUPLICATE of bug 1277214
Product: ovirt-engine
Classification: oVirt
Component: BLL.Virt (Show other bugs)
3.5.6.1
Unspecified Unspecified
unspecified Severity high (vote)
: ---
: ---
Assigned To: Michal Skrivanek
Nisim Simsolo
virt
:
Depends On:
Blocks: 1272924
  Show dependency treegraph
 
Reported: 2015-11-05 08:55 EST by Nisim Simsolo
Modified: 2015-11-09 02:58 EST (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-11-09 02:58:29 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
rule-engine: planning_ack?
rule-engine: devel_ack?
rule-engine: testing_ack?


Attachments (Terms of Use)
engine log (796.22 KB, text/plain)
2015-11-05 09:02 EST, Nisim Simsolo
no flags Details
vdsm log (13.72 MB, text/plain)
2015-11-05 09:03 EST, Nisim Simsolo
no flags Details
screenshot (211.80 KB, image/png)
2015-11-05 09:05 EST, Nisim Simsolo
no flags Details

  None (edit)
Description Nisim Simsolo 2015-11-05 08:55:31 EST
Description of problem:
- When using host with AMD architecture and setting VM OS to windows 10/windows 10 x64, the action rejected with "The guest OS doesn't support the following CPUs: opteron_g4, opteron_g3, opteron_g5, opteron_g2, opteron_g1, penryn, nehalem, conroe. Its possible to change the cluster cpu or set a different one per VM".
- It is possible to run same VM when using "other" OS type.
- Same action using Intel host is not rejected by the webadmin.

Version-Release number of selected component (if applicable):
rhevm-3.5.6.1-0.1.el6ev (vt18).
qemu-kvm-rhev-2.1.2-23.el7_1.10.x86_64
libvirt-client-1.2.8-16.el7_1.4.x86_64
vdsm-4.16.28-1.el7ev.x86_64
sanlock-3.2.2-2.el7.x86_64

How reproducible:
100%

Steps to Reproduce:
1. Create windows 10 VM.
2. Edit VM > from operating system dropbox, select windows 10.
3. Click OK.

Actual results:
Action rejected with error message: 
he guest OS doesn't support the following CPUs: opteron_g4, opteron_g3...
engine log:
2015-11-05 15:52:45,866 INFO  [org.ovirt.engine.core.bll.UpdateVmCommand] (ajp-/127.0.0.1:8702-11) [29ec214b] Lock Acquired to object EngineLock [exclusiveLocks= key: win10 value: VM_NAME
, sharedLocks= key: 4c7ee3c3-3d5c-4c89-b129-1599e930afc9 value: VM
]
2015-11-05 15:52:45,868 WARN  [org.ovirt.engine.core.bll.UpdateVmCommand] (ajp-/127.0.0.1:8702-11) [29ec214b] CanDoAction of action UpdateVm failed for user admin@internal. Reasons: VAR__ACTION__UPDATE,VAR__TYPE__VM,CPU_TYPE_UNSUPPORTED_FOR_THE_GUEST_OS,$unsupportedCpus opteron_g4, opteron_g3, opteron_g5, opteron_g2, opteron_g1, penryn, nehalem, conroe
2015-11-05 15:52:45,869 INFO  [org.ovirt.engine.core.bll.UpdateVmCommand] (ajp-/127.0.0.1:8702-11) [29ec214b] Lock freed to object EngineLock [exclusiveLocks= key: win10 value: VM_NAME
, sharedLocks= key: 4c7ee3c3-3d5c-4c89-b129-1599e930afc9 value: VM
]

Expected results:
Windows 10 OS type should be set on VM without exceptions.

Additional info:
Severity set to high because guest agent cannot be run on windows 10 VM when using AMD architecture.
vdsm, VM XML and engine logs attached.
Comment 1 Nisim Simsolo 2015-11-05 09:02 EST
Created attachment 1090092 [details]
engine log
Comment 2 Nisim Simsolo 2015-11-05 09:03 EST
Created attachment 1090093 [details]
vdsm log
Comment 3 Nisim Simsolo 2015-11-05 09:05 EST
Created attachment 1090095 [details]
screenshot
Comment 4 Nisim Simsolo 2015-11-05 09:56:03 EST
Host CPU model name: Quad-Core AMD Opteron(tm) Processor 2350 (AMD Third Generation Opteron family)
Comment 5 Michal Skrivanek 2015-11-09 02:58:29 EST

*** This bug has been marked as a duplicate of bug 1277214 ***

Note You need to log in before you can comment on or make changes to this bug.