Bug 1273378 - [hosted-engine-setup] [block storage] Cannot import the hosted-engine storage domain because its LUN is written in the engine DB as a direct LUN
[hosted-engine-setup] [block storage] Cannot import the hosted-engine storage...
Status: CLOSED CURRENTRELEASE
Product: ovirt-hosted-engine-setup
Classification: oVirt
Component: Plugins.Block (Show other bugs)
1.3.0
x86_64 Unspecified
urgent Severity urgent (vote)
: ovirt-3.6.1
: 1.3.1.2
Assigned To: Simone Tiraboschi
Elad
:
: 1273779 (view as bug list)
Depends On:
Blocks: 1153278 1158096 1269768 1284979 RHEV3.6Upgrade
  Show dependency treegraph
 
Reported: 2015-10-20 06:34 EDT by Elad
Modified: 2016-02-18 05:52 EST (History)
13 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
On hosted-engine with oVirt 3.5 we were adding the hosted-engine LUN as a fake direct LUN to let the engine know that it's already in use preventing the user to take any action on that because they can lead to the destruction of the engine itself. On hosted-engine with oVirt 3.6, the engine correctly attaches and manages the hosted-engine storage domain so that precaution is not needed anymore.
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-02-18 05:52:17 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: Integration
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
ylavi: ovirt‑3.6.z+
ylavi: blocker+
ylavi: planning_ack+
ykaul: devel_ack+
mavital: testing_ack+


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
oVirt gerrit 47508 master MERGED packaging: setup: avoid adding HE iSCSI/FC lun as direct LUN Never
oVirt gerrit 47662 ovirt-hosted-engine-setup-1.3 MERGED packaging: setup: avoid adding HE iSCSI/FC lun as direct LUN Never
oVirt gerrit 47706 master MERGED core: Allow to remove Hosted Engine direct lun disks only Never
oVirt gerrit 48241 master MERGED dal: Add get BaseDisk list by alias Never
oVirt gerrit 49353 ovirt-engine-3.6 MERGED dal: Add get BaseDisk list by alias Never
oVirt gerrit 49429 ovirt-engine-3.6 MERGED core: Allow to remove Hosted Engine direct lun disks only Never
oVirt gerrit 49439 master MERGED core: Extract interfaces by the right key Never
oVirt gerrit 49440 ovirt-engine-3.6 MERGED core: Extract interfaces by the right key Never
oVirt gerrit 49516 master MERGED core: Fix typo in audit log message Never
oVirt gerrit 49537 ovirt-engine-3.6 MERGED core: Fix typo in audit log message Never
oVirt gerrit 50075 ovirt-engine-3.6.1 MERGED dal: Add get BaseDisk list by alias Never
oVirt gerrit 50076 ovirt-engine-3.6.1 MERGED core: Allow to remove Hosted Engine direct lun disks only Never
oVirt gerrit 50080 ovirt-engine-3.6.1 MERGED core: Extract interfaces by the right key Never
oVirt gerrit 50081 ovirt-engine-3.6.1 MERGED core: Fix typo in audit log message Never

  None (edit)
Description Elad 2015-10-20 06:34:21 EDT
Description of problem:
On block storage, hosted engine storage domain cannot be imported to the engine as part of the rhev3.6 requirement - https://bugzilla.redhat.com/show_bug.cgi?id=1269768.
It cannot be imported because of the code change introduced here: https://gerrit.ovirt.org/#/c/34783/ , which adds the LUN of the hosted-engine storage domain to the engine DB as a direct LUN.
This blocks us from having the HE VM shown and managed by the engine since its OVF cannot be imported.

Version-Release number of selected component (if applicable):
ovirt-hosted-engine-setup-1.3.0-1.el7ev.noarch
rhevm-3.6.0.1-0.1.el6.noarch

How reproducible:
Always

Steps to Reproduce:
1. Deploy hosted-engine over FC/iSCSI
2. Try to import the HE storage domain to the setup


Actual results:
The HE storage domain is not presented as an importable domain since its LUN is written in the engine DB as a direct LUN.

Expected results:
The hosted-engine storage domain should be importable
Comment 1 Simone Tiraboschi 2015-10-20 06:38:36 EDT
Patch http://gerrit.ovirt.org/47508 will handle it for new deployment.
We still have to manage to remove it for HE iSCSI storage domains created on 3.5 and upgraded to 3.6.
Comment 2 Yaniv Kaul 2015-10-20 09:33:16 EDT
(In reply to Simone Tiraboschi from comment #1)
> Patch http://gerrit.ovirt.org/47508 will handle it for new deployment.
> We still have to manage to remove it for HE iSCSI storage domains created on
> 3.5 and upgraded to 3.6.

I suggest opening a separate bug on the other issue (remove it for HE iSCSI storage domains created on 3.5 and upgraded to 3.6)
Comment 3 Sandro Bonazzola 2015-10-21 04:07:06 EDT
Dropping blocker and postponing to 3.6.1 since the auto import code is not in 3.6.0 GA build.
Comment 4 Red Hat Bugzilla Rules Engine 2015-10-21 04:07:13 EDT
This bug is not marked for z-stream, yet the milestone is for a z-stream version, therefore the milestone has been reset.
Please set the correct milestone or add the z-stream flag.
Comment 5 Elad 2015-10-21 07:00:41 EDT
(In reply to Yaniv Kaul from comment #2)
> (In reply to Simone Tiraboschi from comment #1)
> > Patch http://gerrit.ovirt.org/47508 will handle it for new deployment.
> > We still have to manage to remove it for HE iSCSI storage domains created on
> > 3.5 and upgraded to 3.6.
> 
> I suggest opening a separate bug on the other issue (remove it for HE iSCSI
> storage domains created on 3.5 and upgraded to 3.6)


https://bugzilla.redhat.com/show_bug.cgi?id=1273828
Comment 6 Roy Golan 2015-10-25 06:04:29 EDT
Should be an engine fix in the auto-import of SD to remove the direct lun disk if exist see Bug 1269768
Comment 7 Yaniv Lavi 2015-10-29 08:47:13 EDT
In oVirt testing is done on single release by default. Therefore I'm removing the 4.0 flag. If you think this bug must be tested in 4.0 as well, please re-add the flag. Please note we might not have testing resources to handle the 4.0 clone.
Comment 8 Roy Golan 2015-12-09 08:15:17 EST
*** Bug 1273779 has been marked as a duplicate of this bug. ***
Comment 9 Elad 2016-01-21 08:05:31 EST
HE SD LUN is not written in engine's DB anymore, which allows to import the HE SD to the setup.


Tested using:
Host:

ovirt-hosted-engine-ha-1.3.3.7-1.el7ev.noarch
libgovirt-0.3.3-1.el7_2.1.x86_64
ovirt-vmconsole-1.0.0-1.el7ev.noarch
ovirt-host-deploy-1.4.1-1.el7ev.noarch
ovirt-setup-lib-1.0.1-1.el7ev.noarch
ovirt-vmconsole-host-1.0.0-1.el7ev.noarch
ovirt-hosted-engine-setup-1.3.2.3-1.el7ev.noarch
vdsm-jsonrpc-4.17.18-0.el7ev.noarch
vdsm-python-4.17.18-0.el7ev.noarch
vdsm-hook-vmfex-dev-4.17.18-0.el7ev.noarch
vdsm-cli-4.17.18-0.el7ev.noarch
vdsm-yajsonrpc-4.17.18-0.el7ev.noarch
vdsm-xmlrpc-4.17.18-0.el7ev.noarch
vdsm-4.17.18-0.el7ev.noarch
vdsm-infra-4.17.18-0.el7ev.noarch


Engine:

ovirt-engine-extension-aaa-jdbc-1.0.5-1.el6ev.noarch
ovirt-host-deploy-1.4.1-1.el6ev.noarch
ovirt-vmconsole-1.0.0-1.el6ev.noarch
ovirt-host-deploy-java-1.4.1-1.el6ev.noarch
rhevm-setup-plugin-ovirt-engine-common-3.6.2.6-0.1.el6.noarch
ovirt-vmconsole-proxy-1.0.0-1.el6ev.noarch
rhevm-setup-plugin-ovirt-engine-3.6.2.6-0.1.el6.noarch
ovirt-setup-lib-1.0.1-1.el6ev.noarch
rhevm-setup-plugin-websocket-proxy-3.6.2.6-0.1.el6.noarch
rhevm-vmconsole-proxy-helper-3.6.2.6-0.1.el6.noarch
rhevm-spice-client-x86-msi-3.6-6.el6.noarch
rhevm-lib-3.6.2.6-0.1.el6.noarch
rhevm-cli-3.6.0.0-1.el6ev.noarch
rhevm-webadmin-portal-3.6.2.6-0.1.el6.noarch
rhevm-tools-3.6.2.6-0.1.el6.noarch
rhevm-iso-uploader-3.6.0-1.el6ev.noarch
rhevm-doc-3.6.0-2.el6eng.noarch
rhevm-backend-3.6.2.6-0.1.el6.noarch
rhevm-setup-3.6.2.6-0.1.el6.noarch
rhevm-spice-client-x64-cab-3.6-6.el6.noarch
rhevm-userportal-3.6.2.6-0.1.el6.noarch
rhevm-image-uploader-3.6.0-1.el6ev.noarch
rhevm-branding-rhev-3.6.0-3.el6ev.noarch
rhevm-sdk-python-3.6.2.1-1.el6ev.noarch
rhevm-log-collector-3.6.0-1.el6ev.noarch
rhevm-dependencies-3.6.0-1.el6ev.noarch
rhevm-setup-plugin-ovirt-engine-common-3.6.2.6-0.1.el6.noarch
rhevm-dbscripts-3.6.2.6-0.1.el6.noarch
rhevm-setup-plugins-3.6.1-2.el6ev.noarch
rhevm-spice-client-x64-msi-3.6-6.el6.noarch
rhevm-restapi-3.6.2.6-0.1.el6.noarch
rhevm-setup-plugin-ovirt-engine-3.6.2.6-0.1.el6.noarch
rhevm-3.6.2.6-0.1.el6.noarch
rhevm-setup-base-3.6.2.6-0.1.el6.noarch
rhevm-extensions-api-impl-3.6.2.6-0.1.el6.noarch
rhevm-websocket-proxy-3.6.2.6-0.1.el6.noarch
rhevm-setup-plugin-vmconsole-proxy-helper-3.6.2.6-0.1.el6.noarch
rhevm-spice-client-x86-cab-3.6-6.el6.noarch

Note You need to log in before you can comment on or make changes to this bug.