Bug 1274143 - Automatically engine setup failed on the rhevm-appliance during deploying HE on RHEV-H
Automatically engine setup failed on the rhevm-appliance during deploying HE ...
Status: CLOSED ERRATA
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: rhevm-appliance (Show other bugs)
3.6.0
Unspecified Unspecified
unspecified Severity urgent
: ovirt-3.6.1
: 3.6.0
Assigned To: Anatoly Litovsky
Ying Cui
: TestBlocker
Depends On: 1277521 1279364
Blocks:
  Show dependency treegraph
 
Reported: 2015-10-22 01:23 EDT by Ying Cui
Modified: 2016-03-09 16:44 EST (History)
8 users (show)

See Also:
Fixed In Version: rhevm-appliance-20151029.2-1
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-03-09 16:44:02 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: Node
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Hosted_Engine_Deploy_interactive_steps (10.78 KB, text/plain)
2015-10-22 01:26 EDT, Ying Cui
no flags Details
ovirt-engine-setup-log (180.42 KB, text/plain)
2015-10-22 01:27 EDT, Ying Cui
no flags Details
Generated answerfile from engine (2.31 KB, text/plain)
2015-10-22 01:30 EDT, Ying Cui
no flags Details
ovirt-hosted-engine-setup-answerfile (3.29 KB, text/plain)
2015-10-22 01:32 EDT, Ying Cui
no flags Details
varlog_on_node (4.56 MB, application/x-bzip)
2015-10-22 01:36 EDT, Ying Cui
no flags Details

  None (edit)
Description Ying Cui 2015-10-22 01:23:53 EDT
Description of problem:
Deploying hosted engine on the rhevm-appliance ova on RHEV-H, automatically execute engine-setup on the rhevm-appliance failed.

Version-Release number of selected component (if applicable):
# rpm -qa ovirt-node ovirt-node-plugin-hosted-engine ovirt-hosted-engine-setup ovirt-hosted-engine-ha vdsm
ovirt-hosted-engine-setup-1.3.0-1.el7ev.noarch
ovirt-node-3.3.0-0.14.20151013git5f84da0.el7ev.noarch
ovirt-hosted-engine-ha-1.3.0-1.el7ev.noarch
ovirt-node-plugin-hosted-engine-0.3.0-1.el7ev.noarch
vdsm-4.17.8-1.el7ev.noarch
# cat /etc/redhat-release 
Red Hat Enterprise Virtualization Hypervisor release 7.2 (20151013.76.el7ev)

rhevm-appliance-20151019.0-1 
# rpm -qa rhevm
rhevm-3.6.0.1-0.1.el6.noarch

How reproducible:
100%

Steps to Reproduce:
1. Clean installed RHEV-H 7.2 20151013.76 successful.
2. RHEV-H TUI Setup network via dhcp.
3. Set root password for rhevh.
4. Navigate to "Hosted Engine" TUI. 
5. Deploy Hosted Engine
6. Set URL on "Engine ISO/OVA URL for download"
7. Click on "Deploy"
8. hosted-engine deployment process start.
9. one by one steps see the attachment: interactive_steps.txt

Actual results:
Engine setup failed on the appliance, Hosted-Engine deployment process quit on RHEV-H.

Expected results:
Automatically execute engine-setup on the rhevm-appliance successful. 

Additional info:

service status on the rhevm-appliance
# service ovirt-engine status
ovirt-engine is stopped

# service httpd status
httpd (pid  7384) is running...

# service postgresql status
postmaster is stopped

ovirt-engine-setup-20151022000921-at1580.log from rhevm-appliance

<snip>
2015-10-22 00:09:21 DEBUG otopi.plugins.otopi.dialog.human dialog.__logString:219 DIALOG:SEND                 --== PRODUCT OPTIONS ==--
2015-10-22 00:09:21 DEBUG otopi.plugins.otopi.dialog.human dialog.__logString:219 DIALOG:SEND
2015-10-22 00:09:21 DEBUG otopi.context context._executeMethod:142 Stage customization METHOD otopi.plugins.ovirt_engine_setup.ovirt_engine.core.misc.Plugin._customization
2015-10-22 00:09:21 DEBUG otopi.plugins.otopi.dialog.human human.queryString:156 query OVESETUP_ENGINE_ENABLE
2015-10-22 00:09:21 DEBUG otopi.plugins.otopi.dialog.human dialog.__logString:219 DIALOG:SEND                 Configure Engine on this host (Yes, No) [Yes]:
2015-10-22 00:09:21 DEBUG otopi.context context._executeMethod:156 method exception
Traceback (most recent call last):
  File "/usr/lib/python2.6/site-packages/otopi/context.py", line 146, in _executeMethod
    method['method']()
  File "/usr/share/ovirt-engine/setup/bin/../plugins/ovirt-engine-setup/ovirt-engine/core/misc.py", line 83, in _customization
    ) if self.environment[oenginecons.EngineDBEnv.NEW_DATABASE]
  File "/usr/share/ovirt-engine/setup/ovirt_engine_setup/dialog.py", line 47, in queryBoolean
    default=true if default else false,
  File "/usr/share/otopi/plugins/otopi/dialog/human.py", line 174, in queryString
    value = self._readline(hidden=hidden)
  File "/usr/lib/python2.6/site-packages/otopi/dialog.py", line 263, in _readline
    raise IOError(_('End of file'))
IOError: End of file
2015-10-22 00:09:21 ERROR otopi.context context._executeMethod:165 Failed to execute stage 'Environment customization': End of file
2015-10-22 00:09:21 DEBUG otopi.context context.dumpEnvironment:500 ENVIRONMENT DUMP - BEGIN
2015-10-22 00:09:21 DEBUG otopi.context context.dumpEnvironment:510 ENV BASE/error=bool:'True'
</snip>
Comment 1 Ying Cui 2015-10-22 01:26 EDT
Created attachment 1085388 [details]
Hosted_Engine_Deploy_interactive_steps
Comment 2 Ying Cui 2015-10-22 01:27 EDT
Created attachment 1085389 [details]
ovirt-engine-setup-log
Comment 3 Ying Cui 2015-10-22 01:30 EDT
Created attachment 1085390 [details]
Generated answerfile from engine
Comment 4 Ying Cui 2015-10-22 01:32 EDT
Created attachment 1085391 [details]
ovirt-hosted-engine-setup-answerfile
Comment 5 Ying Cui 2015-10-22 01:36 EDT
Created attachment 1085392 [details]
varlog_on_node
Comment 7 Simone Tiraboschi 2015-10-22 07:13:42 EDT
We are missing an answerfile on the appliance or at least is not named as hosted-engine-setup expect:

2015-10-22 00:09:21 WARNING otopi.plugins.otopi.core.config config._post_init:164 The following configuration files are missing: /root/ovirt-engine-answers.
Comment 12 Ying Cui 2015-11-11 23:30:40 EST
With bug 1277521/ bug 1279364 open, we can not test this bug on rhevm-appliance-20151029.2-1.

Tested and Verified the new appliance: rhevm-appliance-20151110.0-1, the bug description error is fixed yet.

Just Note: I tested 2 times for this bug, always encountered the Bug 1280268 - HE-VM cannot startup automatically after successful configure HE. So after HE-VM deployed yet, I need to restart ovirt-ha-agent and ovirt-ha-broker services manually.

# cat /etc/redhat-release 
Red Hat Enterprise Virtualization Hypervisor release 7.2 (20151104.0.el7ev)

Test Step:
1. Clean installed RHEV-H 7.2 20151104 successful.
2. RHEV-H TUI Setup network via dhcp.
3. Navigate to "Hosted Engine" TUI. 
4. Deploy Hosted Engine
5. Set URL on "Engine ISO/OVA URL for download" with rhevm-appliance-20151110.0-1.ova
6. Click on "Deploy"
7. hosted-engine deployment process start.
8. one by one steps to setup engine via cloud-init automatically, HE_APPLIANCE_ENGINE_SETUP_SUCCESS
9. Access engine via webUI, Engine is UP and login successful
10. Hosted display in Host sheets and UP.
Comment 14 errata-xmlrpc 2016-03-09 16:44:02 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2016:0385

Note You need to log in before you can comment on or make changes to this bug.