Bug 1277521 - Deploy from appliance failed because missed answer
Deploy from appliance failed because missed answer
Status: CLOSED ERRATA
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: rhevm-appliance (Show other bugs)
3.6.0
x86_64 Linux
urgent Severity urgent
: ovirt-3.6.0-rc3
: 3.6.0
Assigned To: Anatoly Litovsky
Artyom
: Triaged
: 1277516 1277517 1277520 1279364 (view as bug list)
Depends On:
Blocks: 1217106 1274143
  Show dependency treegraph
 
Reported: 2015-11-03 08:55 EST by Artyom
Modified: 2016-03-09 16:44 EST (History)
15 users (show)

See Also:
Fixed In Version: rhevm-appliance-20151110.0
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-03-09 16:44:13 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: Node
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
setup log (436.80 KB, text/plain)
2015-11-03 08:55 EST, Artyom
no flags Details

  None (edit)
Description Artyom 2015-11-03 08:55:15 EST
Description of problem:
Deploy from appliance failed because missed answer on:
Would you like transactions from the Red Hat Access Plugin sent from the RHEV Manager to be brokered through a proxy server? (Yes, No) [No]: [ ERROR ] Failed to execute stage 'Environment customization': End of file

Version-Release number of selected component (if applicable):
rhevm-appliance-20151029.2-1.el6ev.noarch

How reproducible:
Always

Steps to Reproduce:
1. run hosted-engine --deploy on host
2. choose deployment from appliance
3. answer yes on question: Automatically execute engine-setup on the engine appliance on first boot
4. continue deployment

Actual results:
Deployment failed with error:
Would you like transactions from the Red Hat Access Plugin sent from the RHEV Manager to be brokered through a proxy server? (Yes, No) [No]: [ ERROR ] Failed to execute stage 'Environment customization': End of file


Expected results:
deployment succeed without any errors

Additional info:
Comment 1 Artyom 2015-11-03 08:55 EST
Created attachment 1088994 [details]
setup log
Comment 2 Simone Tiraboschi 2015-11-03 09:24:10 EST
The fix should be inside the answerfile contained in that appliance kind being something specific to that.
Comment 3 Red Hat Bugzilla Rules Engine 2015-11-03 09:26:34 EST
Target release should be placed once a package build is known to fix a issue. Since this bug is not modified, the target version has been reset. Please use target milestone to plan a fix for a oVirt release.
Comment 4 Red Hat Bugzilla Rules Engine 2015-11-03 09:27:09 EST
Target release should be placed once a package build is known to fix a issue. Since this bug is not modified, the target version has been reset. Please use target milestone to plan a fix for a oVirt release.
Comment 5 Artyom 2015-11-04 10:18:57 EST
*** Bug 1277516 has been marked as a duplicate of this bug. ***
Comment 6 Artyom 2015-11-04 10:19:03 EST
*** Bug 1277517 has been marked as a duplicate of this bug. ***
Comment 7 Artyom 2015-11-04 10:19:05 EST
*** Bug 1277520 has been marked as a duplicate of this bug. ***
Comment 8 Sandro Bonazzola 2015-11-05 03:09:22 EST
oVirt 3.6.0 has been released on November 4th, re-targeting to 3.6.1 since this bug has been marked as urgent
Comment 10 Artyom 2015-11-08 05:04:49 EST
Some additional answer missed:
Do you want to review them? (Yes, No) [No]: [ ERROR ] Failed to execute stage 'Setup validation': End of file
Comment 14 Anatoly Litovsky 2015-11-09 08:46:25 EST
*** Bug 1279364 has been marked as a duplicate of this bug. ***
Comment 15 Red Hat Bugzilla Rules Engine 2015-11-10 04:31:48 EST
Fixed bug tickets must have version flags set prior to fixing them. Please set the correct version flags and move the bugs back to the previous status after this is corrected.
Comment 18 Gonza 2015-11-11 11:14:11 EST
Verified with:
rhevm-appliance-20151110.0-1

Engine setup completed successfully.
Comment 19 Sandro Bonazzola 2015-11-17 08:02:14 EST
Gonza, so shouldn't this be on verified?
Comment 21 Artyom 2015-11-18 07:29:42 EST
Verified on rhevm-appliance-20151110.0-1.el7ev.noarch
Hosted engine deploy pass without any errors.
Comment 22 Gonza 2015-11-18 07:40:12 EST
(In reply to Sandro Bonazzola from comment #19)
> Gonza, so shouldn't this be on verified?

At the time the status was "MODIFIED". Was waiting for it to go "ON_QA".
Comment 24 errata-xmlrpc 2016-03-09 16:44:13 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2016:0385

Note You need to log in before you can comment on or make changes to this bug.