Bug 1279364 - Failed to setup hosted engine through cloud-init
Failed to setup hosted engine through cloud-init
Status: CLOSED DUPLICATE of bug 1277521
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: rhevm-appliance (Show other bugs)
3.6.0
Unspecified Unspecified
unspecified Severity urgent
: ovirt-3.6.1
: 3.6.1
Assigned To: Anatoly Litovsky
Pavel Stehlik
node
:
Depends On:
Blocks: 1274143
  Show dependency treegraph
 
Reported: 2015-11-09 04:57 EST by wanghui
Modified: 2016-09-26 17:56 EDT (History)
11 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-11-09 08:46:25 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: Node
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
node log files (966.99 KB, application/x-gzip)
2015-11-09 04:57 EST, wanghui
no flags Details
engine log files (17.58 KB, application/x-gzip)
2015-11-09 04:57 EST, wanghui
no flags Details

  None (edit)
Description wanghui 2015-11-09 04:57:03 EST
Created attachment 1091682 [details]
node log files

Description of problem:
It failed to setup hosted engine through cloud-init with the follow error.

2015-11-09 08:50:12 DEBUG otopi.plugins.otopi.dialog.human dialog.__logString:219 DIALOG:SEND                 |-           --== MISC CONFIGURATION ==--
2015-11-09 08:50:12 DEBUG otopi.plugins.otopi.dialog.human dialog.__logString:219 DIALOG:SEND                 |-
2015-11-09 08:50:12 DEBUG otopi.plugins.otopi.dialog.human dialog.__logString:219 DIALOG:SEND                 |-           Would you like transactions from the Red Hat Access Plugin sent from the RHEV Manager to be brokered through a proxy server? (Yes, No) [No]: [ ERROR ] Failed to execute stage 'Environment customization': End of file
2015-11-09 08:50:12 DEBUG otopi.plugins.otopi.dialog.human dialog.__logString:219 DIALOG:SEND                 |- [ INFO  ] Stage: Clean up
2015-11-09 08:50:12 DEBUG otopi.plugins.otopi.dialog.human dialog.__logString:219 DIALOG:SEND                 |-           Log file is located at /var/log/ovirt-engine/setup/ovirt-engine-setup-20151109035009-kselws.log
2015-11-09 08:50:12 DEBUG otopi.plugins.otopi.dialog.human dialog.__logString:219 DIALOG:SEND                 |- [ INFO  ] Generating answer file '/var/lib/ovirt-engine/setup/answers/20151109035011-setup.conf'
2015-11-09 08:50:12 DEBUG otopi.plugins.otopi.dialog.human dialog.__logString:219 DIALOG:SEND                 |- [ INFO  ] Stage: Pre-termination
2015-11-09 08:50:13 DEBUG otopi.plugins.otopi.dialog.human dialog.__logString:219 DIALOG:SEND                 |- [ INFO  ] Stage: Termination
2015-11-09 08:50:13 DEBUG otopi.plugins.otopi.dialog.human dialog.__logString:219 DIALOG:SEND                 |- [ ERROR ] Execution of setup failed
2015-11-09 08:50:13 DEBUG otopi.plugins.otopi.dialog.human dialog.__logString:219 DIALOG:SEND                 |- HE_APPLIANCE_ENGINE_SETUP_FAIL
2015-11-09 08:50:13 ERROR otopi.plugins.ovirt_hosted_engine_setup.engine.health health._closeup:154 Engine setup failed on the appliance
2015-11-09 08:50:13 DEBUG otopi.context context._executeMethod:156 method exception
Traceback (most recent call last):
  File "/usr/lib/python2.7/site-packages/otopi/context.py", line 146, in _executeMethod
    method['method']()
  File "/usr/share/ovirt-hosted-engine-setup/scripts/../plugins/ovirt-hosted-engine-setup/engine/health.py", line 160, in _closeup
    ).format(since=TIMEOUT*nTimeout5)
RuntimeError: Engine setup failed on the appliance
Please check its log on the appliance.

2015-11-09 08:50:13 ERROR otopi.context context._executeMethod:165 Failed to execute stage 'Closing up': Engine setup failed on the appliance
Please check its log on the appliance.

Version-Release number of selected component (if applicable):
rhev-hypervisor-7-7.2-20151104.0.e17ev
ovirt-node-3.6.0-0.20.20151103git3d3779a.el7ev.noarch
ovirt-node-plugin-hosted-engine-0.3.0-2.el7ev.noarch
ovirt-hosted-engine-setup-1.3.0-1.el7ev.noarch
ovirt-hosted-engine-ha-1.3.2.1-1.el7ev.noarch
rhevm-appliance-20151029.2-1.x86_64.rhevm.ova

How reproducible:
100%

Steps to Reproduce:
1. TUI clean install rhevh
2. Login rhevh, setup network via dhcp
3. Setup Hosted Engine through ova type with rhevm-appliance-20151029.2-1.x86_64.rhevm.ova.
4. Use cloud-init the deploy vm during Hosted Engine setup process.

Actual results:
1. After step4, it will report errors like follow.

2015-11-09 08:50:12 DEBUG otopi.plugins.otopi.dialog.human dialog.__logString:219 DIALOG:SEND                 |-           Would you like transactions from the Red Hat Access Plugin sent from the RHEV Manager to be brokered through a proxy server? (Yes, No) [No]: [ ERROR ] Failed to execute stage 'Environment customization': End of file

Expected results:
1.After step4, it can deploy rhevm succeed.

Additional info:
Comment 1 wanghui 2015-11-09 04:57 EST
Created attachment 1091683 [details]
engine log files
Comment 2 Anatoly Litovsky 2015-11-09 08:46:25 EST

*** This bug has been marked as a duplicate of bug 1277521 ***

Note You need to log in before you can comment on or make changes to this bug.