Bug 1274468 - Need updated pyatspi package for GTK3 testing
Summary: Need updated pyatspi package for GTK3 testing
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: pyatspi
Version: 7.2
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: rc
: ---
Assignee: Rui Matos
QA Contact: Desktop QE
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2015-10-22 19:08 UTC by Sean Toner
Modified: 2016-11-04 01:48 UTC (History)
5 users (show)

Fixed In Version: pyatspi-2.14.0-1.el7
Doc Type: Rebase: Bug Fixes and Enhancements
Doc Text:
Clone Of:
Environment:
Last Closed: 2016-11-04 01:48:21 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2016:2262 0 normal SHIPPED_LIVE at-spi2-atk, at-spi2-core, pyatspi bug fix update 2016-11-03 13:32:59 UTC

Description Sean Toner 2015-10-22 19:08:50 UTC
Description of problem:
=======================

Please see https://bugzilla.redhat.com/show_bug.cgi?id=1274453 and BZ 1274463

For subscription-manager-gui testing, we use a test tool called ldtp which uses pyatspi and the accessibility tool kit for automation testing.  

The version of pyatspi that exists in RHEL-7.2 is pyatspi-2.8.0-3.el7.noarch and is about 3 years old and it is not current enough to support testing of certain GTK3 widgets (for example drop down boxes, spinner buttons, or key event presses).  This is causing a rather large portion of our automated tests to no longer work because of the GTK3 changes.

I have built the src.rpms from Fedora23 Beta on RHEL 7.2 and was able to get several GTK3 tests to work.  The version I built which works is 

[root@dhcp129-21 ~]# rpm -qa | grep pyatspi
pyatspi-2.8.0-3.el7.noarch



Version-Release number of selected component (if applicable):
=============================================================

pyatspi-2.8.0-3.el7.noarch

How reproducible:
=================

Always


Additional info:


There are 3 other packages which simultaneously need to be updated for our testing needs:

at-spi2-core
atk  # a dependency of at-spi2-atk
at-spi2-atk

Comment 6 Tomas Pelka 2016-08-29 13:11:47 UTC
Sean does the rebased pyatspi & friends full filled your needs in rhel7.3?

Can we move this bz to verified?

Thanks
-Tom

Comment 7 Sean Toner 2016-09-07 17:20:05 UTC
I am trying to verify this, but have been running into issues with my test environment.  I will update as soon as I can get past these issues.

Comment 8 Tomas Pelka 2016-09-07 19:04:43 UTC
(In reply to Sean Toner from comment #7)
> I am trying to verify this, but have been running into issues with my test
> environment.  I will update as soon as I can get past these issues.

OK I can wait week or two (Sep 22.) and than move to verified as our test framework using AT-SPI works as expected.

Deal?

Comment 9 Sean Toner 2016-09-08 17:47:44 UTC
That's fair.

I have verified that we can do keyevents and the spinners now.  The combo box appears broken still.  I can set a value for the combo box, but getting the current value of the combo box seems to be broken (it always returns the same starting value, even if you change it).  

I want to try to isolate if getting the value from the combo box might be an LDTP issue rather than a pyatspi one.

Comment 10 Sean Toner 2016-09-13 10:09:12 UTC
I was not able to test out pyatspi unfortunately.  I will close this issue out as I suspect this might be a ldtp bug rather than a pyatspi one.  All the other functionality is working though.

Comment 11 Tomas Pelka 2016-09-13 10:15:10 UTC
(In reply to Sean Toner from comment #10)
> I was not able to test out pyatspi unfortunately.  I will close this issue
> out as I suspect this might be a ldtp bug rather than a pyatspi one.  All
> the other functionality is working though.

Thanks Sean.

Comment 13 errata-xmlrpc 2016-11-04 01:48:21 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2016-2262.html


Note You need to log in before you can comment on or make changes to this bug.