Bug 1274847 - CTR should be enabled on attach tier, disabled otherwise.
CTR should be enabled on attach tier, disabled otherwise.
Status: CLOSED CURRENTRELEASE
Product: GlusterFS
Classification: Community
Component: tiering (Show other bugs)
mainline
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Dan Lambright
bugs@gluster.org
:
Depends On:
Blocks: 1276617 1276671 1276678
  Show dependency treegraph
 
Reported: 2015-10-23 12:08 EDT by Dan Lambright
Modified: 2016-06-16 09:41 EDT (History)
1 user (show)

See Also:
Fixed In Version: glusterfs-3.8rc2
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
: 1276617 1276671 1276678 (view as bug list)
Environment:
Last Closed: 2016-06-16 09:41:27 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Dan Lambright 2015-10-23 12:08:13 EDT
CTR is currently disabled by default, and must be manually enabled for tiering to start. This is an overhead on the administrator and easy to overlook. Enable it automatically when a tier is attached.
Comment 1 Vijay Bellur 2015-10-23 12:12:36 EDT
REVIEW: http://review.gluster.org/12420 (cluster/tier enable CTR on attach tier) posted (#1) for review on master by Dan Lambright (dlambrig@redhat.com)
Comment 2 Vijay Bellur 2015-10-28 10:45:41 EDT
REVIEW: http://review.gluster.org/12420 (cluster/tier enable CTR on attach tier) posted (#2) for review on master by Dan Lambright (dlambrig@redhat.com)
Comment 3 Vijay Bellur 2015-10-29 15:42:23 EDT
REVIEW: http://review.gluster.org/12420 (cluster/tier enable CTR on attach tier) posted (#3) for review on master by Dan Lambright (dlambrig@redhat.com)
Comment 4 Vijay Bellur 2015-10-30 08:21:47 EDT
COMMIT: http://review.gluster.org/12420 committed in master by Dan Lambright (dlambrig@redhat.com) 
------
commit e13733ab871f34c54a6fc44059b3343a5c2f992a
Author: Dan Lambright <dlambrig@redhat.com>
Date:   Fri Oct 23 12:10:42 2015 -0400

    cluster/tier enable CTR on attach tier
    
    CTR is currently disabled by default, and must be manually enabled
    for tiering to start. This is an overhead on the administrator and
    easy to overlook. Enable it automatically when a tier is attached.
    
    Change-Id: I0c29de8762faec1bfe6d1376a57eeef3357ad15a
    BUG: 1274847
    Signed-off-by: Dan Lambright <dlambrig@redhat.com>
    Reviewed-on: http://review.gluster.org/12420
    Tested-by: Gluster Build System <jenkins@build.gluster.com>
    Reviewed-by: mohammed rafi  kc <rkavunga@redhat.com>
Comment 5 Niels de Vos 2016-06-16 09:41:27 EDT
This bug is getting closed because a release has been made available that should address the reported issue. In case the problem is still not fixed with glusterfs-3.8.0, please open a new bug report.

glusterfs-3.8.0 has been announced on the Gluster mailinglists [1], packages for several distributions should become available in the near future. Keep an eye on the Gluster Users mailinglist [2] and the update infrastructure for your distribution.

[1] http://blog.gluster.org/2016/06/glusterfs-3-8-released/
[2] http://thread.gmane.org/gmane.comp.file-systems.gluster.user

Note You need to log in before you can comment on or make changes to this bug.