Bug 1276678 - CTR should be enabled on attach tier, disabled otherwise.
CTR should be enabled on attach tier, disabled otherwise.
Status: CLOSED ERRATA
Product: Red Hat Gluster Storage
Classification: Red Hat
Component: tier (Show other bugs)
3.1
Unspecified Unspecified
unspecified Severity unspecified
: ---
: RHGS 3.1.2
Assigned To: Bug Updates Notification Mailing List
nchilaka
: ZStream
: 1276617 (view as bug list)
Depends On: 1274847
Blocks: 1260783 1260923 1276617 1276671
  Show dependency treegraph
 
Reported: 2015-10-30 09:19 EDT by Dan Lambright
Modified: 2016-09-17 11:44 EDT (History)
5 users (show)

See Also:
Fixed In Version: glusterfs-3.7.5-6
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: 1274847
Environment:
Last Closed: 2016-03-01 00:49:24 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Dan Lambright 2015-10-30 09:19:27 EDT
+++ This bug was initially created as a clone of Bug #1274847 +++

CTR is currently disabled by default, and must be manually enabled for tiering to start. This is an overhead on the administrator and easy to overlook. Enable it automatically when a tier is attached.

--- Additional comment from Vijay Bellur on 2015-10-23 12:12:36 EDT ---

REVIEW: http://review.gluster.org/12420 (cluster/tier enable CTR on attach tier) posted (#1) for review on master by Dan Lambright (dlambrig@redhat.com)

--- Additional comment from Vijay Bellur on 2015-10-28 10:45:41 EDT ---

REVIEW: http://review.gluster.org/12420 (cluster/tier enable CTR on attach tier) posted (#2) for review on master by Dan Lambright (dlambrig@redhat.com)

--- Additional comment from Vijay Bellur on 2015-10-29 15:42:23 EDT ---

REVIEW: http://review.gluster.org/12420 (cluster/tier enable CTR on attach tier) posted (#3) for review on master by Dan Lambright (dlambrig@redhat.com)

--- Additional comment from Vijay Bellur on 2015-10-30 08:21:47 EDT ---

COMMIT: http://review.gluster.org/12420 committed in master by Dan Lambright (dlambrig@redhat.com) 
------
commit e13733ab871f34c54a6fc44059b3343a5c2f992a
Author: Dan Lambright <dlambrig@redhat.com>
Date:   Fri Oct 23 12:10:42 2015 -0400

    cluster/tier enable CTR on attach tier
    
    CTR is currently disabled by default, and must be manually enabled
    for tiering to start. This is an overhead on the administrator and
    easy to overlook. Enable it automatically when a tier is attached.
    
    Change-Id: I0c29de8762faec1bfe6d1376a57eeef3357ad15a
    BUG: 1274847
    Signed-off-by: Dan Lambright <dlambrig@redhat.com>
    Reviewed-on: http://review.gluster.org/12420
    Tested-by: Gluster Build System <jenkins@build.gluster.com>
    Reviewed-by: mohammed rafi  kc <rkavunga@redhat.com>
Comment 2 Dan Lambright 2015-11-01 11:49:12 EST
*** Bug 1276617 has been marked as a duplicate of this bug. ***
Comment 4 nchilaka 2015-11-10 06:16:45 EST
I have verified this on the latest build:
1)check default ctr on a regular volume which was off as expected
2)attached tier to a regular volume and ctr was enabled by default on volume
3)attached a tier to an offline regular volume and ctr was enabled even on offline volume

hence moving to verified.

[root@zod ~]# rpm -qa|grep gluster
glusterfs-libs-3.7.5-6.el7rhgs.x86_64
glusterfs-fuse-3.7.5-6.el7rhgs.x86_64
glusterfs-3.7.5-6.el7rhgs.x86_64
glusterfs-server-3.7.5-6.el7rhgs.x86_64
glusterfs-client-xlators-3.7.5-6.el7rhgs.x86_64
glusterfs-cli-3.7.5-6.el7rhgs.x86_64
glusterfs-api-3.7.5-6.el7rhgs.x86_64
glusterfs-debuginfo-3.7.5-6.el7rhgs.x86_64
[root@zod ~]# 



logs:
======
[root@zod ~]# gluster v create offline disperse 6 disperse-data 4 zod:/rhs/brick1/offline yarrow:/rhs/brick1/offline zod:/rhs/brick2/offline yarrow:/rhs/brick2/offline zod:/rhs/brick3/offline yarrow:/rhs/brick3/offline force
volume create: offline: success: please start the volume to access data
[root@zod ~]# 
[root@zod ~]# 
[root@zod ~]# #gluster v attach-tier offline replica 2 zod:/rhs/brick7/offline_hot yarrow:/rhs/brick7/offline_hot zod:/rhs/brick6/offline_hot yarrow:/rhs/brick6/offline_hot
[root@zod ~]# gluster v get ctr features.ctr-enabled
Option                                  Value                                   
------                                  -----                                   
features.ctr-enabled                    on                                      
[root@zod ~]# gluster v get offline features.ctr-enabled
Option                                  Value                                   
------                                  -----                                   
features.ctr-enabled                    off                                     
[root@zod ~]# #gluster v get ctr features.ctr-enabled
[root@zod ~]# gluster v attach-tier offline replica 2 zod:/rhs/brick7/offline_hot yarrow:/rhs/brick7/offline_hot zod:/rhs/brick6/offline_hot yarrow:/rhs/brick6/offline_hot
volume attach-tier: success
Tiering Migration Functionality: offline: failed: Volume offline needs to be started to perform rebalance
Failed to run tier start. Please execute tier start command explictly
Usage : gluster volume rebalance <volname> tier start
Tier command failed
[root@zod ~]# gluster v status offline
Volume offline is not started
[root@zod ~]# gluster v info offline
 
Volume Name: offline
Type: Tier
Volume ID: ace77d4b-68c5-4fca-a0c7-df0a51606ff6
Status: Created
Number of Bricks: 10
Transport-type: tcp
Hot Tier :
Hot Tier Type : Distributed-Replicate
Number of Bricks: 2 x 2 = 4
Brick1: yarrow:/rhs/brick6/offline_hot
Brick2: zod:/rhs/brick6/offline_hot
Brick3: yarrow:/rhs/brick7/offline_hot
Brick4: zod:/rhs/brick7/offline_hot
Cold Tier:
Cold Tier Type : Disperse
Number of Bricks: 1 x (4 + 2) = 6
Brick5: zod:/rhs/brick1/offline
Brick6: yarrow:/rhs/brick1/offline
Brick7: zod:/rhs/brick2/offline
Brick8: yarrow:/rhs/brick2/offline
Brick9: zod:/rhs/brick3/offline
Brick10: yarrow:/rhs/brick3/offline
Options Reconfigured:
features.ctr-enabled: on
performance.readdir-ahead: on
[root@zod ~]# #gluster v get ctr features.ctr-enabled
[root@zod ~]# gluster v get offline features.ctr-enabled
Option                                  Value                                   
------                                  -----                                   
features.ctr-enabled                    on
Comment 6 errata-xmlrpc 2016-03-01 00:49:24 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2016-0193.html

Note You need to log in before you can comment on or make changes to this bug.