Bug 1275840 - Product Assistance text box renders incorrectly for non-super administrators
Summary: Product Assistance text box renders incorrectly for non-super administrators
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat CloudForms Management Engine
Classification: Red Hat
Component: UI - OPS
Version: 5.4.0
Hardware: Unspecified
OS: Unspecified
high
medium
Target Milestone: GA
: 5.6.0
Assignee: lgalis
QA Contact: Pavol Kotvan
URL:
Whiteboard: ui:rbac
Depends On:
Blocks: 1291810 1300071
TreeView+ depends on / blocked
 
Reported: 2015-10-27 22:17 UTC by Jared Deubel
Modified: 2019-10-10 10:25 UTC (History)
11 users (show)

Fixed In Version: 5.6.0.0
Doc Type: Bug Fix
Doc Text:
Clone Of:
: 1291810 1300071 (view as bug list)
Environment:
Last Closed: 2016-06-29 15:01:25 UTC
Category: ---
Cloudforms Team: ---
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Red Hat Bugzilla 1272618 0 high CLOSED Missing links to product documentation on Support Page 2021-02-22 00:41:40 UTC
Red Hat Product Errata RHBA-2016:1348 0 normal SHIPPED_LIVE CFME 5.6.0 bug fixes and enhancement update 2016-06-29 18:50:04 UTC

Internal Links: 1272618

Description Jared Deubel 2015-10-27 22:17:57 UTC
Created attachment 1087073 [details]
ui_screenshot_incorrect

Description of problem:

Clicking on Configure->About as a role other than super administrator results in an empty "Product Assistance" box. When configuring the Custom Support URL and would expect it to show the URL instead of a blank box.

When the URL/Description is empty, the Product Assistance box does not show at all.

When it is set, the box shows up, but the link is not displayed. As shown in the screen shots attached. 

Version-Release number of selected component (if applicable):
5.4

How reproducible:
100%

Comment 2 Jared Deubel 2015-10-27 22:18:38 UTC
Created attachment 1087074 [details]
ui_screenshot_correct

Comment 11 CFME Bot 2016-02-12 21:10:55 UTC
New commit detected on ManageIQ/manageiq/master:
https://github.com/ManageIQ/manageiq/commit/71fcac8bda28bd19a270be157ebc81a0ed385962

commit 71fcac8bda28bd19a270be157ebc81a0ed385962
Author:     Laura Galis <lgalis@redhat.com>
AuthorDate: Fri Feb 5 12:25:51 2016 -0500
Commit:     Laura Galis <lgalis@redhat.com>
CommitDate: Fri Feb 12 14:04:48 2016 -0500

    Do not display the Product Assistance Box for non-admin if the custom url is not defined.
    
    https://bugzilla.redhat.com/show_bug.cgi?id=1275840

 app/views/support/show.html.haml | 22 +++++++++++-----------
 1 file changed, 11 insertions(+), 11 deletions(-)

Comment 13 CFME Bot 2016-02-15 15:44:23 UTC
Detected commit referencing this ticket while ticket status is MODIFIED.

Comment 14 lgalis 2016-02-15 18:56:22 UTC
The commit mentioned above was not related to this BZ.

Comment 17 CFME Bot 2016-02-19 21:25:34 UTC
New commit detected on cfme/5.5.z:
https://code.engineering.redhat.com/gerrit/gitweb?p=cfme.git;a=commitdiff;h=9d68d349ab7b4c1af87405ebf448e101230bd3c3

commit 9d68d349ab7b4c1af87405ebf448e101230bd3c3
Author:     Laura Galis <lgalis@redhat.com>
AuthorDate: Fri Feb 5 12:25:51 2016 -0500
Commit:     Laura Galis <lgalis@redhat.com>
CommitDate: Fri Feb 19 14:43:35 2016 -0500

    Do not display the Product Assistance Box for non-admin if the custom url is not defined.
    
    https://bugzilla.redhat.com/show_bug.cgi?id=1275840
    (cherry picked from commit 71fcac8)

 app/views/support/show.html.haml | 22 +++++++++++-----------
 1 file changed, 11 insertions(+), 11 deletions(-)

Comment 21 errata-xmlrpc 2016-06-29 15:01:25 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2016:1348


Note You need to log in before you can comment on or make changes to this bug.