Bugzilla (bugzilla.redhat.com) will be under maintenance for infrastructure upgrades and will not be available on July 31st between 12:30 AM - 05:30 AM UTC. We appreciate your understanding and patience. You can follow status.redhat.com for details.
Bug 1276084 - [DOCS] Information on securing PVs to namespaces with PVC.
Summary: [DOCS] Information on securing PVs to namespaces with PVC.
Keywords:
Status: CLOSED DUPLICATE of bug 1327308
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Documentation
Version: 3.0.0
Hardware: Unspecified
OS: Unspecified
medium
medium
Target Milestone: ---
: ---
Assignee: Ashley Hardin
QA Contact: Vikram Goyal
Vikram Goyal
URL:
Whiteboard:
Depends On: 1276082
Blocks:
TreeView+ depends on / blocked
 
Reported: 2015-10-28 16:20 UTC by Ryan Howe
Modified: 2019-08-15 05:45 UTC (History)
6 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of: 1276082
Environment:
Last Closed: 2016-06-02 14:50:13 UTC
Target Upstream Version:


Attachments (Terms of Use)

Description Ryan Howe 2015-10-28 16:20:26 UTC
We need to expand information on how an systems admin would secure a PV so that a system admin can control what PV a claim uses. 

https://docs.openshift.com/enterprise/3.0/dev_guide/persistent_volumes.html#volume-and-claim-binding

https://docs.openshift.com/enterprise/3.0/rest_api/kubernetes_v1.html#v1-persistentvolumeclaim


We can create a PVC with the volumeName but looking for use case in the docs for this and also information on how a sysadmin would limit project admin from creating a PVC that just binds to an available PV  


 apiVersion: v1
  kind: PersistentVolumeClaim
  metadata:
name: registry-claim
  spec:
accessModes:
- ReadWriteMany
resources:
  requests:
storage: 5Gi
volumeName: registry-volume
  status: {}



+++ This bug was initially created as a clone of Bug #1276082 +++

Description of problem:

PV needs to be able to be secured down so that claims can auto bind to the available PVs for the namespace.

Admin are looking for a way to provision Persistent Volumes that are only available to a defined namespace. While at the same time allowing the user to provision their own PVCs.

https://docs.openshift.com/enterprise/3.0/rest_api/kubernetes_v1.html#v1-persistentvolume

Version-Release number of selected component (if applicable):
3.0.x

Comment 3 Ashley Hardin 2016-05-31 15:24:51 UTC
@Ryan
OSE 3.2 docs included new information on configuring persistent storage. Please review these new topics and let me know if there is still an issue or anything else that should be added:

https://docs.openshift.com/enterprise/3.2/install_config/persistent_storage/index.html

Thanks!

Comment 4 Ashley Hardin 2016-06-02 14:50:13 UTC
After discussion with Ryan Howe, it was determined that this a duplicate of https://bugzilla.redhat.com/show_bug.cgi?id=1284994 and https://bugzilla.redhat.com/show_bug.cgi?id=1327308

*** This bug has been marked as a duplicate of bug 1327308 ***


Note You need to log in before you can comment on or make changes to this bug.