Bug 127677 - please reenable alsaconf in alsa-utils (needed for some soundcards)
please reenable alsaconf in alsa-utils (needed for some soundcards)
Status: CLOSED WONTFIX
Product: Fedora
Classification: Fedora
Component: alsa-utils (Show other bugs)
rawhide
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Bill Nottingham
http://www.cs.utsa.edu/~bylander/fedo...
:
: 129414 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-07-12 09:38 EDT by Barry K. Nathan
Modified: 2014-03-16 22:46 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-07-13 14:38:20 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Barry K. Nathan 2004-07-12 09:38:35 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7)
Gecko/20040626 Firefox/0.9.1

Description of problem:
Some non-PnP ISA sound cards (like the cs423x ones in the IBM ThinkPad
600 series) cannot be configured with {redhat,system}-config-soundcard.

I'm not asking for system-config-soundcard to support these kinds of
cards (that would be a dupe of bug 122838, which is CLOSED/WONTFIX).
However, now that sndconfig has been removed (and correctly so), there
is no way to automatically probe and configure older cards like these
-- unless alsaconf is reenabled in alsa-utils.

I know that Red Hat does not officially support non-PnP ISA
soundcards, however this is a trivial change to the alsa-utils spec
file, and it would save *tons* of effort for people like me who are
stuck trying to configure these kinds of soundcards. Also, I know that
alsaconf actually works once it's enabled in the RPM -- I tested this
earlier this morning.

Furthermore, people are already hacking around the lack of alsaconf in
the FC2 alsa-utils by stuffing fedora.us FC1 alsa packages into their
FC2 installs, which is really disgusting IMO:
http://www.cs.utsa.edu/~bylander/fedora2-experience.html

This type of disgusting act would be unnecessary if alsaconf was
simply included in the alsa-utils package. It would be such a small
change for Red Hat to make to the package that I believe it's worth
doing for Fedora Core, even though Red Hat no longer officially
supports this hardware.


Version-Release number of selected component (if applicable):
alsa-utils-1.0.5-1

How reproducible:
Always

Steps to Reproduce:
1. Install FC2 or FC-devel.
2. Notice that system-config-soundcard doesn't configure your
soundcard. Head to google, notice that people on other distributions
are using alsaconf.
3. Run "alsaconf" as root to configure your soundcard.
    

Actual Results:  alsaconf: command not found

Expected Results:  alsaconf asks several questions and eventually gets
the sound card working

Additional info:

I'm filing this bug against the "distribution" component because an
"alsa-utils" component does not exist yet (that's bug 127672).
Comment 1 Bill Nottingham 2004-07-12 16:42:49 EDT
Exactly what does alsaconf do to detect non-PNP ISA cards?
Comment 2 Barry K. Nathan 2004-07-13 04:03:26 EDT
I haven't read the source code yet so I'm not 100% sure, but it seems
to do something like the following:

+ It asks the user the following questions:
  + Do you want to probe for legacy ISA cards?
  + What kinds of cards do you want to probe for?
  + Do you just want to probe for the common IO/IRQ/DMA combinations,
or for all of the possible combinations that can be used by the kinds
of cards you picked?
+ Then it tries loading (and unloading) different modules with
different settings a bunch of times, to try the combinations and see
what works
+ If no combinations work, it lets you know that, otherwise it asks if
you want it to modify your /etc/modprobe.conf.

It's something like that...
Comment 3 Bill Nottingham 2004-07-13 14:38:20 EDT
Eww; that's certianly not the sort of thing I want to encourage people
to run.
Comment 4 Jeff Moe (jebba) 2004-08-07 20:39:01 EDT
I'm trying to help a guy get sound going on his thinkpad. What are the
options?
1) Get a full build of alsa-utils
2) ?

I've used alsaconf in the past and it's been quite nice. Run it, slap
<enter> a few times, and everything comes up on reboot. Nice. It won't
go modprobing like mad unless you tell it to go on an ISA hunt.

Most folk won't need it at all, but for those that do? Well, what
should we encourage?
Comment 5 Bill Nottingham 2004-08-10 12:11:28 EDT
Except... the ISA modprobe hunt is the only additional feature it
gives you.
Comment 6 Bill Nottingham 2004-08-10 12:18:12 EDT
*** Bug 129414 has been marked as a duplicate of this bug. ***
Comment 7 Jeff Moe (jebba) 2004-08-12 01:45:13 EDT
Ya, ISA modprobe hunt may be the only(?) additional feature, but
what's wrong with that? It's needed by some people and it's part of
the upstream packaging. It's a whopping 29k. Including it can save
lots of hassle for lots of folk...
Comment 8 Barry K. Nathan 2004-08-23 05:38:49 EDT
FWIW, perhaps a better replacement could be written for alsaconf (in
the ThinkPad case) which uses tpctl or something related. However, I
don't have the hardware in my possession at this time, and I probably
won't have it again for a long while, so I won't be able to try
implementing this anytime in the near future. Nonetheless, I figure
the idea's worth mentioning in case someone else wants to try...
Comment 9 Rick Wagner 2004-11-30 13:14:47 EST
This is not just a thinkpad issue.  I have two systems (both based on
the ESS18xx chipset) which would not configure under FC3.  In both
cases rebuilding alsa-utils and running alsaconf got me my sound.

One setup was an FC1->FC3 upgrade that cause the sound to go missing.
 The other was clean install (first FC2, then FC3) which never had
sound.  Alsaconf configure both.

Granted, using the probe method is less than desireable, but alsaconf
warns that may make your system unstable (didn't happen on either my
machines).  

Given the warning, and the alternatives (throw out the laptop (not
likely), replace the sound card (not easy on the laptop), throw out
Fedora, or risk a crash in a controlled environment)  It paid off in
my case (and appearantly for a number of others who install back
versions of alsa-utils).

Note You need to log in before you can comment on or make changes to this bug.