Bug 1303934 - [abrt] rpmconf: filecmp.py:51:cmp:FileNotFoundError: [Errno 2] No such file or directory: '/etc/mock/default.cfg'
[abrt] rpmconf: filecmp.py:51:cmp:FileNotFoundError: [Errno 2] No such file o...
Status: CLOSED DUPLICATE of bug 1277025
Product: Fedora
Classification: Fedora
Component: rpmconf (Show other bugs)
23
x86_64 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Miroslav Suchý
Fedora Extras Quality Assurance
https://retrace.fedoraproject.org/faf...
abrt_hash:6d891bf9135aa52200288c9878a...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2016-02-02 07:56 EST by Gabriel PREDA
Modified: 2016-02-02 13:35 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-02-02 13:35:41 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
File: backtrace (899 bytes, text/plain)
2016-02-02 07:56 EST, Gabriel PREDA
no flags Details
File: environ (2.13 KB, text/plain)
2016-02-02 07:56 EST, Gabriel PREDA
no flags Details

  None (edit)
Description Gabriel PREDA 2016-02-02 07:56:40 EST
Version-Release number of selected component:
rpmconf-1.0.12-1.fc23

Additional info:
reporter:       libreport-2.6.3
cmdline:        /usr/bin/python3 /sbin/rpmconf -a
executable:     /sbin/rpmconf
kernel:         4.2.5-300.fc23.x86_64
runlevel:       N 5
type:           Python3
uid:            0

Truncated backtrace:
filecmp.py:51:cmp:FileNotFoundError: [Errno 2] No such file or directory: '/etc/mock/default.cfg'

Traceback (most recent call last):
  File "/sbin/rpmconf", line 63, in <module>
    main()
  File "/sbin/rpmconf", line 60, in main
    rconf.run()
  File "/usr/lib/python3.4/site-packages/rpmconf/rpmconf.py", line 90, in run
    self._handle_package(pkg_hdr)
  File "/usr/lib/python3.4/site-packages/rpmconf/rpmconf.py", line 264, in _handle_package
    tmp.format(conf_file, "rpmnew"))
  File "/usr/lib/python3.4/site-packages/rpmconf/rpmconf.py", line 273, in _handle_rpmnew
    if filecmp.cmp(conf_file, other_file):
  File "/usr/lib64/python3.4/filecmp.py", line 51, in cmp
    s1 = _sig(os.stat(f1))
FileNotFoundError: [Errno 2] No such file or directory: '/etc/mock/default.cfg'

Local variables in innermost frame:
shallow: True
f1: '/etc/mock/default.cfg'
f2: '/etc/mock/default.cfg.rpmnew'

Potential duplicate: bug 1279655
Comment 1 Gabriel PREDA 2016-02-02 07:56:46 EST
Created attachment 1120408 [details]
File: backtrace
Comment 2 Gabriel PREDA 2016-02-02 07:56:47 EST
Created attachment 1120409 [details]
File: environ
Comment 3 Miroslav Suchý 2016-02-02 13:35:41 EST
This have been fixed in rpmconf-1.0.16

*** This bug has been marked as a duplicate of bug 1277025 ***

Note You need to log in before you can comment on or make changes to this bug.