Bug 1277444 - Can't attach more than 20 filters to role.
Summary: Can't attach more than 20 filters to role.
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Satellite 6
Classification: Red Hat
Component: Users & Roles
Version: 6.1.3
Hardware: Unspecified
OS: Unspecified
unspecified
high vote
Target Milestone: Unspecified
Assignee: Shimon Shtein
QA Contact: Corey Welton
URL: http://projects.theforeman.org/issues...
Whiteboard:
: 1281608 1315271 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2015-11-03 10:39 UTC by Stefan Nemeth
Modified: 2019-12-16 05:04 UTC (History)
9 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2016-07-27 08:59:00 UTC
Target Upstream Version:


Attachments (Terms of Use)
screens of filters of role (182.09 KB, image/png)
2015-11-03 10:39 UTC, Stefan Nemeth
no flags Details
full role list (126.09 KB, image/png)
2016-01-13 22:13 UTC, Mike McCune
no flags Details


Links
System ID Priority Status Summary Last Updated
Red Hat Bugzilla 1293458 None None None Never
Red Hat Product Errata RHBA-2016:1500 normal SHIPPED_LIVE Red Hat Satellite 6.2 Base Libraries 2016-07-27 12:24:38 UTC

Internal Links: 1293458

Description Stefan Nemeth 2015-11-03 10:39:39 UTC
Created attachment 1088910 [details]
screens of filters of role

Description of problem:

It is not possible to attach more than 20 filters to role. If you attach more than 20 filters, filter will not appear in list.


Version-Release number of selected component (if applicable):


How reproducible:

100%

Steps to Reproduce:
1. Go to Administer 
2. Roles
3. Click on Role
4. Go to filters
5. Add 20 filters
6. Add extra filter (21.st)

Actual results:

Filter not visible/added

Expected results:

Filter visible/added

Additional info:

Comment 1 Bryan Kearney 2015-11-03 14:54:29 UTC
Created redmine issue http://projects.theforeman.org/issues/12380 from this bug

Comment 2 Bryan Kearney 2015-11-03 17:05:26 UTC
Upstream bug component is Users & Roles

Comment 3 Bryan Kearney 2015-11-13 16:27:47 UTC
*** Bug 1281608 has been marked as a duplicate of this bug. ***

Comment 6 Bryan Kearney 2015-12-29 15:33:20 UTC
When this is fixed please also check out https://bugzilla.redhat.com/show_bug.cgi?id=1293458.

Comment 7 Mike McCune 2016-01-13 22:09:28 UTC
You can actually attach more than 20 via hammer but the UI and API will only show 20. Confirmed at the DB level.

Comment 8 Mike McCune 2016-01-13 22:11:35 UTC
WORKAROUND:

You can view all the filters for the roles if you click the "Filters" button next to a Role, note in the attached screenshot there are 8 pages of Filters for the single Role I'm looking at

Comment 9 Mike McCune 2016-01-13 22:13:28 UTC
Created attachment 1114524 [details]
full role list

Comment 10 Bryan Kearney 2016-02-17 17:08:11 UTC
Moving to POST since upstream bug http://projects.theforeman.org/issues/12380 has been closed
-------------
Shimon Shtein
Applied in changeset commit:e3047ef2b3ba32e6b288dc36526310e0d11155e1.

Comment 12 Bryan Kearney 2016-03-16 12:25:54 UTC
*** Bug 1315271 has been marked as a duplicate of this bug. ***

Comment 13 Corey Welton 2016-03-18 21:34:49 UTC
Verified in SNAP4 - i have created a role 'bz1277444' and added individual filters to it (some with multiple permissions, some with only one, etc.) until I exceeded a count of 20.  I then viewed and reloaded page to assure my role still appeared, which it did.

Comment 16 errata-xmlrpc 2016-07-27 08:59:00 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2016:1500


Note You need to log in before you can comment on or make changes to this bug.