Bug 1293458 - Roles pages limited to 20 entries
Summary: Roles pages limited to 20 entries
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Satellite 6
Classification: Red Hat
Component: Users & Roles
Version: 6.1.5
Hardware: All
OS: All
urgent
high vote
Target Milestone: Unspecified
Assignee: satellite6-bugs
QA Contact: jcallaha
URL:
Whiteboard:
Depends On:
Blocks: 1315271
TreeView+ depends on / blocked
 
Reported: 2015-12-21 19:17 UTC by Andrew Schofield
Modified: 2019-11-14 07:16 UTC (History)
8 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
: 1315271 (view as bug list)
Environment:
Last Closed: 2016-09-27 09:02:05 UTC
Target Upstream Version:


Attachments (Terms of Use)
verification screenshot (134.63 KB, image/png)
2016-09-19 21:07 UTC, jcallaha
no flags Details


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2016:1938 normal SHIPPED_LIVE Satellite 6.1.10 bug fix update 2016-09-27 12:56:10 UTC
Foreman Issue Tracker 12380 None None None 2016-07-28 11:40:51 UTC
Red Hat Bugzilla 1277444 None CLOSED Can't attach more than 20 filters to role. 2019-05-28 17:05:26 UTC

Internal Links: 1277444

Description Andrew Schofield 2015-12-21 19:17:44 UTC
Description of problem:
Administer -> Roles -> <role> -> Filters only shows 20 entries. 

Version-Release number of selected component (if applicable):
6.1.5

How reproducible:
Repeatable with all roles that have > 20 entries. We notice this on the 'Viewer' roles as it has a large number of entries.

Steps to Reproduce:
1. Administer -> Roles -> Viewer -> Filters
2. Notice this only has 20 entries

Actual results:
Filters view limited to 20 entries

Expected results:
The Filter table should show either:
a) ALL entries 
b) A paginated list of entries.

Additional info:

Comment 1 Andrew Schofield 2015-12-21 19:19:02 UTC
Marked as URGENT as this *could* cause users who are dependent on the UI to view roles to think that roles have less permissions that they actually do.

Comment 3 Karl Abbott 2015-12-22 21:31:17 UTC
Is this the same as https://bugzilla.redhat.com/show_bug.cgi?id=1277444 ?

Karl

Comment 4 Bryan Kearney 2015-12-29 15:32:53 UTC
This is likely the same. I will attach them.

Comment 5 Bryan Kearney 2016-01-26 13:55:36 UTC
Moving this out of 6.1.7 due to capacity issues. Will keep it on the 6.1.z and 6.2 trackers to ensure that it is evaluated for both.

Comment 6 Bryan Kearney 2016-03-16 12:26:21 UTC
Moving this to POST. The fix for this is actually in https://bugzilla.redhat.com/show_bug.cgi?id=1277444.

Comment 7 Mike McCune 2016-03-28 23:32:32 UTC
This bug was accidentally moved from POST to MODIFIED via an error in automation, please see mmccune@redhat.com with any questions

Comment 8 Marek Hulan 2016-07-28 11:40:25 UTC
WORKAROUND:

You can view all the filters for the roles if you click the "Filters" button next to a Role

The fix is available, it has not been cherry-picked to 6.1 yet. I'm lowering the severity since there's a workaround.

Comment 11 jcallaha 2016-09-19 21:06:30 UTC
Verified in Satellite 6.1.10.

Filters are paginated correctly in increments of 10. See attached screenshot.

Comment 12 jcallaha 2016-09-19 21:07:05 UTC
Created attachment 1202627 [details]
verification screenshot

Comment 14 errata-xmlrpc 2016-09-27 09:02:05 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2016:1938


Note You need to log in before you can comment on or make changes to this bug.