Bug 1277590 - Tier : Move common functions into tier.rc
Tier : Move common functions into tier.rc
Status: CLOSED CURRENTRELEASE
Product: GlusterFS
Classification: Community
Component: tiering (Show other bugs)
3.7.6
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: bugs@gluster.org
bugs@gluster.org
:
Depends On: 1272319
Blocks: glusterfs-3.7.6 1278723
  Show dependency treegraph
 
Reported: 2015-11-03 10:33 EST by Nithya Balachandran
Modified: 2015-11-17 01:02 EST (History)
2 users (show)

See Also:
Fixed In Version: glusterfs-3.7.6
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: 1272319
: 1278723 (view as bug list)
Environment:
Last Closed: 2015-11-17 01:02:38 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Nithya Balachandran 2015-11-03 10:33:37 EST
+++ This bug was initially created as a clone of Bug #1272319 +++

Description of problem:
Functions are duplicated across .t files in the tiering regression tests. Move common functions into tier.rc

Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.

Actual results:


Expected results:


Additional info:

--- Additional comment from Vijay Bellur on 2015-10-20 13:00:16 EDT ---

REVIEW: http://review.gluster.org/12404 (tests/tier:  Move common functions to tier.rc) posted (#1) for review on master by N Balachandran (nbalacha@redhat.com)

--- Additional comment from Vijay Bellur on 2015-10-21 03:22:18 EDT ---

REVIEW: http://review.gluster.org/12404 (tests/tier:  Move common functions to tier.rc) posted (#2) for review on master by N Balachandran (nbalacha@redhat.com)

--- Additional comment from Vijay Bellur on 2015-10-21 11:01:02 EDT ---

REVIEW: http://review.gluster.org/12404 (tests/tier:  Move common functions to tier.rc) posted (#3) for review on master by N Balachandran (nbalacha@redhat.com)

--- Additional comment from Vijay Bellur on 2015-10-21 22:47:43 EDT ---

COMMIT: http://review.gluster.org/12404 committed in master by Dan Lambright (dlambrig@redhat.com) 
------
commit 594a03b030577bf0ed6960199e920cc5fa7e7afc
Author: N Balachandran <nbalacha@redhat.com>
Date:   Tue Oct 20 22:23:17 2015 +0530

    tests/tier:  Move common functions to tier.rc
    
    Move common functions in tier .t files to tier.rc
    
    Change-Id: Ibc312d987be9d93e7cc7fc47d0bf598bb1c944c2
    BUG: 1272319
    Signed-off-by: N Balachandran <nbalacha@redhat.com>
    Reviewed-on: http://review.gluster.org/12404
    Tested-by: Gluster Build System <jenkins@build.gluster.com>
    Reviewed-by: Dan Lambright <dlambrig@redhat.com>
    Tested-by: Dan Lambright <dlambrig@redhat.com>

--- Additional comment from Nithya Balachandran on 2015-10-30 05:45:56 EDT ---
Comment 1 Vijay Bellur 2015-11-03 10:47:43 EST
REVIEW: http://review.gluster.org/12497 (tests/tier:  Move common functions to tier.rc) posted (#1) for review on release-3.7 by N Balachandran (nbalacha@redhat.com)
Comment 2 Vijay Bellur 2015-11-03 13:44:43 EST
COMMIT: http://review.gluster.org/12497 committed in release-3.7 by Dan Lambright (dlambrig@redhat.com) 
------
commit 081e7938c8711aa7ce8a2955bb34767b697cf8b9
Author: N Balachandran <nbalacha@redhat.com>
Date:   Tue Nov 3 21:07:00 2015 +0530

    tests/tier:  Move common functions to tier.rc
    
    Move common functions in tier .t files to tier.rc
    
    > Change-Id: Ibc312d987be9d93e7cc7fc47d0bf598bb1c944c2
    > Signed-off-by: N Balachandran <nbalacha@redhat.com>
    > Reviewed-on: http://review.gluster.org/12404
    > Tested-by: Gluster Build System <jenkins@build.gluster.com>
    > Reviewed-by: Dan Lambright <dlambrig@redhat.com>
    > Tested-by: Dan Lambright <dlambrig@redhat.com>
    (cherry picked from commit 594a03b030577bf0ed6960199e920cc5fa7e7afc)
    
    Change-Id: Ie13bb86f85575164e62120e29bbbedb7789b0af5
    BUG: 1277590
    Signed-off-by: N Balachandran <nbalacha@redhat.com>
    Reviewed-on: http://review.gluster.org/12497
    Tested-by: Gluster Build System <jenkins@build.gluster.com>
    Reviewed-by: Dan Lambright <dlambrig@redhat.com>
    Tested-by: Dan Lambright <dlambrig@redhat.com>
Comment 3 Raghavendra Talur 2015-11-17 01:02:38 EST
This bug is getting closed because a release has been made available that should address the reported issue. In case the problem is still not fixed with glusterfs-3.7.6, please open a new bug report.

glusterfs-3.7.6 has been announced on the Gluster mailinglists [1], packages for several distributions should become available in the near future. Keep an eye on the Gluster Users mailinglist [2] and the update infrastructure for your distribution.

[1] http://www.gluster.org/pipermail/gluster-users/2015-November/024359.html
[2] http://thread.gmane.org/gmane.comp.file-systems.gluster.user

Note You need to log in before you can comment on or make changes to this bug.