Bug 1272319 - Tier : Move common functions into tier.rc
Summary: Tier : Move common functions into tier.rc
Status: CLOSED CURRENTRELEASE
Alias: None
Product: GlusterFS
Classification: Community
Component: tiering   
(Show other bugs)
Version: mainline
Hardware: Unspecified Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Nithya Balachandran
QA Contact: bugs@gluster.org
URL:
Whiteboard:
Keywords:
: 1273317 (view as bug list)
Depends On:
Blocks: 1277590 1278723
TreeView+ depends on / blocked
 
Reported: 2015-10-16 05:49 UTC by Nithya Balachandran
Modified: 2016-06-16 13:40 UTC (History)
2 users (show)

Fixed In Version: glusterfs-3.8rc2
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
: 1277590 (view as bug list)
Environment:
Last Closed: 2016-06-16 13:40:19 UTC
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Nithya Balachandran 2015-10-16 05:49:55 UTC
Description of problem:
Functions are duplicated across .t files in the tiering regression tests. Move common functions into tier.rc

Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.

Actual results:


Expected results:


Additional info:

Comment 1 Vijay Bellur 2015-10-20 17:00:16 UTC
REVIEW: http://review.gluster.org/12404 (tests/tier:  Move common functions to tier.rc) posted (#1) for review on master by N Balachandran (nbalacha@redhat.com)

Comment 2 Vijay Bellur 2015-10-21 07:22:18 UTC
REVIEW: http://review.gluster.org/12404 (tests/tier:  Move common functions to tier.rc) posted (#2) for review on master by N Balachandran (nbalacha@redhat.com)

Comment 3 Vijay Bellur 2015-10-21 15:01:02 UTC
REVIEW: http://review.gluster.org/12404 (tests/tier:  Move common functions to tier.rc) posted (#3) for review on master by N Balachandran (nbalacha@redhat.com)

Comment 4 Vijay Bellur 2015-10-22 02:47:43 UTC
COMMIT: http://review.gluster.org/12404 committed in master by Dan Lambright (dlambrig@redhat.com) 
------
commit 594a03b030577bf0ed6960199e920cc5fa7e7afc
Author: N Balachandran <nbalacha@redhat.com>
Date:   Tue Oct 20 22:23:17 2015 +0530

    tests/tier:  Move common functions to tier.rc
    
    Move common functions in tier .t files to tier.rc
    
    Change-Id: Ibc312d987be9d93e7cc7fc47d0bf598bb1c944c2
    BUG: 1272319
    Signed-off-by: N Balachandran <nbalacha@redhat.com>
    Reviewed-on: http://review.gluster.org/12404
    Tested-by: Gluster Build System <jenkins@build.gluster.com>
    Reviewed-by: Dan Lambright <dlambrig@redhat.com>
    Tested-by: Dan Lambright <dlambrig@redhat.com>

Comment 5 Nithya Balachandran 2015-10-30 09:45:56 UTC
*** Bug 1273317 has been marked as a duplicate of this bug. ***

Comment 6 Niels de Vos 2016-06-16 13:40:19 UTC
This bug is getting closed because a release has been made available that should address the reported issue. In case the problem is still not fixed with glusterfs-3.8.0, please open a new bug report.

glusterfs-3.8.0 has been announced on the Gluster mailinglists [1], packages for several distributions should become available in the near future. Keep an eye on the Gluster Users mailinglist [2] and the update infrastructure for your distribution.

[1] http://blog.gluster.org/2016/06/glusterfs-3-8-released/
[2] http://thread.gmane.org/gmane.comp.file-systems.gluster.user


Note You need to log in before you can comment on or make changes to this bug.