Bug 1278723 - Tier : Move common functions into tier.rc
Tier : Move common functions into tier.rc
Status: CLOSED ERRATA
Product: Red Hat Gluster Storage
Classification: Red Hat
Component: tier (Show other bugs)
3.1
Unspecified Unspecified
unspecified Severity unspecified
: ---
: RHGS 3.1.2
Assigned To: Bug Updates Notification Mailing List
nchilaka
: ZStream
Depends On: 1272319 1277590
Blocks:
  Show dependency treegraph
 
Reported: 2015-11-06 04:44 EST by Nithya Balachandran
Modified: 2016-09-17 11:39 EDT (History)
6 users (show)

See Also:
Fixed In Version: glusterfs-3.7.5-11
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: 1277590
Environment:
Last Closed: 2016-03-01 00:53:27 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Nithya Balachandran 2015-11-06 04:44:12 EST
+++ This bug was initially created as a clone of Bug #1277590 +++

+++ This bug was initially created as a clone of Bug #1272319 +++

Description of problem:
Functions are duplicated across .t files in the tiering regression tests. Move common functions into tier.rc

Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.

Actual results:


Expected results:


Additional info:

--- Additional comment from Vijay Bellur on 2015-10-20 13:00:16 EDT ---

REVIEW: http://review.gluster.org/12404 (tests/tier:  Move common functions to tier.rc) posted (#1) for review on master by N Balachandran (nbalacha@redhat.com)

--- Additional comment from Vijay Bellur on 2015-10-21 03:22:18 EDT ---

REVIEW: http://review.gluster.org/12404 (tests/tier:  Move common functions to tier.rc) posted (#2) for review on master by N Balachandran (nbalacha@redhat.com)

--- Additional comment from Vijay Bellur on 2015-10-21 11:01:02 EDT ---

REVIEW: http://review.gluster.org/12404 (tests/tier:  Move common functions to tier.rc) posted (#3) for review on master by N Balachandran (nbalacha@redhat.com)

--- Additional comment from Vijay Bellur on 2015-10-21 22:47:43 EDT ---

COMMIT: http://review.gluster.org/12404 committed in master by Dan Lambright (dlambrig@redhat.com) 
------
commit 594a03b030577bf0ed6960199e920cc5fa7e7afc
Author: N Balachandran <nbalacha@redhat.com>
Date:   Tue Oct 20 22:23:17 2015 +0530

    tests/tier:  Move common functions to tier.rc
    
    Move common functions in tier .t files to tier.rc
    
    Change-Id: Ibc312d987be9d93e7cc7fc47d0bf598bb1c944c2
    BUG: 1272319
    Signed-off-by: N Balachandran <nbalacha@redhat.com>
    Reviewed-on: http://review.gluster.org/12404
    Tested-by: Gluster Build System <jenkins@build.gluster.com>
    Reviewed-by: Dan Lambright <dlambrig@redhat.com>
    Tested-by: Dan Lambright <dlambrig@redhat.com>

--- Additional comment from Nithya Balachandran on 2015-10-30 05:45:56 EDT ---

--- Additional comment from Vijay Bellur on 2015-11-03 10:47:43 EST ---

REVIEW: http://review.gluster.org/12497 (tests/tier:  Move common functions to tier.rc) posted (#1) for review on release-3.7 by N Balachandran (nbalacha@redhat.com)

--- Additional comment from Vijay Bellur on 2015-11-03 13:44:43 EST ---

COMMIT: http://review.gluster.org/12497 committed in release-3.7 by Dan Lambright (dlambrig@redhat.com) 
------
commit 081e7938c8711aa7ce8a2955bb34767b697cf8b9
Author: N Balachandran <nbalacha@redhat.com>
Date:   Tue Nov 3 21:07:00 2015 +0530

    tests/tier:  Move common functions to tier.rc
    
    Move common functions in tier .t files to tier.rc
    
    > Change-Id: Ibc312d987be9d93e7cc7fc47d0bf598bb1c944c2
    > Signed-off-by: N Balachandran <nbalacha@redhat.com>
    > Reviewed-on: http://review.gluster.org/12404
    > Tested-by: Gluster Build System <jenkins@build.gluster.com>
    > Reviewed-by: Dan Lambright <dlambrig@redhat.com>
    > Tested-by: Dan Lambright <dlambrig@redhat.com>
    (cherry picked from commit 594a03b030577bf0ed6960199e920cc5fa7e7afc)
    
    Change-Id: Ie13bb86f85575164e62120e29bbbedb7789b0af5
    BUG: 1277590
    Signed-off-by: N Balachandran <nbalacha@redhat.com>
    Reviewed-on: http://review.gluster.org/12497
    Tested-by: Gluster Build System <jenkins@build.gluster.com>
    Reviewed-by: Dan Lambright <dlambrig@redhat.com>
    Tested-by: Dan Lambright <dlambrig@redhat.com>
Comment 2 nchilaka 2015-11-06 04:53:51 EST
Acking it as it is helpful for dev and don't see a direct impact on qe
Comment 3 nchilaka 2015-12-18 01:02:12 EST
Hi Nithya,
Can you kindly help me with what validation QE must do for this bug.
I feel it is ideal to be verified by dev?
Comment 4 Nithya Balachandran 2015-12-21 22:42:24 EST
Confirmed that the patch is available in the downstream branch:

commit eebaf41794c5fd03c30d044e934db2906c9c89b5
Author: Nithya Balachandran <nbalacha@redhat.com>
Date:   Fri Nov 6 15:42:51 2015 +0530

    tests/tier:  Move common functions to tier.rc
    
    Move common functions in tier .t files to tier.rc
    
    upstream patch : http://review.gluster.org/12404
Comment 5 nchilaka 2015-12-22 00:23:44 EST
As this bug was to make a check of the above mentioned patch, and that being resolved, I am moving it to verified after discussing with dev counterpart.
Comment 7 errata-xmlrpc 2016-03-01 00:53:27 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2016-0193.html

Note You need to log in before you can comment on or make changes to this bug.