Bug 1277625 - [abrt] nautilus: nautilus_file_is_in_recent(): nautilus killed by SIGABRT
Summary: [abrt] nautilus: nautilus_file_is_in_recent(): nautilus killed by SIGABRT
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Fedora
Classification: Fedora
Component: nautilus
Version: 23
Hardware: x86_64
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Matthias Clasen
QA Contact: Fedora Extras Quality Assurance
URL: https://retrace.fedoraproject.org/faf...
Whiteboard: abrt_hash:5c20b622b1d2dd00bdf911c9a6c...
: 1258635 1272744 1273179 1305663 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2015-11-03 16:49 UTC by Ricardo Ramos
Modified: 2016-02-14 22:38 UTC (History)
20 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2016-01-27 04:57:46 UTC
Type: ---


Attachments (Terms of Use)
File: backtrace (46.22 KB, text/plain)
2015-11-03 16:49 UTC, Ricardo Ramos
no flags Details
File: cgroup (190 bytes, text/plain)
2015-11-03 16:49 UTC, Ricardo Ramos
no flags Details
File: core_backtrace (19.35 KB, text/plain)
2015-11-03 16:49 UTC, Ricardo Ramos
no flags Details
File: dso_list (12.68 KB, text/plain)
2015-11-03 16:49 UTC, Ricardo Ramos
no flags Details
File: environ (862 bytes, text/plain)
2015-11-03 16:49 UTC, Ricardo Ramos
no flags Details
File: limits (1.29 KB, text/plain)
2015-11-03 16:49 UTC, Ricardo Ramos
no flags Details
File: maps (63.00 KB, text/plain)
2015-11-03 16:49 UTC, Ricardo Ramos
no flags Details
File: mountinfo (3.26 KB, text/plain)
2015-11-03 16:49 UTC, Ricardo Ramos
no flags Details
File: open_fds (1.92 KB, text/plain)
2015-11-03 16:49 UTC, Ricardo Ramos
no flags Details
File: proc_pid_status (1005 bytes, text/plain)
2015-11-03 16:49 UTC, Ricardo Ramos
no flags Details
File: var_log_messages (294 bytes, text/plain)
2015-11-03 16:49 UTC, Ricardo Ramos
no flags Details

Description Ricardo Ramos 2015-11-03 16:49:35 UTC
Description of problem:
I went to settings and then I choose to show files sorted by type from the dropdown, at that moment files crashed.

Version-Release number of selected component:
nautilus-3.18.1-1.fc23

Additional info:
reporter:       libreport-2.6.3
backtrace_rating: 4
cmdline:        /usr/bin/nautilus --gapplication-service
crash_function: nautilus_file_is_in_recent
executable:     /usr/bin/nautilus
global_pid:     2633
kernel:         4.2.3-300.fc23.x86_64
runlevel:       N 5
type:           CCpp
uid:            1000

Truncated backtrace:
Thread no. 1 (10 frames)
 #4 nautilus_file_is_in_recent at nautilus-file.c:7024
 #5 update_sort_criterion at nautilus-canvas-view.c:282
 #6 default_sort_order_changed_callback at nautilus-canvas-view.c:1514
 #11 g_settings_real_change_event at gsettings.c:386
 #12 ffi_call_unix64 at ../src/x86/unix64.S:76
 #13 ffi_call at ../src/x86/ffi64.c:525
 #14 g_cclosure_marshal_generic_va at gclosure.c:1600
 #15 _g_closure_invoke_va at gclosure.c:864
 #18 settings_backend_changed at gsettings.c:446
 #19 g_settings_backend_invoke_closure at gsettingsbackend.c:267

Comment 1 Ricardo Ramos 2015-11-03 16:49:40 UTC
Created attachment 1089136 [details]
File: backtrace

Comment 2 Ricardo Ramos 2015-11-03 16:49:41 UTC
Created attachment 1089137 [details]
File: cgroup

Comment 3 Ricardo Ramos 2015-11-03 16:49:43 UTC
Created attachment 1089138 [details]
File: core_backtrace

Comment 4 Ricardo Ramos 2015-11-03 16:49:44 UTC
Created attachment 1089139 [details]
File: dso_list

Comment 5 Ricardo Ramos 2015-11-03 16:49:46 UTC
Created attachment 1089140 [details]
File: environ

Comment 6 Ricardo Ramos 2015-11-03 16:49:47 UTC
Created attachment 1089141 [details]
File: limits

Comment 7 Ricardo Ramos 2015-11-03 16:49:49 UTC
Created attachment 1089142 [details]
File: maps

Comment 8 Ricardo Ramos 2015-11-03 16:49:51 UTC
Created attachment 1089143 [details]
File: mountinfo

Comment 9 Ricardo Ramos 2015-11-03 16:49:52 UTC
Created attachment 1089144 [details]
File: open_fds

Comment 10 Ricardo Ramos 2015-11-03 16:49:53 UTC
Created attachment 1089145 [details]
File: proc_pid_status

Comment 11 Ricardo Ramos 2015-11-03 16:49:55 UTC
Created attachment 1089146 [details]
File: var_log_messages

Comment 12 Carlos Soriano 2015-11-12 17:35:41 UTC
were you seraching or in recent or in some special location or directory?

Comment 13 Ricardo Ramos 2015-11-12 21:26:40 UTC
I wasn't searching for nothing, I was on home folder when I attempted to change the settings to sort files by type from the drop down menu.

Comment 14 Carlos Soriano 2015-11-12 22:00:15 UTC
thanks, found the problem, but it's one difficult to found the root and fix it.

Comment 15 Carlos Soriano 2015-11-13 17:50:47 UTC
*** Bug 1272744 has been marked as a duplicate of this bug. ***

Comment 16 Carlos Soriano 2015-11-13 17:51:10 UTC
*** Bug 1273179 has been marked as a duplicate of this bug. ***

Comment 18 Ricardo Ramos 2015-11-13 22:11:18 UTC
Wow! This was fast! I've reported other bugs and this is the only one I've seen fixed. Thanks.

Comment 19 Paul Lazaga 2015-11-16 05:39:06 UTC
Another user experienced a similar problem:

Right mouse click on loaded DVD icon on desktop.

reporter:       libreport-2.6.3
backtrace_rating: 4
cmdline:        /usr/bin/nautilus --gapplication-service
crash_function: nautilus_canvas_view_update_click_mode
executable:     /usr/bin/nautilus
global_pid:     26776
kernel:         4.2.5-300.fc23.x86_64
package:        nautilus-3.18.1-1.fc23
reason:         nautilus killed by SIGABRT
runlevel:       N 5
type:           CCpp
uid:            1001

Comment 20 Carlos Soriano 2015-11-18 14:33:44 UTC
*** Bug 1258635 has been marked as a duplicate of this bug. ***

Comment 21 Robin A. Meade 2015-11-24 19:47:53 UTC
Another user experienced a similar problem:

1. Open Nautilus
2. Application Menu > Preferences <== works fine
3. Close Preferences
4. Select Other Locations
5. Optionally, select anything else, like Videos or Home
6. Application Menu > Preferences <== Nautilus crashes


reporter:       libreport-2.6.3
backtrace_rating: 4
cmdline:        /usr/bin/nautilus --gapplication-service
crash_function: nautilus_file_is_in_trash
executable:     /usr/bin/nautilus
global_pid:     2994
kernel:         4.2.6-300.fc23.x86_64
package:        nautilus-3.18.2-2.fc23
reason:         nautilus killed by SIGABRT
runlevel:       N 5
type:           CCpp
uid:            1000

Comment 22 Mitsutoshi Kiuchi 2015-11-27 01:07:37 UTC
Another user experienced a similar problem:

1. cut multiple files on smb shared volume
2. move to parent directory
3. windows closed unexpectedly

reporter:       libreport-2.6.3
backtrace_rating: 4
cmdline:        nautilus -n
crash_function: nautilus_list_model_is_empty
executable:     /usr/bin/nautilus
global_pid:     2088
kernel:         4.2.6-300.fc23.x86_64
package:        nautilus-3.18.2-2.fc23
reason:         nautilus killed by SIGSEGV
runlevel:       N 5
type:           CCpp
uid:            1000

Comment 23 Sylvain Petreolle 2015-12-03 21:03:45 UTC
Another user experienced a similar problem:

I opened the preferences menu, clicking into the upside bar.

reporter:       libreport-2.6.3
backtrace_rating: 4
cmdline:        /usr/bin/nautilus --gapplication-service
crash_function: nautilus_file_is_in_trash
executable:     /usr/bin/nautilus
global_pid:     30934
kernel:         4.2.3-300.fc23.x86_64
package:        nautilus-3.18.2-2.fc23
reason:         nautilus killed by SIGABRT
runlevel:       N 5
type:           CCpp
uid:            500

Comment 24 Sylvain Petreolle 2015-12-13 13:50:13 UTC
This is fixed into version 3.18.3.
https://bugzilla.gnome.org/show_bug.cgi?id=753210#c12

Comment 25 Eduardo Zimmer 2016-02-06 18:59:57 UTC
Another user experienced a similar problem:

Uma tentativa de fazer a atualizacao do windows 8 para o windows 10 falhou. Entao reiniciei o computador pelo pen drive do Fedora. Enquanto eu estava tentando restaurar o windows 8 (copiando o conteudo da pasta Windows.old para a raiz do drive) eu cliquei em Preferences e entao travou.

reporter:       libreport-2.6.3
backtrace_rating: 3
cmdline:        /usr/bin/nautilus --gapplication-service
crash_function: nautilus_file_is_in_trash
executable:     /usr/bin/nautilus
global_pid:     2662
kernel:         4.2.3-300.fc23.i686
package:        nautilus-3.18.1-1.fc23
reason:         nautilus killed by SIGABRT
runlevel:       N 5
type:           CCpp
uid:            1000

Comment 26 xzj8b3 2016-02-08 20:33:12 UTC
*** Bug 1305663 has been marked as a duplicate of this bug. ***

Comment 27 Christian Stadelmann 2016-02-14 22:38:30 UTC
This bug is NOT fixed in 3.18.3, in fact it is still present in nautilus-3.18.5-1.fc23.x86_64. You can e.g. see that when looking at data on retrace servers. Please reopen this bug report. 

I ran into this issue when opening nautilus' menu from the "nautilus" symbol left of "previous"/"back" arrows and opened preferences. Instead of showing preferences nautilus crashed.


Note You need to log in before you can comment on or make changes to this bug.