Bug 1277649 - Move all the tests away from the lago repo to their own
Move all the tests away from the lago repo to their own
Status: CLOSED CURRENTRELEASE
Product: ovirt-system-tests
Classification: Community
Component: RFEs (Show other bugs)
2.0
Unspecified Unspecified
unspecified Severity unspecified
: milestone2
: 0.4
Assigned To: David Caro
Pavel Stehlik
ci
:
Depends On: 1279433
Blocks: 1279411 1278491
  Show dependency treegraph
 
Reported: 2015-11-03 12:52 EST by David Caro
Modified: 2016-04-24 07:29 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-04-24 07:29:57 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
oVirt gerrit 45886 master MERGED Remove unmaintained files and lago-ovirt-extras package Never
oVirt gerrit 48157 master MERGED Added 3.5 tests as they are now on lago rpm Never
oVirt gerrit 48200 master MERGED Running everything inside mock Never
oVirt gerrit 48481 master ABANDONED Removing unneeded files Never
oVirt gerrit 48505 master MERGED lago-ovirt-extras not needed anymore Never

  None (edit)
Description David Caro 2015-11-03 12:52:02 EST
Description of problem:
Right now all the tests and their configs are stored in the same repo as the code, that should be moved away to their own repo so their development is separated
 
Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.

Actual results:


Expected results:


Additional info:
Comment 1 Red Hat Bugzilla Rules Engine 2015-11-05 10:22:37 EST
Target release should be placed once a package build is known to fix a issue. Since this bug is not modified, the target version has been reset. Please use target milestone to plan a fix for a oVirt release.
Comment 2 Red Hat Bugzilla Rules Engine 2015-11-05 10:22:37 EST
This bug is not marked for z-stream, yet the milestone is for a z-stream version, therefore the milestone has been reset.
Please set the correct milestone or add the z-stream flag.
Comment 3 Eyal Edri 2015-11-05 10:31:22 EST
the priority for this bug is clear, once we split the code into 2 projects:
infra & tests, development can be in parallel for developing the infra capabilities and also starting to write tests.
Comment 4 Red Hat Bugzilla Rules Engine 2015-11-05 10:31:25 EST
Target release should be placed once a package build is known to fix a issue. Since this bug is not modified, the target version has been reset. Please use target milestone to plan a fix for a oVirt release.
Comment 5 Red Hat Bugzilla Rules Engine 2015-11-05 10:31:25 EST
This bug is not marked for z-stream, yet the milestone is for a z-stream version, therefore the milestone has been reset.
Please set the correct milestone or add the z-stream flag.
Comment 6 Eyal Edri 2015-11-05 10:31:51 EST
the priority for this bug is clear, once we split the code into 2 projects:
infra & tests, development can be in parallel for developing the infra capabilities and also starting to write tests.
Comment 7 Red Hat Bugzilla Rules Engine 2015-11-05 10:31:54 EST
Target release should be placed once a package build is known to fix a issue. Since this bug is not modified, the target version has been reset. Please use target milestone to plan a fix for a oVirt release.
Comment 8 Red Hat Bugzilla Rules Engine 2015-11-05 10:31:54 EST
This bug is not marked for z-stream, yet the milestone is for a z-stream version, therefore the milestone has been reset.
Please set the correct milestone or add the z-stream flag.
Comment 9 Eyal Edri 2015-11-05 10:55:57 EST
also, worth to mention we'll disable the ovirt-plugin logic within lago
and move the logic to the tests repo.

design of the plugin will be discussed in future milestones,
for simplicity we'll make sure the logic runs from the tests themselves.
Comment 10 Red Hat Bugzilla Rules Engine 2015-11-05 11:05:49 EST
This bug is not marked for z-stream, yet the milestone is for a z-stream version, therefore the milestone has been reset.
Please set the correct milestone or add the z-stream flag.
Comment 11 Red Hat Bugzilla Rules Engine 2015-11-05 11:49:09 EST
Target release should be placed once a package build is known to fix a issue. Since this bug is not modified, the target version has been reset. Please use target milestone to plan a fix for a oVirt release.
Comment 12 David Caro 2015-11-05 11:51:56 EST
The new repo is here:

https://gerrit.ovirt.org/#/admin/projects/ovirt-system-tests


(somehow I forgot that the rule is changing the target release all the time :/)
Comment 13 Eyal Edri 2015-11-12 04:55:02 EST
keeping on modified until the change will be included in latest 0.4 rpms.
Comment 14 David Caro 2015-11-12 05:16:22 EST
Missing removing it from lago
Comment 15 Red Hat Bugzilla Rules Engine 2015-11-12 05:16:27 EST
Target release should be placed once a package build is known to fix a issue. Since this bug is not modified, the target version has been reset. Please use target milestone to plan a fix for a oVirt release.

Note You need to log in before you can comment on or make changes to this bug.