This service will be undergoing maintenance at 00:00 UTC, 2016-09-28. It is expected to last about 1 hours
Bug 127797 - UTF-8 input doesn't work with xemacs
UTF-8 input doesn't work with xemacs
Status: CLOSED UPSTREAM
Product: Fedora
Classification: Fedora
Component: xorg-x11 (Show other bugs)
rawhide
i386 Linux
medium Severity high
: ---
: ---
Assigned To: X/OpenGL Maintenance List
David Lawrence
:
: 157357 157534 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-07-13 19:55 EDT by Horst H. von Brand
Modified: 2007-11-30 17:10 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-05-25 22:13:43 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
Answer to my question to the Xemacs bugs list (2.24 KB, text/plain)
2005-05-12 09:22 EDT, Horst H. von Brand
no flags Details


External Trackers
Tracker ID Priority Status Summary Last Updated
FreeDesktop.org 3392 None None None Never

  None (edit)
Description Horst H. von Brand 2004-07-13 19:55:08 EDT
Description of problem:
xemacs complains about UTF-8 input characters in text

Version-Release number of selected component (if applicable):
xemacs-21.4.15-5

How reproducible:
Always

Steps to Reproduce:
1. Open textfile with xemacs, LANG=en_US.UTF-8, keyboard is spanish
2. Enter an accented char, e.g. á
3.
  
Actual results:
Error message: "U00E1 not defined"

Expected results:
á in buffer/file

Additional info:
Comment 1 Ville Skyttä 2005-05-11 17:25:15 EDT
*** Bug 157357 has been marked as a duplicate of this bug. ***
Comment 2 Horst H. von Brand 2005-05-12 09:22:44 EDT
Created attachment 114292 [details]
Answer to my question to the Xemacs bugs list
Comment 3 Ville Skyttä 2005-05-13 14:43:27 EDT
Upstream says this is a X problem, so reassigning to xorg-x11 for comments.
Start of upstream thread is at
http://list-archive.xemacs.org/xemacs-beta/200505/msg00112.html
Comment 4 Mike A. Harris 2005-05-24 09:32:39 EDT
Please report this problem to X.Org at http://bugs.freedesktop.org, as
this issue will require upstream do review it, and make considerations
as to what the most correct fix is.  I suspect this will be in Ivan and
Sergey's department - the experts in this area of X.

Once you've filed your bug report to X.Org, if you paste the new
bug URL here, Red Hat will continue to track the issue in the
centralized X.Org bug tracker, and will review any bug fixes that
become available for consideration in future updates.

Setting status to "NEEDINFO", awaiting X.Org bug URL for tracking.
Comment 5 Mike A. Harris 2005-05-24 12:27:31 EDT
*** Bug 157534 has been marked as a duplicate of this bug. ***
Comment 6 Mike A. Harris 2005-05-25 22:13:43 EDT
Tracking bug http://freedesktop.org/bugzilla/show_bug.cgi?id=3392 in our
"UPSTREAM" tracker.

Note You need to log in before you can comment on or make changes to this bug.