Bug 127810 - Lack of /boot/message made lilo fale on update from RH9
Lack of /boot/message made lilo fale on update from RH9
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
2
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Jeremy Katz
Mike McLean
FC3
:
: 128078 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-07-14 00:47 EDT by Sampo Nurmentaus
Modified: 2007-11-30 17:10 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-02-01 18:35:50 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Sampo Nurmentaus 2004-07-14 00:47:38 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.6) Gecko/20040510

Description of problem:
I told anaconda to update my bootloader configuration
while updating. Installation went fine and anaconda
did not notice that somthing is wrong. First boot
tried to load my old kernel from RH9 that failed
since it was not able to load any modules.

I booted using rescue mode of the CD and
found out that anaconda had updated /etc/lilo.conf,
but running lilo failed due to missing /boot/message,
which is of course a critical error condition. 

echo "Yesterday, all my troubles seemed so far away" >/boot/message
lilo

Fixed everything and fedora booted up.

So there is actually two problems.

1) lilo failing for a very stubid reason
2) anaconda not noticing it.

Version-Release number of selected component (if applicable):


How reproducible:
Didn't try

Steps to Reproduce:
1.Existing lilo installation
2.Ask anaconda to update it 
3.Watch it crassing?

    

Actual Results:  Did not try to update an RH9 again :-)

Additional info:

Check that lilo actually is run ok would be nice
and also ensuring that there is /boot/message.

Or remove the option to update lilo and live only
with grub. Would be good for conservative people like
me, sticking with their old habits.
Comment 1 Sampo Nurmentaus 2004-07-14 00:49:23 EDT
May be related to bug #76177
Comment 2 Bill Nottingham 2004-08-05 14:24:18 EDT
*** Bug 128078 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.