This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours
Bug 127819 - Could not set exec context to root:sysadm_r:rpm_t
Could not set exec context to root:sysadm_r:rpm_t
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: up2date (Show other bugs)
rawhide
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Adrian Likins
Fanny Augustin
:
: 128097 (view as bug list)
Depends On:
Blocks: FC3Target
  Show dependency treegraph
 
Reported: 2004-07-14 06:53 EDT by Tim Raats
Modified: 2007-11-30 17:10 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-08-26 15:16:51 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Tim Raats 2004-07-14 06:53:27 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7) Gecko/20040625

Description of problem:
When I try to download an program with Up2Date via a terminal I get a
strange error: Could not set exec context to root:sysadm_r:rpm_t. In
other versions this works without the output

Version-Release number of selected component (if applicable):
up2date-4.3.19-1.1

How reproducible:
Always

Steps to Reproduce:
1. Open terminal
2. Type: up2date
    

Actual Results:  Could not set exec context to root:sysadm_r:rpm_t

Expected Results:  Updating of up2date or when you do: up2date xmms.
xmms should have been downloaded

Additional info:
Comment 1 Wolfgang Richter 2004-07-22 21:08:26 EDT
I have this exact same problem with Fedora Test Release 3.  My bug
report is #128078.  I think this might have something to do with
SELinux  ? But I am not sure.
Comment 2 Bill Nottingham 2004-08-05 14:24:30 EDT
*** Bug 128078 has been marked as a duplicate of this bug. ***
Comment 3 Bill Nottingham 2004-08-05 15:05:45 EDT
*** Bug 128097 has been marked as a duplicate of this bug. ***
Comment 4 J.Jansen 2004-08-12 18:05:40 EDT
I just installed FC3-test1 and got the same problem.
To me it seems a problem of a wrong PATH. If I give the command
"su" and than "up2date" I get the error message.
If do "su -" and "up2date" up2date starts normal.

This error probably is the cause that I cannot launche up2date from the
notifier window.
Comment 5 john nap 2004-09-10 16:55:13 EDT
Same problem on my end, doing the "su -" instead of "su" from the
terminal window solved the problem, so it must be an env issue.

Note You need to log in before you can comment on or make changes to this bug.