Bug 1278410 - Edit menu for CFME database backup schedule displays a wrong Starting time.
Edit menu for CFME database backup schedule displays a wrong Starting time.
Status: CLOSED DUPLICATE of bug 1274270
Product: Red Hat CloudForms Management Engine
Classification: Red Hat
Component: Appliance (Show other bugs)
5.4.0
Unspecified Unspecified
high Severity high
: GA
: 5.6.0
Assigned To: Tim Wade
Dave Johnson
:
Depends On:
Blocks: 1290192 1297005
  Show dependency treegraph
 
Reported: 2015-11-05 07:11 EST by Nikhil Gupta
Modified: 2016-01-08 12:08 EST (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
: 1290192 (view as bug list)
Environment:
Last Closed: 2015-12-15 11:37:19 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: Bug
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
schedule screenshot (54.69 KB, image/png)
2015-11-05 07:11 EST, Nikhil Gupta
no flags Details
Edit schedule (69.98 KB, image/png)
2015-11-05 07:12 EST, Nikhil Gupta
no flags Details
Cancel schedule (58.22 KB, image/png)
2015-11-05 07:14 EST, Nikhil Gupta
no flags Details


External Trackers
Tracker ID Priority Status Summary Last Updated
Red Hat Knowledge Base (Solution) 2042273 None None None Never

  None (edit)
Description Nikhil Gupta 2015-11-05 07:11:57 EST
Created attachment 1090041 [details]
schedule screenshot

Description of problem:
I have set a CFME database backup schedule. I can view it by navigating to Configure -> Configuration -> Settings accordion -> Schedules, I select the "DBBackup" schedule (see attached screenshot dbbackup-2.png).

Next schedule is planned for  11/5 at 3:45 CET 2015.

But if I edit the schedule (see attached screenshot dbbackup-3.png), it shows:
Timezone: GMT+01:00 (Paris)
Starting date: 11/5/2015
Starting time (Paris): 2h45mn

The time is not Paris time, but GMT+00:00 time (the appliance timezone is GMT+01:00 (Paris)).

If I cancel the edit without doing any change, and go back to the view, time is displayed correctly. (see attached screenshot dbbackup-4.png).

Version-Release number of selected component (if applicable):
5.4.0.5.20150605150206_7daa1a8 

How reproducible:
Always

Steps to Reproduce:
1. Configure -> Configuration, Settings accordion -> Schedules
2. Configuration -> Add a new schedule -> Select 'Database Backup' Action 
3. Fill required details 
   Timezone: GMT+01:00 (Paris)
   Starting date: 11/5/2015
   Starting time (Paris): 3h45mn
   Save
4. Next schedule is planned for  11/5 at 3:45 CET 2015.
5. Now edit the same schedule, Starting time (Paris) shows GMT+00:00 time
   Starting time (Paris): 2h45mn

Actual results:
Starting time (Paris) shows GMT+00:00 time

Expected results:
Starting time (Paris) should show GMT+01:00 time which is 3h45mn in this case.

Additional info:
This is happening in all timezones except UTC.
Comment 2 Nikhil Gupta 2015-11-05 07:12 EST
Created attachment 1090042 [details]
Edit schedule
Comment 3 Nikhil Gupta 2015-11-05 07:14 EST
Created attachment 1090043 [details]
Cancel schedule
Comment 4 Tim Wade 2015-11-06 18:06:35 EST
Hi Nikhil,

I've tried to reproduce this in 5.5.z and have been unable to. Could you possibly provide any other details of your environment, and/or configuration if any changes were made? Thanks
Comment 6 Tim Wade 2015-12-15 11:37:19 EST
Nikhil,

I didn't see this at first, because it's already been fixed in https://github.com/ManageIQ/manageiq/commit/32b9cb23c0828f9daaff516d9cbec7e518bfa28d. It's now clear that this is a duplicate of https://bugzilla.redhat.com/show_bug.cgi?id=1274270, so I'll close this ticket.

*** This bug has been marked as a duplicate of bug 1274270 ***

Note You need to log in before you can comment on or make changes to this bug.