Bug 127892 - swap uuid/label support
Summary: swap uuid/label support
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Fedora
Classification: Fedora
Component: anaconda   
(Show other bugs)
Version: rawhide
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Jeremy Katz
QA Contact: Mike McLean
URL:
Whiteboard: FC3
Keywords:
Depends On:
Blocks: FC3Target 133260
TreeView+ depends on / blocked
 
Reported: 2004-07-14 22:38 UTC by Elliot Lee
Modified: 2007-11-30 22:10 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-03-22 03:57:43 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Elliot Lee 2004-07-14 22:38:40 UTC
Here's what the swap header looks like:

At offset 0, the structure:
struct swap_header_v1_1 {
        char         uuid[16];
        char         volume_name[16];
	char         bootbits[1024-32];    /* Space for disklabel */
	unsigned int version;
	unsigned int last_page;
	unsigned int nr_badpages;
	unsigned int padding[125];
	unsigned int badpages[1];
};

At offset getpagesize()-10, the characters "SWAPSPACE2".

mkswap will have a -L label, and swapon will start accepting UUID= and
LABEL=, and that should about be it.

Comment 1 Jeremy Katz 2004-09-27 21:32:58 UTC
mkswap doesn't have a -L option right now, which is going to make this
kind of difficult to do :-)

What's up with the util-linux side?

Comment 2 Jeremy Katz 2004-09-28 21:14:20 UTC
Added anaconda support in CVS.  Swaps will be labeled as SWAP-device.

Comment 3 Milan Kerslager 2004-12-07 20:00:04 UTC
So how to create label at post-install time on RHEL4 Beta 2?

Comment 4 Joshua Jensen 2005-03-22 05:53:04 UTC
Yes, how does one create such a label?

Comment 5 Milan Kerslager 2005-03-29 16:31:08 UTC
See the bug #152026 (RHEL4 related).


Note You need to log in before you can comment on or make changes to this bug.