Bug 1279070 - Thunar crashes while doing cut&paste
Thunar crashes while doing cut&paste
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: Thunar (Show other bugs)
rawhide
x86_64 Linux
unspecified Severity urgent
: ---
: ---
Assigned To: Mukundan Ragavan
Fedora Extras Quality Assurance
: Reopened
: 1279227 1281434 1282942 1285087 1285892 1294950 1297224 1306434 1313083 1313087 1321160 1328810 1335735 1366781 1371473 1379124 1382229 1401711 1405765 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-11-07 12:05 EST by htd
Modified: 2017-02-25 20:35 EST (History)
33 users (show)

See Also:
Fixed In Version: Thunar-1.6.10-6.fc23 Thunar-1.6.10-6.fc24 Thunar-1.6.10-5.el7 Thunar-1.6.11-1.fc25
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2017-02-25 20:35:46 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
File: backtrace (21.67 KB, text/plain)
2015-11-18 09:55 EST, Michael
no flags Details


External Trackers
Tracker ID Priority Status Summary Last Updated
Xfce 12260 None None None Never
Xfce 12264 None None None 2016-05-19 22:11 EDT

  None (edit)
Description htd 2015-11-07 12:05:01 EST
Description of problem:
Thunar crashes while copying/pasting a file

Version-Release number of selected component (if applicable):
Thunar-1.6.10-1.fc23.x86_64

How reproducible:
Always

Steps to Reproduce:
1.Copy & paste any file from one to another directory
2.
3.

Actual results:
Thunar segfaults

Expected results:
Works

Additional info:
Here is the log:
Thunar[1653]: segfault at 2 ip 00007f87c2a2c07d sp 00007fff45204d98 error 4 in libgobject-2.0.so.0.4600.1[7f87c29f8000+50000]

There are other users encountering this, see e.g.
https://bbs.archlinux.org/viewtopic.php?id=203663&p=2
Comment 1 htd 2015-11-07 12:24:09 EST
This must be "cut & paste" (move a file), not "copy & paste". Sorry!!
Comment 2 Mukundan Ragavan 2015-11-08 08:25:47 EST
Upstream bug exists and I think it's the same issue (cut/copy) and paste ... We'll wait for resolution there ...
Comment 3 htd 2015-11-09 01:35:38 EST
See https://bugzilla.xfce.org/show_bug.cgi?id=12260

The XFCE people demand a gdb debug session and backtraces of the bug. Unfortunately, it is not possible for me to do this, because gdb is missing required debuginfo on Fedora 23 (which can't be installed):

GDB says:
Starting program: /usr/bin/Thunar 
[Thread debugging using libthread_db enabled]
Using host libthread_db library "/lib64/libthread_db.so.1".
[Inferior 1 (process 2163) exited normally]
Missing separate debuginfos, use: dnf debuginfo-install bzip2-libs-1.0.6-17.fc23.x86_64 libgcc-5.1.1-4.fc23.x86_64
(gdb) 

Trying to do so results in:

[root@chiara ~]# dnf debuginfo-install bzip2-libs-1.0.6-17.fc23.x86_64 libgcc-5.1.1-4.fc23.x86_64
[....]
Package glibc-debuginfo-2.22-3.fc23.x86_64 is already installed, skipping.
Package nss-softokn-debuginfo-3.20.1-1.0.fc23.x86_64 is already installed, skipping.
Dependencies resolved.
Nothing to do.
Complete!


So I'm unable to help.
Comment 4 Kevin Fenzi 2015-11-10 17:26:40 EST
Odd. I don't know why dnf would not want to download those... 

You can get them via the buildsystem: https://koji.fedoraproject.org and search for the exact packages and versions you need and the debuginfo should be downloadable from there. 

It might also be that there are newer ones in the repos now, so you could try a: 

dnf update

and then reproduce?
Comment 5 htd 2015-11-11 01:05:41 EST
Dnf claims they are already installed (see my comment one step above), which in fact is the case, while gdb complains of them NOT being installed/available. So simply reinstalling or updating does not solve the problem. Besides, I have no clue how important these two packages are for debugging Thunar..
Comment 6 Kevin Fenzi 2015-11-12 11:46:19 EST
*** Bug 1281434 has been marked as a duplicate of this bug. ***
Comment 7 Kevin Fenzi 2015-11-17 16:58:25 EST
*** Bug 1282942 has been marked as a duplicate of this bug. ***
Comment 8 Michael 2015-11-18 09:55:05 EST
Another user experienced a similar problem:

i drag an drop files (*.png) on my Desktop in a (new) folder, thunar crashes "every time" 

reporter:       libreport-2.6.3
backtrace_rating: 4
cmdline:        Thunar --daemon
crash_function: thunar_file_info_clear
executable:     /usr/bin/thunar
global_pid:     1622
kernel:         4.2.5-300.fc23.x86_64
package:        Thunar-1.6.10-2.fc23
reason:         thunar killed by SIGABRT
runlevel:       N 5
type:           CCpp
uid:            1000
Comment 9 Michael 2015-11-18 09:55:12 EST
Created attachment 1096120 [details]
File: backtrace
Comment 10 Mukundan Ragavan 2015-12-05 17:40:07 EST
Can you give this build a spin and see if solves the problem?

https://koji.fedoraproject.org/koji/taskinfo?taskID=12075656
Comment 11 Mukundan Ragavan 2015-12-05 17:41:26 EST
I am setting NEEDINFO from reporter - Anyone else can test this of course.
Comment 12 htd 2015-12-06 04:47:10 EST
Tried your build for some 20 minutes, and I can't reproduce the crash any longer. Would you mind providing the .src.rpm or the patch you applied to fix this?
Comment 13 Mukundan Ragavan 2015-12-06 11:06:13 EST
Sure.

SRPM is here - https://nonamedotc.fedorapeople.org/thunar/

rpm2cpio Thunar-1.6.10-4.fc23.src.rpm | cpio -idmv

will provide you the patch.
Comment 14 Michael 2015-12-23 05:53:37 EST
Another user experienced a similar problem:

mkdir "new folder" (for screenshots, on my desktop)
copy&paste a screenshot from my XFCE desktop to the "new folder" 

reporter:       libreport-2.6.3
backtrace_rating: 4
cmdline:        /usr/bin/Thunar --daemon
crash_function: thunar_file_info_clear
executable:     /usr/bin/thunar
global_pid:     1799
kernel:         4.2.8-300.fc23.x86_64
package:        Thunar-1.6.10-2.fc23
reason:         thunar killed by SIGABRT
runlevel:       N 5
type:           CCpp
uid:            1000
Comment 15 Benjamin Ariel Nava Martinez 2015-12-30 16:56:41 EST
Another user experienced a similar problem:

I just cut a file (CTRL+X) and pasted it somewhere else (CTRL+V). It doesn't happen everytime, but very often, say, 90% of the time.

reporter:       libreport-2.6.3
backtrace_rating: 4
cmdline:        thunar /home/ariel/Descargas
crash_function: thunar_file_info_clear
executable:     /usr/bin/thunar
global_pid:     27909
kernel:         4.2.3-300.fc23.x86_64
package:        Thunar-1.6.10-2.fc23
reason:         thunar killed by SIGSEGV
runlevel:       N 5
type:           CCpp
uid:            1000
Comment 16 Mukundan Ragavan 2015-12-31 12:23:43 EST
*** Bug 1294950 has been marked as a duplicate of this bug. ***
Comment 17 William Cummings 2016-01-01 05:36:36 EST
Another user experienced a similar problem:

Cut a file from one folder, then select the folder to paste into, then hit Paste

reporter:       libreport-2.6.3
backtrace_rating: 4
cmdline:        thunar
crash_function: g_malloc
executable:     /usr/bin/thunar
global_pid:     3647
kernel:         4.2.8-300.fc23.i686
package:        Thunar-1.6.10-2.fc23
reason:         thunar killed by SIGSEGV
runlevel:       N 5
type:           CCpp
uid:            1000
Comment 18 Mukundan Ragavan 2016-01-12 17:10:53 EST
*** Bug 1297224 has been marked as a duplicate of this bug. ***
Comment 19 Mukundan Ragavan 2016-01-20 19:26:16 EST
*** Bug 1279227 has been marked as a duplicate of this bug. ***
Comment 20 Gabirel 2016-02-02 14:55:29 EST
Another user experienced a similar problem:

A1: When I cut files(about 76G shared by 7 folders) into one empty folder

A2:You can do cutting like this

A3:I don't know too much of all these stuff, So, I don't know,maybe yes. 

reporter:       libreport-2.6.3
backtrace_rating: 4
cmdline:        /usr/bin/Thunar --daemon
crash_function: thunar_file_info_clear
executable:     /usr/bin/thunar
global_pid:     6792
kernel:         4.3.4-300.fc23.x86_64
package:        Thunar-1.6.10-2.fc23
reason:         thunar killed by SIGABRT
runlevel:       N 5
type:           CCpp
uid:            1000
Comment 21 Kevin Fenzi 2016-02-11 18:10:25 EST
*** Bug 1306434 has been marked as a duplicate of this bug. ***
Comment 22 Kevin Fenzi 2016-02-29 18:40:09 EST
*** Bug 1313083 has been marked as a duplicate of this bug. ***
Comment 23 Kevin Fenzi 2016-02-29 18:40:21 EST
*** Bug 1313087 has been marked as a duplicate of this bug. ***
Comment 24 Luca Ciavatta 2016-03-16 00:17:51 EDT
Similar problem has been detected:

It happens moving a folder from a tab to another.

reporter:       libreport-2.6.4
backtrace_rating: 4
cmdline:        /usr/bin/Thunar file:///home/cialu/Desktop/Quote-Academy
crash_function: g_type_check_instance_is_fundamentally_a
executable:     /usr/bin/thunar
global_pid:     5490
kernel:         4.4.4-301.fc23.x86_64
package:        Thunar-1.6.10-2.fc23
reason:         thunar killed by SIGSEGV
runlevel:       N 5
type:           CCpp
uid:            1000
Comment 25 Gregory Seaborn 2016-03-16 13:15:18 EDT
Similar problem has been detected:

Just moving files (mostly jpg) out of my download folder into the pictures folder

reporter:       libreport-2.6.4
backtrace_rating: 4
cmdline:        /bin/thunar
crash_function: thunar_file_info_clear
executable:     /usr/bin/thunar
global_pid:     12525
kernel:         4.4.4-301.fc23.x86_64
package:        Thunar-1.6.10-2.fc23
reason:         thunar killed by SIGABRT
runlevel:       N 5
type:           CCpp
uid:            1000
Comment 26 Marius Ghita 2016-03-17 19:38:17 EDT
Similar problem has been detected:

If I cut and paste *multiple* files with Thunar between folders it crashes. Can replicate it some times between moves on the same disk, and between different disks, but most consistent with moves on the second disk (not the root mount).

In my setup there are the following folders (in $HOME) I'll use for examples:

~/Downloads -> /media/mhitza/Downloads
~/Media -> /media/mhitza/Media
~/Workspace

Where /media is a mount of my second disk:
/dev/sdb2 /media ext4 rw,seclabel,relatime,data=ordered 0 0

For each example I'll open a fresh new Thundar instance:
1. Move multiple files from Downloads to Media, CRASH
2. Move multiple files from Media to Downloads, CRASH
3. Move multiple files from Downloads to Workspace, OK
4. Move multiple files from Workspace to Downloads, OK
5. Move multiple times the files around my Home and Workspace folder, EVENTUALLY CRASHES (inconsistent)

reporter:       libreport-2.6.4
backtrace_rating: 4
cmdline:        Thunar --daemon
crash_function: thunar_file_info_clear
executable:     /usr/bin/thunar
global_pid:     1740
kernel:         4.4.4-301.fc23.x86_64
package:        Thunar-1.6.10-2.fc23
reason:         thunar killed by SIGABRT
runlevel:       N 5
type:           CCpp
uid:            1000
Comment 27 Arjen Heidinga 2016-03-24 04:37:44 EDT
Similar problem has been detected:

Dragged folder Documents from homedir to the Desktop (not the folder, but the actual desktop). The goal was to create a link, but I moved it insted. The move was successfull, however Thunar crashed.

reporter:       libreport-2.6.4
backtrace_rating: 4
cmdline:        /usr/bin/Thunar --daemon
crash_function: g_type_check_instance_is_fundamentally_a
executable:     /usr/bin/thunar
global_pid:     12138
kernel:         4.4.5-300.fc23.x86_64
package:        Thunar-1.6.10-2.fc23
reason:         thunar killed by SIGSEGV
runlevel:       N 5
type:           CCpp
uid:            1000
Comment 28 Mukundan Ragavan 2016-03-24 17:47:48 EDT
*** Bug 1321160 has been marked as a duplicate of this bug. ***
Comment 29 xinnx009 2016-03-28 01:51:41 EDT
Similar problem has been detected:

Draged a shortcut from my desktop to a thunar window in my home folder.

reporter:       libreport-2.6.4
backtrace_rating: 4
cmdline:        /usr/bin/Thunar --daemon
crash_function: thunar_file_info_clear
executable:     /usr/bin/thunar
global_pid:     4692
kernel:         4.4.6-300.fc23.x86_64
package:        Thunar-1.6.10-2.fc23
reason:         thunar killed by SIGABRT
runlevel:       N 5
type:           CCpp
uid:            1000
Comment 30 Mukundan Ragavan 2016-03-28 21:08:46 EDT
There was a patch submitted in the upstream bug report that seemed to work rather well for at least one person.

I have rebuilt Thunar with two patches from the upstream bug report. Can folks here test these builds?

https://nonamedotc.fedorapeople.org/thunar-fix/

The page linked above has packages for rawhide, f24, f23 and f22 on x86_64, i686 and arm arches.
Comment 31 Mukundan Ragavan 2016-04-02 16:52:28 EDT
*** Bug 1285087 has been marked as a duplicate of this bug. ***
Comment 32 Mukundan Ragavan 2016-04-02 16:55:22 EDT
*** Bug 1285892 has been marked as a duplicate of this bug. ***
Comment 33 Dan Beard 2016-04-09 14:35:30 EDT
Ayup.   Add me to the list.   

F23 Thunar 1.6.10

Both cut & paste and drag & drop between both tabs and windows effectively kills Thunar.
Comment 34 Dan Beard 2016-04-09 14:48:51 EDT
Testing with https://nonamedotc.fedorapeople.org/thunar-fix/ fails to duplicate the problem.   SO far, so good.
Comment 35 Mukundan Ragavan 2016-04-20 14:18:04 EDT
*** Bug 1328810 has been marked as a duplicate of this bug. ***
Comment 36 iakovos Gurulian 2016-04-25 06:44:57 EDT
Patched version looks to have fixed the issue. The problem is that the unpatched version didn't always crash, so hard to tell for sure.
Comment 37 Timothy Redmond 2016-04-28 09:01:49 EDT
Similar problem has been detected:

When I drag and drop a file from one Thunar window to another one sometimes I get a crash.  The move operation succeeds.  In this case, I was dragging from the desktop and not from another Thunar application.  The workaround is simple - re-open Thunar and continue what you were doing.

reporter:       libreport-2.6.4
backtrace_rating: 4
cmdline:        Thunar --daemon
crash_function: thunar_file_info_clear
executable:     /usr/bin/thunar
global_pid:     1861
kernel:         4.4.7-300.fc23.x86_64
package:        Thunar-1.6.10-2.fc23
reason:         thunar killed by SIGABRT
runlevel:       N 5
type:           CCpp
uid:            1000
Comment 38 bitchecker 2016-04-30 17:06:48 EDT
Similar problem has been detected:

cut and paste of more then one file from a directory to another

reporter:       libreport-2.6.4
backtrace_rating: 4
cmdline:        Thunar --daemon
crash_function: thunar_file_info_clear
executable:     /usr/bin/thunar
global_pid:     1546
kernel:         4.4.8-300.fc23.x86_64
package:        Thunar-1.6.10-2.fc23
reason:         thunar killed by SIGABRT
runlevel:       N 5
type:           CCpp
uid:            1000
Comment 39 Mukundan Ragavan 2016-04-30 17:36:45 EDT
Can folks try the build detailed in comment #30 and provide feedback?

Thanks.
Comment 40 htd 2016-05-01 02:34:16 EDT
A build based on #30 does still produce the crashes reported here, at least on my system. F23-x64.
Comment 41 Marius Ghita 2016-05-01 20:07:14 EDT
(In reply to Mukundan Ragavan from comment #39)
> Can folks try the build detailed in comment #30 and provide feedback?
> 
> Thanks.

I've just tested myself as well and can't reproduce the issue.
Comment 42 Panu Matilainen 2016-05-02 00:56:05 EDT
(In reply to htd from comment #40)
> A build based on #30 does still produce the crashes reported here, at least
> on my system. F23-x64.

Are you sure you completely restarted Thunar so there's no old version running in the background?

Anyway, as for me, I haven't used the actual build in #30 but my own build with the same patch from upstream bugzilla applied, no more crashes.
Comment 43 Mukundan Ragavan 2016-05-02 20:07:06 EDT
(In reply to htd from comment #40)
> A build based on #30 does still produce the crashes reported here, at least
> on my system. F23-x64.

I wonder if you completely killed Thunar (instance, daemon, everything) after installing the patched build.

Can you please check?
Comment 44 bitchecker 2016-05-04 05:43:08 EDT
Similar problem has been detected:

cut & paste of multiple files from a directory to another

reporter:       libreport-2.6.4
backtrace_rating: 4
cmdline:        Thunar --daemon
crash_function: g_type_check_instance_is_fundamentally_a
executable:     /usr/bin/thunar
global_pid:     1479
kernel:         4.4.8-300.fc23.x86_64
package:        Thunar-1.6.10-2.fc23
reason:         thunar killed by SIGSEGV
runlevel:       N 5
type:           CCpp
uid:            1000
Comment 45 htd 2016-05-04 06:21:39 EDT
(In reply to Mukundan Ragavan from comment #43)
> (In reply to htd from comment #40)
> > A build based on #30 does still produce the crashes reported here, at least
> > on my system. F23-x64.
> 
> I wonder if you completely killed Thunar (instance, daemon, everything)
> after installing the patched build.
> 
> Can you please check?

I reinstallet Thunar and then rebooted.
Comment 46 bitchecker 2016-05-04 10:45:43 EDT
Similar problem has been detected:

cut & paste multiple files from a directory to another

reporter:       libreport-2.6.4
backtrace_rating: 4
cmdline:        /usr/bin/Thunar --daemon
crash_function: thunar_file_info_clear
executable:     /usr/bin/thunar
global_pid:     11115
kernel:         4.4.8-300.fc23.x86_64
package:        Thunar-1.6.10-2.fc23
reason:         thunar killed by SIGABRT
runlevel:       N 5
type:           CCpp
uid:            1000
Comment 47 Mukundan Ragavan 2016-05-13 19:23:03 EDT
*** Bug 1335735 has been marked as a duplicate of this bug. ***
Comment 48 vihochiamatiamici 2016-05-14 06:09:39 EDT
Similar problem has been detected:

I copied a folder containing some files using "drag and drop" from desktop to my ownCloud local folder.

reporter:       libreport-2.6.4
backtrace_rating: 4
cmdline:        /usr/bin/Thunar --daemon
crash_function: thunar_file_info_clear
executable:     /usr/bin/thunar
global_pid:     3392
kernel:         4.4.9-300.fc23.x86_64
package:        Thunar-1.6.10-2.fc23
reason:         thunar killed by SIGABRT
runlevel:       N 5
type:           CCpp
uid:            1000
Comment 49 Benjamin Ariel Nava Martinez 2016-05-14 16:58:01 EDT
Similar problem has been detected:

I cut and pasted several items (including dirs and files) from a directory to its parent directory (Ctrl+X → Ctrl+Up → Ctrl+V).

reporter:       libreport-2.6.4
backtrace_rating: 4
cmdline:        Thunar --daemon
crash_function: g_type_check_instance_is_fundamentally_a
executable:     /usr/bin/thunar
global_pid:     1650
kernel:         4.4.9-300.fc23.x86_64
package:        Thunar-1.6.10-2.fc23
reason:         thunar killed by SIGSEGV
runlevel:       N 5
type:           CCpp
uid:            1000
Comment 50 xinode 2016-05-18 11:03:57 EDT
Similar problem has been detected:

Simply copy-pasting a folder seems to have caused Thunar to crash, it seems however that this only happens on occasion, sometimes with a succesful copy and sometimes wihtout.

reporter:       libreport-2.6.4
backtrace_rating: 4
cmdline:        /usr/bin/Thunar
crash_function: g_type_check_instance_is_fundamentally_a
executable:     /usr/bin/thunar
global_pid:     29536
kernel:         4.4.6-301.fc23.x86_64
package:        Thunar-1.6.10-2.fc23
reason:         thunar killed by SIGSEGV
runlevel:       N 5
type:           CCpp
uid:            1000
Comment 51 Mukundan Ragavan 2016-05-18 21:13:01 EDT
Thinking out loud - I am very inclined to add the two patches using which I have built Thunar on comment #30 and push it to the repos ..

It does not complete solve the issue for sure but it certainly greatly mitigates the crashes as far as I can tell.

kevin, thoughts?
Comment 52 Kevin Fenzi 2016-05-18 21:55:08 EDT
Sounds like a good plan to me. ;)
Comment 53 Fedora Update System 2016-05-19 23:04:15 EDT
Thunar-1.6.10-6.fc24 has been submitted as an update to Fedora 24. https://bodhi.fedoraproject.org/updates/FEDORA-2016-86fa11fe0c
Comment 54 Fedora Update System 2016-05-19 23:04:35 EDT
Thunar-1.6.10-6.fc23 has been submitted as an update to Fedora 23. https://bodhi.fedoraproject.org/updates/FEDORA-2016-97f26c74c3
Comment 55 Fedora Update System 2016-05-19 23:04:47 EDT
Thunar-1.6.10-5.el7 has been submitted as an update to Fedora EPEL 7. https://bodhi.fedoraproject.org/updates/FEDORA-EPEL-2016-edcd46fc9f
Comment 56 bitchecker 2016-05-20 10:32:33 EDT
Similar problem has been detected:

cut & paste

reporter:       libreport-2.6.4
backtrace_rating: 4
cmdline:        Thunar --daemon
crash_function: thunar_file_info_clear
executable:     /usr/bin/thunar
global_pid:     1504
kernel:         4.4.9-300.fc23.x86_64
package:        Thunar-1.6.10-2.fc23
reason:         thunar killed by SIGABRT
runlevel:       N 5
type:           CCpp
uid:            1000
Comment 57 Fedora Update System 2016-05-20 21:31:27 EDT
Thunar-1.6.10-6.fc24 has been pushed to the Fedora 24 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2016-86fa11fe0c
Comment 58 Fedora Update System 2016-05-20 22:26:29 EDT
Thunar-1.6.10-6.fc23 has been pushed to the Fedora 23 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2016-97f26c74c3
Comment 59 Fedora Update System 2016-05-21 02:21:50 EDT
Thunar-1.6.10-5.el7 has been pushed to the Fedora EPEL 7 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-EPEL-2016-edcd46fc9f
Comment 60 bitchecker 2016-05-22 04:39:27 EDT
Similar problem has been detected:

cut & paste

reporter:       libreport-2.6.4
backtrace_rating: 4
cmdline:        Thunar --daemon
crash_function: thunar_file_info_clear
executable:     /usr/bin/thunar
global_pid:     1495
kernel:         4.4.9-300.fc23.x86_64
package:        Thunar-1.6.10-2.fc23
reason:         thunar killed by SIGABRT
runlevel:       N 5
type:           CCpp
uid:            1000
Comment 61 bitchecker 2016-05-22 05:36:35 EDT
Similar problem has been detected:

cut ù6 paste

reporter:       libreport-2.6.4
backtrace_rating: 4
cmdline:        thunar
crash_function: g_type_check_instance_is_fundamentally_a
executable:     /usr/bin/thunar
global_pid:     13729
kernel:         4.4.9-300.fc23.x86_64
package:        Thunar-1.6.10-2.fc23
reason:         thunar killed by SIGSEGV
runlevel:       N 5
type:           CCpp
uid:            1000
Comment 62 Konstantin Svist 2016-05-23 16:19:39 EDT
Similar problem has been detected:

moved some files from one directory (~/Desktop/) to another (~/Documents/)

reporter:       libreport-2.6.4
backtrace_rating: 4
cmdline:        Thunar --daemon
crash_function: thunar_file_info_clear
executable:     /usr/bin/thunar
global_pid:     1784
kernel:         4.4.9-300.fc23.x86_64
package:        Thunar-1.6.10-2.fc23
reason:         thunar killed by SIGABRT
runlevel:       N 5
type:           CCpp
uid:            1000
Comment 63 Fedora Update System 2016-05-23 21:24:08 EDT
Thunar-1.6.10-6.fc23 has been pushed to the Fedora 23 stable repository. If problems still persist, please make note of it in this bug report.
Comment 64 Fedora Update System 2016-05-25 16:02:58 EDT
Thunar-1.6.10-6.fc24 has been pushed to the Fedora 24 stable repository. If problems still persist, please make note of it in this bug report.
Comment 65 Fedora Update System 2016-06-05 02:48:35 EDT
Thunar-1.6.10-5.el7 has been pushed to the Fedora EPEL 7 stable repository. If problems still persist, please make note of it in this bug report.
Comment 66 Mukundan Ragavan 2016-09-01 19:25:55 EDT
Reopening

This is not completely fixed as crashes are still being reported both in fedora and upstream.
Comment 67 Mukundan Ragavan 2016-09-01 19:26:15 EDT
*** Bug 1371473 has been marked as a duplicate of this bug. ***
Comment 68 Mukundan Ragavan 2016-10-06 20:30:14 EDT
*** Bug 1382229 has been marked as a duplicate of this bug. ***
Comment 69 Mukundan Ragavan 2016-10-16 19:55:30 EDT
*** Bug 1379124 has been marked as a duplicate of this bug. ***
Comment 70 Mukundan Ragavan 2016-10-16 22:09:49 EDT
*** Bug 1366781 has been marked as a duplicate of this bug. ***
Comment 71 Mukundan Ragavan 2016-12-05 18:27:04 EST
*** Bug 1401711 has been marked as a duplicate of this bug. ***
Comment 72 Mukundan Ragavan 2016-12-18 13:06:41 EST
*** Bug 1405765 has been marked as a duplicate of this bug. ***
Comment 73 Fedora Update System 2017-02-14 22:15:08 EST
Thunar-1.6.11-1.fc25 has been submitted as an update to Fedora 25. https://bodhi.fedoraproject.org/updates/FEDORA-2017-9b303854c7
Comment 74 Fedora Update System 2017-02-17 10:24:52 EST
Thunar-1.6.11-1.fc25 has been pushed to the Fedora 25 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2017-9b303854c7
Comment 75 Fedora Update System 2017-02-25 20:35:46 EST
Thunar-1.6.11-1.fc25 has been pushed to the Fedora 25 stable repository. If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.