Bug 1279506 - Logging backtrace in metrics processing
Logging backtrace in metrics processing
Status: CLOSED ERRATA
Product: Red Hat CloudForms Management Engine
Classification: Red Hat
Component: C&U Capacity and Utilization (Show other bugs)
5.5.0
Unspecified Unspecified
medium Severity high
: GA
: 5.6.0
Assigned To: Ladislav Smola
Ola Pavlenko
openstack
:
Depends On:
Blocks: 1290212
  Show dependency treegraph
 
Reported: 2015-11-09 10:25 EST by Marius Cornea
Modified: 2017-08-29 23:46 EDT (History)
7 users (show)

See Also:
Fixed In Version: 5.6.0.0
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
: 1290212 (view as bug list)
Environment:
Last Closed: 2016-06-29 11:05:09 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Marius Cornea 2015-11-09 10:25:29 EST
Description of problem:
Currently the metrics collection shows unclear exception and we should log proper backtrace in the metrics processing. BZ#1279380 can be check as reference for such occurence.

Version-Release number of selected component (if applicable):
5.5.0.9-beta2.20151102161742_5530c9a
Comment 3 CFME Bot 2015-11-12 09:50:37 EST
New commit detected on ManageIQ/manageiq/master:
https://github.com/ManageIQ/manageiq/commit/b0dc1b1034cc67dd9a8d8dd6b354158ed6ffb617

commit b0dc1b1034cc67dd9a8d8dd6b354158ed6ffb617
Author:     Ladislav Smola <lsmola@redhat.com>
AuthorDate: Thu Nov 12 13:48:52 2015 +0100
Commit:     Ladislav Smola <lsmola@redhat.com>
CommitDate: Thu Nov 12 13:48:52 2015 +0100

    Log backtrace of queued job error
    
    Log backtrace of queued job error, otherwise it's almost
    impossible to track the error.
    
    In the BZ there is link to another BZ that had very hard
    to track exception message.
    
    Fixes BZ:
    https://bugzilla.redhat.com/show_bug.cgi?id=1279506

 app/models/miq_queue.rb | 2 +-
 1 file changed, 1 insertion(+), 1 deletion(-)
Comment 5 CFME Bot 2016-03-11 10:00:02 EST
New commit detected on cfme/5.5.z:
https://code.engineering.redhat.com/gerrit/gitweb?p=cfme.git;a=commitdiff;h=c766b21cd76805f2c19fb386eb18db06f4013c15

commit c766b21cd76805f2c19fb386eb18db06f4013c15
Author:     Ladislav Smola <lsmola@redhat.com>
AuthorDate: Thu Nov 12 13:48:52 2015 +0100
Commit:     Ladislav Smola <lsmola@redhat.com>
CommitDate: Mon Mar 7 11:12:04 2016 +0100

    Log backtrace of queued job error
    
    Log backtrace of queued job error, otherwise it's almost
    impossible to track the error.
    
    In the BZ there is link to another BZ that had very hard
    to track exception message.
    
    Fixes BZ:
    https://bugzilla.redhat.com/show_bug.cgi?id=1279506

 app/models/miq_queue.rb | 2 +-
 1 file changed, 1 insertion(+), 1 deletion(-)
Comment 6 CFME Bot 2016-03-11 10:00:07 EST
New commit detected on cfme/5.5.z:
https://code.engineering.redhat.com/gerrit/gitweb?p=cfme.git;a=commitdiff;h=934d6fa7d9c417370b61d819e3b6d7023cb6890f

commit 934d6fa7d9c417370b61d819e3b6d7023cb6890f
Merge: 5bac7f3 c766b21
Author:     Greg Blomquist <gblomqui@redhat.com>
AuthorDate: Fri Mar 11 09:40:45 2016 -0500
Commit:     Greg Blomquist <gblomqui@redhat.com>
CommitDate: Fri Mar 11 09:40:45 2016 -0500

    Merge branch 'bz1290212' into '5.5.z'
    
    Log backtrace of queued job error
    
    Log backtrace of queued job error, otherwise it's almost
    impossible to track the error.
    
    In the BZ there is link to another BZ that had very hard
    to track exception message.
    
    Fixes BZ:
    https://bugzilla.redhat.com/show_bug.cgi?id=1279506
    
    Clean cherry-pick of:
    https://github.com/ManageIQ/manageiq/pull/5402
    
    Fixes 5.5.z BZ:
    https://bugzilla.redhat.com/show_bug.cgi?id=1290212
    
    See merge request !838

 app/models/miq_queue.rb | 2 +-
 1 file changed, 1 insertion(+), 1 deletion(-)
Comment 8 errata-xmlrpc 2016-06-29 11:05:09 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2016:1348

Note You need to log in before you can comment on or make changes to this bug.