Bug 1279739 - libgfapi to support set_volfile-server-transport type "unix"
libgfapi to support set_volfile-server-transport type "unix"
Status: CLOSED CURRENTRELEASE
Product: GlusterFS
Classification: Community
Component: libgfapi (Show other bugs)
mainline
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Mohamed Ashiq
Sudhir D
:
Depends On:
Blocks: 1283038 1283040 1283563
  Show dependency treegraph
 
Reported: 2015-11-10 02:47 EST by Mohamed Ashiq
Modified: 2016-06-16 09:43 EDT (History)
1 user (show)

See Also:
Fixed In Version: glusterfs-3.8rc2
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
: 1283038 1283040 1283563 (view as bug list)
Environment:
Last Closed: 2016-06-16 09:43:35 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
test to reproduce the issue (1.36 KB, text/x-csrc)
2015-11-10 02:47 EST, Mohamed Ashiq
no flags Details

  None (edit)
Description Mohamed Ashiq 2015-11-10 02:47:21 EST
Created attachment 1092100 [details]
test to reproduce the issue

Description of problem:
libgfapi does not support unix domain socket. In case if glusterd is binded to a specific-IP, libgfapi clients(like heal) fails. Using unix domain socket libgfapi will over come the failure.


Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. Download the attached program.
2. Find the readme within the file.
3. Follow the instructions.
Comment 1 Mohamed Ashiq 2015-11-10 07:44:52 EST
patch:

http://review.gluster.org/12563
Comment 2 Vijay Bellur 2015-11-16 01:26:09 EST
REVIEW: http://review.gluster.org/12563 (libgfapi: To support set_volfile-server-transport type "unix") posted (#6) for review on master by Mohamed Ashiq Liyazudeen (mliyazud@redhat.com)
Comment 3 Vijay Bellur 2015-11-17 10:46:51 EST
COMMIT: http://review.gluster.org/12563 committed in master by Shyamsundar Ranganathan (srangana@redhat.com) 
------
commit f71c08b8d592fa6125fee57fb73f774ce522756c
Author: Mohamed Ashiq <mliyazud@redhat.com>
Date:   Tue Nov 10 13:18:41 2015 +0530

    libgfapi: To support set_volfile-server-transport type "unix"
    
    This patch helps libgfapi to get the volfile using Unix domain socket.
    run the attachment file in the bug to test.
    The patch checks if the glfs_set_volfile_server transport is of type "unix",
    If It is then uses rpc_transport_unix_options_build to get the volfile.
    
    Change-Id: Ifd5d1e7c0d8cc9a906c3c3355b8977141e892a2f
    BUG: 1279739
    Signed-off-by: Mohamed Ashiq <mliyazud@redhat.com>
    Signed-off-by: Humble Devassy Chirammal <hchiramm@redhat.com>
    Reviewed-on: http://review.gluster.org/12563
    Tested-by: NetBSD Build System <jenkins@build.gluster.org>
    Tested-by: Gluster Build System <jenkins@build.gluster.com>
    Reviewed-by: Niels de Vos <ndevos@redhat.com>
    Reviewed-by: Poornima G <pgurusid@redhat.com>
    Reviewed-by: Raghavendra Talur <rtalur@redhat.com>
    Reviewed-by: Shyamsundar Ranganathan <srangana@redhat.com>
Comment 4 Niels de Vos 2016-06-16 09:43:35 EDT
This bug is getting closed because a release has been made available that should address the reported issue. In case the problem is still not fixed with glusterfs-3.8.0, please open a new bug report.

glusterfs-3.8.0 has been announced on the Gluster mailinglists [1], packages for several distributions should become available in the near future. Keep an eye on the Gluster Users mailinglist [2] and the update infrastructure for your distribution.

[1] http://blog.gluster.org/2016/06/glusterfs-3-8-released/
[2] http://thread.gmane.org/gmane.comp.file-systems.gluster.user

Note You need to log in before you can comment on or make changes to this bug.