Bug 1283040 - libgfapi to support set_volfile-server-transport type "unix"
libgfapi to support set_volfile-server-transport type "unix"
Status: CLOSED DUPLICATE of bug 1283038
Product: GlusterFS
Classification: Community
Component: libgfapi (Show other bugs)
3.7.6
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: bugs@gluster.org
Sudhir D
:
Depends On: 1279739 1283563
Blocks:
  Show dependency treegraph
 
Reported: 2015-11-18 00:14 EST by Mohamed Ashiq
Modified: 2015-11-19 05:06 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: 1279739
Environment:
Last Closed: 2015-11-18 00:27:18 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Mohamed Ashiq 2015-11-18 00:14:21 EST
+++ This bug was initially created as a clone of Bug #1279739 +++

Description of problem:
libgfapi does not support unix domain socket. In case if glusterd is binded to a specific-IP, libgfapi clients(like heal) fails. Using unix domain socket libgfapi will over come the failure.


Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. Download the attached program.
2. Find the readme within the file.
3. Follow the instructions.

--- Additional comment from Mohamed Ashiq on 2015-11-10 07:44:52 EST ---

patch:

http://review.gluster.org/12563

--- Additional comment from Vijay Bellur on 2015-11-16 01:26:09 EST ---

REVIEW: http://review.gluster.org/12563 (libgfapi: To support set_volfile-server-transport type "unix") posted (#6) for review on master by Mohamed Ashiq Liyazudeen (mliyazud@redhat.com)

--- Additional comment from Vijay Bellur on 2015-11-17 10:46:51 EST ---

COMMIT: http://review.gluster.org/12563 committed in master by Shyamsundar Ranganathan (srangana@redhat.com) 
------
commit f71c08b8d592fa6125fee57fb73f774ce522756c
Author: Mohamed Ashiq <mliyazud@redhat.com>
Date:   Tue Nov 10 13:18:41 2015 +0530

    libgfapi: To support set_volfile-server-transport type "unix"
    
    This patch helps libgfapi to get the volfile using Unix domain socket.
    run the attachment file in the bug to test.
    The patch checks if the glfs_set_volfile_server transport is of type "unix",
    If It is then uses rpc_transport_unix_options_build to get the volfile.
    
    Change-Id: Ifd5d1e7c0d8cc9a906c3c3355b8977141e892a2f
    BUG: 1279739
    Signed-off-by: Mohamed Ashiq <mliyazud@redhat.com>
    Signed-off-by: Humble Devassy Chirammal <hchiramm@redhat.com>
    Reviewed-on: http://review.gluster.org/12563
    Tested-by: NetBSD Build System <jenkins@build.gluster.org>
    Tested-by: Gluster Build System <jenkins@build.gluster.com>
    Reviewed-by: Niels de Vos <ndevos@redhat.com>
    Reviewed-by: Poornima G <pgurusid@redhat.com>
    Reviewed-by: Raghavendra Talur <rtalur@redhat.com>
    Reviewed-by: Shyamsundar Ranganathan <srangana@redhat.com>
Comment 1 Mohamed Ashiq 2015-11-18 00:27:18 EST

*** This bug has been marked as a duplicate of bug 1283038 ***

Note You need to log in before you can comment on or make changes to this bug.