Bug 1283038 - libgfapi to support set_volfile-server-transport type "unix"
libgfapi to support set_volfile-server-transport type "unix"
Status: CLOSED CURRENTRELEASE
Product: GlusterFS
Classification: Community
Component: libgfapi (Show other bugs)
3.7.6
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Mohamed Ashiq
Sudhir D
:
: 1283040 (view as bug list)
Depends On: 1279739 1283563
Blocks:
  Show dependency treegraph
 
Reported: 2015-11-18 00:12 EST by Mohamed Ashiq
Modified: 2016-04-19 03:48 EDT (History)
2 users (show)

See Also:
Fixed In Version: glusterfs-3.7.7
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: 1279739
Environment:
Last Closed: 2016-04-19 03:48:11 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
test to reproduce the issue (1.36 KB, text/x-csrc)
2015-11-18 00:12 EST, Mohamed Ashiq
no flags Details

  None (edit)
Description Mohamed Ashiq 2015-11-18 00:12:36 EST
Created attachment 1095835 [details]
test to reproduce the issue

+++ This bug was initially created as a clone of Bug #1279739 +++

Description of problem:
libgfapi does not support unix domain socket. In case if glusterd is binded to a specific-IP, libgfapi clients(like heal) fails. Using unix domain socket libgfapi will over come the failure.


Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. Download the attached program.
2. Find the readme within the file.
3. Follow the instructions.

--- Additional comment from Mohamed Ashiq on 2015-11-10 07:44:52 EST ---

patch:

http://review.gluster.org/12563

--- Additional comment from Vijay Bellur on 2015-11-16 01:26:09 EST ---

REVIEW: http://review.gluster.org/12563 (libgfapi: To support set_volfile-server-transport type "unix") posted (#6) for review on master by Mohamed Ashiq Liyazudeen (mliyazud@redhat.com)

--- Additional comment from Vijay Bellur on 2015-11-17 10:46:51 EST ---

COMMIT: http://review.gluster.org/12563 committed in master by Shyamsundar Ranganathan (srangana@redhat.com) 
------
commit f71c08b8d592fa6125fee57fb73f774ce522756c
Author: Mohamed Ashiq <mliyazud@redhat.com>
Date:   Tue Nov 10 13:18:41 2015 +0530

    libgfapi: To support set_volfile-server-transport type "unix"
    
    This patch helps libgfapi to get the volfile using Unix domain socket.
    run the attachment file in the bug to test.
    The patch checks if the glfs_set_volfile_server transport is of type "unix",
    If It is then uses rpc_transport_unix_options_build to get the volfile.
    
    Change-Id: Ifd5d1e7c0d8cc9a906c3c3355b8977141e892a2f
    BUG: 1279739
    Signed-off-by: Mohamed Ashiq <mliyazud@redhat.com>
    Signed-off-by: Humble Devassy Chirammal <hchiramm@redhat.com>
    Reviewed-on: http://review.gluster.org/12563
    Tested-by: NetBSD Build System <jenkins@build.gluster.org>
    Tested-by: Gluster Build System <jenkins@build.gluster.com>
    Reviewed-by: Niels de Vos <ndevos@redhat.com>
    Reviewed-by: Poornima G <pgurusid@redhat.com>
    Reviewed-by: Raghavendra Talur <rtalur@redhat.com>
    Reviewed-by: Shyamsundar Ranganathan <srangana@redhat.com>
Comment 1 Mohamed Ashiq 2015-11-18 00:27:18 EST
*** Bug 1283040 has been marked as a duplicate of this bug. ***
Comment 2 Vijay Bellur 2015-11-18 07:51:39 EST
REVIEW: http://review.gluster.org/12645 (libgfapi: To support set_volfile-server-transport type "unix") posted (#1) for review on release-3.7 by Mohamed Ashiq Liyazudeen (mliyazud@redhat.com)
Comment 3 Vijay Bellur 2015-11-27 01:02:29 EST
REVIEW: http://review.gluster.org/12645 (libgfapi: To support set_volfile-server-transport type "unix") posted (#2) for review on release-3.7 by Mohamed Ashiq Liyazudeen (mliyazud@redhat.com)
Comment 4 Vijay Bellur 2015-12-02 04:19:58 EST
COMMIT: http://review.gluster.org/12645 committed in release-3.7 by Niels de Vos (ndevos@redhat.com) 
------
commit 41d84bb6256bdd17df09cce3d51a89d44c117bab
Author: Mohamed Ashiq <mliyazud@redhat.com>
Date:   Tue Nov 10 13:18:41 2015 +0530

    libgfapi: To support set_volfile-server-transport type "unix"
    
    This patch helps libgfapi to get the volfile using Unix domain socket.
    run the attachment file in the bug to test.
    The patch checks if the glfs_set_volfile_server transport is of type "unix",
    If It is then uses rpc_transport_unix_options_build to get the volfile.
    
    Signed-off-by: Mohamed Ashiq <mliyazud@redhat.com>
    Signed-off-by: Humble Devassy Chirammal <hchiramm@redhat.com>
    
    >Change-Id: Ifd5d1e7c0d8cc9a906c3c3355b8977141e892a2f
    >BUG: 1279739
    >Signed-off-by: Mohamed Ashiq <mliyazud@redhat.com>
    >Signed-off-by: Humble Devassy Chirammal <hchiramm@redhat.com>
    >Reviewed-on: http://review.gluster.org/12563
    >Tested-by: NetBSD Build System <jenkins@build.gluster.org>
    >Tested-by: Gluster Build System <jenkins@build.gluster.com>
    >Reviewed-by: Niels de Vos <ndevos@redhat.com>
    >Reviewed-by: Poornima G <pgurusid@redhat.com>
    >Reviewed-by: Raghavendra Talur <rtalur@redhat.com>
    >Reviewed-by: Shyamsundar Ranganathan <srangana@redhat.com>
    
    Change-Id: I0b3f2023e6698366d8c20d6574f5de7b8a641f30
    BUG: 1283038
    Reviewed-on: http://review.gluster.org/12645
    Tested-by: NetBSD Build System <jenkins@build.gluster.org>
    Tested-by: Gluster Build System <jenkins@build.gluster.com>
    Reviewed-by: Niels de Vos <ndevos@redhat.com>
Comment 5 Kaushal 2016-04-19 03:48:11 EDT
This bug is getting closed because a release has been made available that should address the reported issue. In case the problem is still not fixed with glusterfs-3.7.7, please open a new bug report.

glusterfs-3.7.7 has been announced on the Gluster mailinglists [1], packages for several distributions should become available in the near future. Keep an eye on the Gluster Users mailinglist [2] and the update infrastructure for your distribution.

[1] https://www.gluster.org/pipermail/gluster-users/2016-February/025292.html
[2] http://thread.gmane.org/gmane.comp.file-systems.gluster.user

Note You need to log in before you can comment on or make changes to this bug.