Bug 1280469 - rhel-osp-director: overcloud deployment exists with "Resource CREATE failed: resources.ControllerOvercloudServicesDeployment_Step4": puppet reports /usr/bin/nova-manage db sync returned 1 instead of one of
rhel-osp-director: overcloud deployment exists with "Resource CREATE failed: ...
Status: CLOSED DUPLICATE of bug 1281613
Product: Red Hat OpenStack
Classification: Red Hat
Component: rhosp-director (Show other bugs)
8.0 (Liberty)
x86_64 Unspecified
high Severity urgent
: ga
: 8.0 (Liberty)
Assigned To: Giulio Fidente
yeylon@redhat.com
:
Depends On: 1281613 1337537
Blocks: 1261979
  Show dependency treegraph
 
Reported: 2015-11-11 14:54 EST by Alexander Chuzhoy
Modified: 2016-05-19 08:11 EDT (History)
14 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-12-09 14:07:44 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
messages from one controller. (126.32 KB, application/x-gzip)
2015-11-11 14:56 EST, Alexander Chuzhoy
no flags Details
log and configs (103.80 KB, application/x-gzip)
2015-12-08 16:15 EST, Chris Dearborn
no flags Details

  None (edit)
Description Alexander Chuzhoy 2015-11-11 14:54:30 EST
rhel-osp-director: overcloud deployment exists with "Resource CREATE failed: resources.ControllerOvercloudServicesDeployment_Step4":  puppet reports /usr/bin/nova-manage db sync returned 1 instead of one of  

Environment:


openstack-heat-api-cloudwatch-5.0.0-1.el7ost.noarch
openstack-heat-api-5.0.0-1.el7ost.noarch
heat-cfntools-1.3.0-2.el7.noarch
python-heatclient-0.8.0-1.el7ost.noarch
openstack-heat-api-cfn-5.0.0-1.el7ost.noarch
openstack-heat-common-5.0.0-1.el7ost.noarch
openstack-heat-engine-5.0.0-1.el7ost.noarch
instack-undercloud-2.1.3-1.el7ost.noarch

Steps to reproduce:
Attempt to deploy overcloud.
openstack overcloud deploy --templates --ntp-server x.x.x.x --timeout90 --control-scale 3 --compute-scale 1

Result:
The deployment fails with:
                                                                                


Stack failed with status: Resource CREATE failed: resources.ControllerOvercloudServicesDeployment_Step4: resources.ControllerNodesPostDeployment.Error: resources[0]: Deployment to server failed: deploy_status_code: Deployment exited with non-zero status code: 6                                                                                                                                                                     
Heat Stack create failed.  


Checking the os-collect-config on a controller:

Nov 11 14:29:13 overcloud-controller-0.localdomain os-collect-config[4095]: Error: /Stage[main]/Nova::Db::Sync/Exec[nova-db-sync]: Failed to call refresh: /usr/bin/nova-manage db sync returned 1 instead of one of 
Nov 11 14:29:13 overcloud-controller-0.localdomain os-collect-config[4095]: Error: /Stage[main]/Nova::Db::Sync/Exec[nova-db-sync]: /usr/bin/nova-manage db sync returned 1 instead of one of [0]
Nov 11 14:29:13 overcloud-controller-0.localdomain os-collect-config[4095]: Error: /Stage[main]/Heat::Db::Sync/Exec[heat-dbsync]: Failed to call refresh: heat-manage --config-file /etc/heat/heat.conf db_sync retur
Nov 11 14:29:13 overcloud-controller-0.localdomain os-collect-config[4095]: Error: /Stage[main]/Heat::Db::Sync/Exec[heat-dbsync]: heat-manage --config-file /etc/heat/heat.conf db_sync returned 1 instead of one of 
Nov 11 14:29:13 overcloud-controller-0.localdomain os-collect-config[4095]: [2015-11-11 14:29:13,158] (heat-config) [ERROR] Error running /var/lib/heat-config/heat-config-puppet/fe7a1ad6-d0ce-467a-b81c-880ea46c783
Nov 11 14:29:13 overcloud-controller-0.localdomain os-collect-config[4095]: [2015-11-11 14:29:13,165] (heat-config) [INFO] Completed /var/lib/heat-config/hooks/puppet
Comment 2 Alexander Chuzhoy 2015-11-11 14:56 EST
Created attachment 1092857 [details]
messages from one controller.
Comment 3 Chris Dearborn 2015-12-04 15:36:31 EST
I hit this same problem as well.
Comment 4 Chris Dearborn 2015-12-04 16:12:13 EST
Hit this problem on two consecutive overcloud deployments.  It appears to be a blocker.
Comment 5 Chris Dearborn 2015-12-08 16:15 EST
Created attachment 1103723 [details]
log and configs
Comment 6 Chris Dearborn 2015-12-08 16:18:08 EST
Gael has hit this issue consistently on about 10 deployments.

I tried running the failing command directly from the command line and it appeared to work:

[heat-admin@overcloud-controller-0 ~]$ sudo /usr/bin/nova-manage db sync
No handlers could be found for logger "oslo_config.cfg"
[heat-admin@overcloud-controller-0 ~]$ echo $?
Comment 7 Giulio Fidente 2015-12-09 09:34:14 EST
we can't deploy multiple controllers without pacemaker yet, this seems to be failing because we don't default to use pacemaker for 8 yet, see bz #1281613
Comment 8 Giulio Fidente 2015-12-09 09:35:06 EST
adding the following to the deployment command should make it pass:

  -e /usr/share/openstack-tripleo-heat-templates/environments/puppet-pacemaker.yaml
Comment 9 Chris Dearborn 2015-12-09 14:05:05 EST
Gael has done an automated deployment with this setting, and it worked.  I think we can go ahead and close this one out.

Thanks!
Comment 10 Giulio Fidente 2015-12-09 14:07:44 EST

*** This bug has been marked as a duplicate of bug 1281613 ***

Note You need to log in before you can comment on or make changes to this bug.