Bug 128137 - RFE: please add aspell-bg
RFE: please add aspell-bg
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: distribution (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Eido INOUE
Bill Nottingham
: FutureFeature
Depends On:
Blocks: FC3Target
  Show dependency treegraph
 
Reported: 2004-07-19 04:36 EDT by Doncho N. Gunchev
Modified: 2014-03-16 22:46 EDT (History)
2 users (show)

See Also:
Fixed In Version: 50:0.50-3
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-10-19 16:25:36 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
aspell-bg spec file (1.07 KB, text/plain)
2004-08-01 17:50 EDT, Doncho N. Gunchev
no flags Details

  None (edit)
Description Doncho N. Gunchev 2004-07-19 04:36:22 EDT
I've created a rpm package from
http://bgoffice.sourceforge.net/aspell/ for aspell - aspell-bg. It is
available at
http://mr700.cjb.net/pub/packages/aspell-bg/SRPMS/aspell-bg-4.0-0.mr700.src.rpm.
 I used aspell-en-0.51-6.1.ker.rhel3.src.rpm's spec file as template.
The size is of the source package is 1.7Mb, binary package is 13Mb 
and when installed it takes 33-36 Mb. I belive we'll translate the
required po files in time to include Bulgarian in FC3 and aspell-bg
will be good to have too. I've tested the package while translating
system-logviewer and it works with kbabel, kwrite, kmail...
Comment 1 Doncho N. Gunchev 2004-08-01 17:50:07 EDT
Created attachment 102343 [details]
aspell-bg spec file

It only needs
http://belnet.dl.sourceforge.net/sourceforge/bgoffice/aspell-bg-4.0.tar.gz to
compile.
Comment 2 Doncho N. Gunchev 2004-08-05 04:48:01 EDT
As Fedora Core 3 test2 will have Bulgarian included it would be nice
to have this one too.
I've recompiled aspell-bg for FC3t1 and it is available from
http://mr700.cjb.net/pub/fc/3/i386/aspell-bg-4.0-0.i386.rpm. I did
some tests and it works fine with the following settings in kde:
  Dictionary: Bulgarian
  Encoding:   CP1251
  Client:     Aspell
and 'Consider run-together words as spelling errors' selected.
Is there something more that must/can be done?
Comment 3 Yanko Kaneti 2004-08-05 08:49:29 EDT
> Is there something more that can be done?

On a related note:

gnome-spell needs some fixing (like adding bg as a known language)
that would allow spellchecking in Evolution and other gnome apps.
I've managed to hack this together, but it was just a hack and not in
line with the extensive patching thats done in the Fedora gnome-spell rpm.

Somehow adding the spelling package without being able to support it
in the default desktop seems backwards.

Thanks for aspell-bg rpm.
Comment 4 Doncho N. Gunchev 2004-08-06 07:53:30 EDT
    I use only KDE (and it works fine with this package). Can you
provide more details about gnome-spell? What did you hack?
    I added Bulgarian in gnome-spell-1.0.5/gnome-spell/dictionary.c,
but this did not help.
    PS: does this gnome problem belong here or a new bug against
gnome-spell should be entered?
Comment 5 Eido INOUE 2004-08-24 15:04:41 EDT

*** This bug has been marked as a duplicate of 129520 ***
Comment 6 Doncho N. Gunchev 2004-09-27 17:12:27 EDT
    I reopen this bug since it's not fixed - there's still no
aspell-bg in the development tree. I have attached a spec file to bug
# 129520, so I don't attach it here again.
Comment 7 Eido INOUE 2004-10-14 16:04:03 EDT
It should be in the development tree for fc3 now.
Comment 8 Doncho N. Gunchev 2004-10-16 18:35:04 EDT
    Many thanks for aspell-bg, but I reopen this bug because there are
problems with the package (If I should open separate bug please tell me).
    I see your aspell-bg package is based on aspell-bg-0.50-0.tar.bz2,
which is older than aspell-bg-4.0.tar.gz. The problem with 0.50 it is
that it uses koi8-r (our 'official' encoding is cp-1251) and
'soundslike none' in bg.dat. I tought I can iconv the dictionary, but
there's another big problem with it - it includes a huge (about 1/2)
number of wrong words. You can verify this with this command (bg.cwl
is from aspell-bg-0.50-0.tar.bz2):
word-list-compress d < bg.cwl | iconv -f koi8-r -t utf8 | sort >
bg.cwl.txt
    At the end of the file (bg.cwl.txt) you'll see a number of words
that start with two equal letters 'я'(ia) like 'яямата' - there's no
such word in Bulgarian.
    In aspell-bg-4.0 these problems are fixed and it includes about
65000 words. There are also aspell5-bg-4.0-0 and aspell6-bg-0.02, so I
contacted Radostin Radnev and am waiting for response. When I know
what package should be used (I hope in 2-3 days) I'll attach a new
spec file and add the information I've gathered.
    PS: all files can be downloaded from bgoffice's sourceforge page -
 http://bgoffice.sourceforge.net/ or directly -
http://prdownloads.sourceforge.net/bgoffice/. Thanks again.
Comment 9 Doncho N. Gunchev 2004-10-17 15:36:37 EDT
    I got response from Radostin Radnev. He says that all version
except the last one on bgoffice.sf.net are wrong. He says all previous
versions were converted from the ispell's author to koi8-r and thet
don't work (infact, they have huge amount of mistakes).
    I assume that by 'last version' he means aspell-bg-0.50-2, because
all other are released on the same date too
(http://prdownloads.sourceforge.net/bgoffice/?sort_by=date).
    I'll not attach the whole spec file, because the original one
needs just these changes:
--- cut ---
%define langrelease 2
...
Source:
http://prdownloads.sourceforge.net/bgoffice/aspell-%{lang}-%{version}-%{langrelease}.tar.bz2
--- cut ---
    PS: I see there are aspell-bg-4.0.tar.gz, aspell6-bg-0.02.tar.bz2
and aspell5-bg-4.0-0.tar.bz2, but the files inside do not differ (only
comments and unesential files). I tested the new package and it works
fine with encoding CP-1251 as it must be.

Note You need to log in before you can comment on or make changes to this bug.