Bug 128322 - ntp Seg fault on system boot
Summary: ntp Seg fault on system boot
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: iptables (Show other bugs)
(Show other bugs)
Version: rawhide
Hardware: i686 Linux
medium
medium
Target Milestone: ---
Assignee: Thomas Woerner
QA Contact: Ben Levenson
URL:
Whiteboard:
Keywords:
: 128648 129247 (view as bug list)
Depends On:
Blocks: FC3Target
TreeView+ depends on / blocked
 
Reported: 2004-07-21 18:37 UTC by Will Backman
Modified: 2007-11-30 22:10 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-08-25 17:20:31 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
/etc/sysconfig/iptables (684 bytes, text/plain)
2004-08-02 15:20 UTC, Jef Spaleta
no flags Details
/etc/sysconfig/iptables-config (1.35 KB, text/plain)
2004-08-02 15:23 UTC, Jef Spaleta
no flags Details

Description Will Backman 2004-07-21 18:37:38 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7) Gecko/20040625

Description of problem:
During redhat graphical boot, I see seg fault when it tries to sync
time with clock.redhat.com

Version-Release number of selected component (if applicable):
ntp-4.2.0-8

How reproducible:
Always

Steps to Reproduce:
1. Press Power button
2. Watch screen
3. See seg fault message
    

Actual Results:  seg fault

Expected Results:  sync time with server

Additional info:

Comment 1 Harald Hoyer 2004-07-26 15:01:47 UTC
does the new rawhide version work for you?

Comment 2 Will Backman 2004-07-27 13:48:38 UTC
[whb@d1ntpm41 init.d]$ sudo /sbin/service ntpd stop
ntpd: Removing firewall opening for 66.187.224.4 port 123  [  OK  ]
ntpd: Removing firewall opening for clock.redhat.com port 123free():
invalid pointer 0x87d2664!
/etc/init.d/ntpd: line 169:  2351 Segmentation fault      iptables -D
$FWCHAIN -m udp -p udp -s $server/32 --sport 123 -d 0/0 --dport 123 -j
ACCEPT
                                                           [FAILED]
Shutting down ntpd:                                        [  OK  ]
[whb@d1ntpm41 init.d]$
ntp-4.2.0.a.20040616-1


Comment 3 Harald Hoyer 2004-07-27 13:54:14 UTC
wow... this seems to be iptables...

Comment 4 Thomas Woerner 2004-08-02 15:13:46 UTC
*** Bug 128648 has been marked as a duplicate of this bug. ***

Comment 5 Thomas Woerner 2004-08-02 15:14:27 UTC
Can you give me the glibc and iptables version by 'rpm -q <rpm>' and
your fireall configuration (/etc/sysconfig/iptables*), please?



Comment 6 Jef Spaleta 2004-08-02 15:20:58 UTC
Created attachment 102357 [details]
/etc/sysconfig/iptables

Comment 7 Jef Spaleta 2004-08-02 15:22:50 UTC
I'm seeing this as well

ntp-4.2.0.a.20040616-2
iptables-1.2.11-1
glibc-2.3.3-39

see attachment for the /etc/sysconfig/iptables  and iptables-config

Comment 8 Jef Spaleta 2004-08-02 15:23:40 UTC
Created attachment 102358 [details]
/etc/sysconfig/iptables-config

Comment 9 Glen 2004-08-05 15:05:18 UTC
*** Bug 129247 has been marked as a duplicate of this bug. ***

Comment 10 Thomas Woerner 2004-08-25 17:20:31 UTC
Fixed in rawhide in rpm iptables-1.2.11-2, or newer.


Note You need to log in before you can comment on or make changes to this bug.