Bug 1283278 - Add dependency when fix for bug 1283116 (7.2.z) is in ([abrt] qemu-img: get_block_status(): qemu-img killed by SIGABRT)
Summary: Add dependency when fix for bug 1283116 (7.2.z) is in ([abrt] qemu-img: get_b...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: vdsm
Version: 3.6.0
Hardware: x86_64
OS: Unspecified
medium
high
Target Milestone: ovirt-4.0.0-beta
: 4.0.0
Assignee: Allon Mureinik
QA Contact: Kevin Alon Goldblatt
URL: https://retrace.fedoraproject.org/faf...
Whiteboard:
Depends On: 1229394 1290683 1298828 1298886
Blocks: 1332028
TreeView+ depends on / blocked
 
Reported: 2015-11-18 15:20 UTC by Daniel Erez
Modified: 2016-08-23 20:18 UTC (History)
26 users (show)

Fixed In Version: v4.18.0
Doc Type: Bug Fix
Doc Text:
Clone Of: 1229394
: 1332028 (view as bug list)
Environment:
Last Closed: 2016-08-23 20:18:26 UTC
oVirt Team: Storage
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHEA-2016:1671 normal SHIPPED_LIVE VDSM 4.0 GA bug fix and enhancement update 2016-09-02 21:32:03 UTC
oVirt gerrit 56142 master MERGED spec: qemu-kvm-img to handle unaligned images 2016-04-26 12:29:10 UTC

Description Daniel Erez 2015-11-18 15:20:30 UTC
+++ This bug was initially created as a clone of Bug #1229394 +++

Description of problem:
$ truncate -s 1G test_sparse
$ echo "a" >> test_sparse
$ qemu-img map test_sparse

Version-Release number of selected component:
qemu-img-2.3.0-4.fc22

Additional info:
reporter:       libreport-2.5.1
backtrace_rating: 4
cmdline:        qemu-img map test_sparse
crash_function: get_block_status
executable:     /usr/bin/qemu-img
global_pid:     70309
kernel:         4.0.4-303.fc22.x86_64
runlevel:       N 5
type:           CCpp
uid:            1000

Truncated backtrace:
Thread no. 1 (2 frames)
 #4 get_block_status at qemu-img.c:2190
 #5 img_map at qemu-img.c:2286

--- Additional comment from Eric Harney on 2015-06-08 11:17:25 EDT ---



--- Additional comment from Eric Harney on 2015-06-08 11:17:26 EDT ---



--- Additional comment from Eric Harney on 2015-06-08 11:17:27 EDT ---



--- Additional comment from Eric Harney on 2015-06-08 11:17:28 EDT ---



--- Additional comment from Eric Harney on 2015-06-08 11:17:29 EDT ---



--- Additional comment from Eric Harney on 2015-06-08 11:17:30 EDT ---



--- Additional comment from Eric Harney on 2015-06-08 11:17:31 EDT ---



--- Additional comment from Eric Harney on 2015-06-08 11:17:32 EDT ---



--- Additional comment from Eric Harney on 2015-06-08 11:17:33 EDT ---



--- Additional comment from Eric Harney on 2015-06-08 11:17:34 EDT ---



--- Additional comment from Eric Harney on 2015-06-08 11:17:35 EDT ---



--- Additional comment from Eric Harney on 2015-06-08 11:17:36 EDT ---



--- Additional comment from Cole Robinson on 2015-06-08 16:52:53 EDT ---

Thanks for the simple reproducer! The assertion reproduces for me with qemu-2.1 up to current qemu.git

CCing some block layer folks

--- Additional comment from Kevin Wolf on 2015-06-09 05:26:23 EDT ---

Sent an upstream patch to fix this:
http://lists.nongnu.org/archive/html/qemu-devel/2015-06/msg02505.html

--- Additional comment from Cole Robinson on 2015-06-09 10:17:22 EDT ---

Thanks Kevin!

--- Additional comment from Fedora Update System on 2015-08-11 18:10:47 EDT ---

qemu-2.3.0-7.fc22 has been submitted as an update for Fedora 22.
https://admin.fedoraproject.org/updates/qemu-2.3.0-7.fc22

--- Additional comment from Fedora Update System on 2015-08-12 09:36:11 EDT ---

qemu-2.3.1-1.fc22 has been submitted as an update for Fedora 22.
https://admin.fedoraproject.org/updates/qemu-2.3.1-1.fc22

--- Additional comment from Fedora Update System on 2015-08-13 12:57:16 EDT ---

Package qemu-2.3.1-1.fc22:
* should fix your issue,
* was pushed to the Fedora 22 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing qemu-2.3.1-1.fc22'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2015-13402/qemu-2.3.1-1.fc22
then log in and leave karma (feedback).

--- Additional comment from Fedora Update System on 2015-08-18 01:15:53 EDT ---

qemu-2.3.1-1.fc22 has been pushed to the Fedora 22 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 5 Allon Mureinik 2016-04-14 09:06:36 UTC
Reducing priority. Without the underlying qmeu fix there's nothing VDSM can do, and once this fix is provided a "work around"  is a easy as "yum upgrade qemu". Having VDSM specify this requirement is just a nicety.

Comment 6 Nir Soffer 2016-04-14 16:10:37 UTC
Why do we need this bug? we do not create unaligned images.

Comment 7 Daniel Erez 2016-04-14 16:33:59 UTC
(In reply to Nir Soffer from comment #6)
> Why do we need this bug? we do not create unaligned images.

It solves an assertion error in live extend on PPC, see: https://gerrit.ovirt.org/#/c/50435/

Comment 8 Nir Soffer 2016-04-14 16:46:44 UTC
(In reply to Daniel Erez from comment #7)
> (In reply to Nir Soffer from comment #6)
> > Why do we need this bug? we do not create unaligned images.
> 
> It solves an assertion error in live extend on PPC, see:
> https://gerrit.ovirt.org/#/c/50435/

So why do we need https://gerrit.ovirt.org/56142?

Comment 9 Daniel Erez 2016-04-17 06:58:50 UTC
(In reply to Nir Soffer from comment #8)
> (In reply to Daniel Erez from comment #7)
> > (In reply to Nir Soffer from comment #6)
> > > Why do we need this bug? we do not create unaligned images.
> > 
> > It solves an assertion error in live extend on PPC, see:
> > https://gerrit.ovirt.org/#/c/50435/
> 
> So why do we need https://gerrit.ovirt.org/56142?

IIUC, this patch is for fixing the issue of converting the VM metadata file. See: https://bugzilla.redhat.com/show_bug.cgi?id=1282239#c14

Comment 10 Allon Mureinik 2016-04-27 10:58:48 UTC
The patch was merged on the ovirt-3.6 branch, moving to MODIFIED.

Comment 13 Kevin Alon Goldblatt 2016-06-14 11:36:47 UTC
Hi,

Please provide steps to reproduce this for QE,

Thanks, Kevin

Comment 14 Yaniv Kaul 2016-06-14 11:40:04 UTC
(In reply to Kevin Alon Goldblatt from comment #13)
> Hi,
> 
> Please provide steps to reproduce this for QE,
> 
> Thanks, Kevin

Kevin - see the patch itself.
Check that we require newer versions of qemu-kvm-rhev and qemu-img-rhev (downstream).

Comment 15 Kevin Alon Goldblatt 2016-06-14 13:11:01 UTC
Tested using the following code:
-------------------------------------
rhevm-4.0.0.2-0.1.el7ev.noarch
vdsm-4.18.1-11.gita92976e.el7ev.x86_64

Tested with the following outcome:
-------------------------------------
[root@purple-vds1 ~]# rpm -qR vdsm-4.18.1-11.gita92976e.el7ev.x86_64 |grep kvm
qemu-kvm-rhev >= 10:2.3.0-31.el7_2.6

Comment 16 Kevin Alon Goldblatt 2016-06-14 13:11:36 UTC
Moving to VERIFIED!

Comment 18 errata-xmlrpc 2016-08-23 20:18:26 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHEA-2016-1671.html


Note You need to log in before you can comment on or make changes to this bug.