Bug 1298886 - [abrt] qemu-img: get_block_status(): qemu-img killed by SIGABRT
Summary: [abrt] qemu-img: get_block_status(): qemu-img killed by SIGABRT
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: qemu-kvm-rhev
Version: 7.2
Hardware: x86_64
OS: Unspecified
high
high
Target Milestone: rc
: ---
Assignee: Max Reitz
QA Contact: Virtualization Bugs
URL:
Whiteboard:
: 1290683 (view as bug list)
Depends On:
Blocks: 1283278 1299345 1327592
TreeView+ depends on / blocked
 
Reported: 2016-01-15 11:11 UTC by Miroslav Rezanina
Modified: 2016-11-07 20:55 UTC (History)
17 users (show)

Fixed In Version: qemu-kvm-rhev-2.5.0-1.el7
Doc Type: Bug Fix
Doc Text:
Clone Of: 1283116
: 1299345 (view as bug list)
Environment:
Last Closed: 2016-11-07 20:55:01 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2016:2673 normal SHIPPED_LIVE qemu-kvm-rhev bug fix and enhancement update 2016-11-08 01:06:13 UTC

Comment 3 Ademar Reis 2016-05-31 19:22:26 UTC
*** Bug 1290683 has been marked as a duplicate of this bug. ***

Comment 4 weliao 2016-06-01 02:09:10 UTC
Reproduced this bug with qemu-img-rhev-2.3.0-31.el7.x86_64 & qemu-kvm-rhev-2.3.0-31.el7.x86_64

[root@dhcp-8-118 qemu230]# truncate -s 1G test_sparse
[root@dhcp-8-118 qemu230]# echo "a" >> test_sparse
[root@dhcp-8-118 qemu230]# qemu-img map test_sparse
Offset          Length          Mapped to       File
qemu-img: qemu-img.c:2294: get_block_status: Assertion `nb_sectors' failed.
Aborted (core dumped)


--------------------------------------------------------------------
Verified the bug with qemu-img-rhev-2.6.0-4.el7.x86_64 & qemu-kvm-rhev-2.6.0-4.el7.x86_64

[root@dhcp-8-118 opt]# truncate -s 1G test_sparse
[root@dhcp-8-118 opt]# echo "a" >> test_sparse
[root@dhcp-8-118 opt]# qemu-img map test_sparse
Offset          Length          Mapped to       File
0x40000000      0x200           0x40000000      test_sparse

according to this result.  The bug is fixed.

Comment 7 errata-xmlrpc 2016-11-07 20:55:01 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2016-2673.html


Note You need to log in before you can comment on or make changes to this bug.