Bug 1290683 - [abrt] qemu-img: get_block_status(): qemu-img killed by SIGABRT
Summary: [abrt] qemu-img: get_block_status(): qemu-img killed by SIGABRT
Keywords:
Status: CLOSED DUPLICATE of bug 1298886
Alias: None
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: qemu-kvm-rhev
Version: 7.2
Hardware: x86_64
OS: Unspecified
high
high
Target Milestone: rc
: ---
Assignee: Max Reitz
QA Contact: Virtualization Bugs
URL:
Whiteboard:
Depends On: 1229394 1283116
Blocks: 1283278 1327592
TreeView+ depends on / blocked
 
Reported: 2015-12-11 07:16 UTC by Max Reitz
Modified: 2016-05-31 19:22 UTC (History)
19 users (show)

Fixed In Version: QEMU 2.5
Doc Type: Bug Fix
Doc Text:
Clone Of: 1283116
: 1327592 (view as bug list)
Environment:
Last Closed: 2016-05-31 19:22:26 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2016:2673 normal SHIPPED_LIVE qemu-kvm-rhev bug fix and enhancement update 2016-11-08 01:06:13 UTC

Description Max Reitz 2015-12-11 07:16:23 UTC
+++ This bug was initially created as a clone of Bug #1283116 +++

Cloning for qemu-kvm in RHEL 7.3. The bug is fixed by upstream commit f4a769aba
("raw-posix: Fix .bdrv_co_get_block_status() for unaligned image size").


+++ This bug was initially created as a clone of Bug #1229394 +++

Description of problem:
$ truncate -s 1G test_sparse
$ echo "a" >> test_sparse
$ qemu-img map test_sparse

Version-Release number of selected component:
qemu-img-2.3.0-4.fc22

Additional info:
reporter:       libreport-2.5.1
backtrace_rating: 4
cmdline:        qemu-img map test_sparse
crash_function: get_block_status
executable:     /usr/bin/qemu-img
global_pid:     70309
kernel:         4.0.4-303.fc22.x86_64
runlevel:       N 5
type:           CCpp
uid:            1000

Truncated backtrace:
Thread no. 1 (2 frames)
 #4 get_block_status at qemu-img.c:2190
 #5 img_map at qemu-img.c:2286

--- Additional comment from Cole Robinson on 2015-06-08 22:52:53 CEST ---

Thanks for the simple reproducer! The assertion reproduces for me with qemu-2.1 up to current qemu.git

CCing some block layer folks

--- Additional comment from Kevin Wolf on 2015-06-09 11:26:23 CEST ---

Sent an upstream patch to fix this:
http://lists.nongnu.org/archive/html/qemu-devel/2015-06/msg02505.html

--- Additional comment from Cole Robinson on 2015-06-09 16:17:22 CEST ---

Thanks Kevin!

--- Additional comment from Fedora Update System on 2015-08-12 00:10:47 CEST ---

qemu-2.3.0-7.fc22 has been submitted as an update for Fedora 22.
https://admin.fedoraproject.org/updates/qemu-2.3.0-7.fc22

--- Additional comment from Fedora Update System on 2015-08-12 15:36:11 CEST ---

qemu-2.3.1-1.fc22 has been submitted as an update for Fedora 22.
https://admin.fedoraproject.org/updates/qemu-2.3.1-1.fc22

--- Additional comment from Fedora Update System on 2015-08-13 18:57:16 CEST ---

Package qemu-2.3.1-1.fc22:
* should fix your issue,
* was pushed to the Fedora 22 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing qemu-2.3.1-1.fc22'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2015-13402/qemu-2.3.1-1.fc22
then log in and leave karma (feedback).

--- Additional comment from Fedora Update System on 2015-08-18 07:15:53 CEST ---

qemu-2.3.1-1.fc22 has been pushed to the Fedora 22 stable repository.  If problems still persist, please make note of it in this bug report.

--- Additional comment from Daniel Erez on 2015-11-26 11:59:22 CET ---

Hi Max,

Should this bug be cloned in order to get it in qemu-kvm-rhev 7.2.z?

Thanks!
Daniel

--- Additional comment from Max Reitz on 2015-11-27 17:15:49 CET ---

Hi Daniel,

I do not know the exact process, but I think it does indeed make sense to have one BZ per target version.


Thank you,

Max

Comment 1 Jan Kurik 2015-12-11 08:59:10 UTC
rhel-7.2.z clone will be created from Bug 1283116 once the 1283116 is fully approved for zstream. For more information about the ZStream process, please follow the link: https://mojo.redhat.com/docs/DOC-1021938

Comment 2 Yaniv Lavi 2016-02-29 12:21:51 UTC
Reopening since this was missed for qemu-kvm-rhev.
When is a fix planned for this package?

Comment 8 Mike McCune 2016-03-28 23:09:17 UTC
This bug was accidentally moved from POST to MODIFIED via an error in automation, please see mmccune@redhat.com with any questions


Note You need to log in before you can comment on or make changes to this bug.