Bug 1283420 - message box fonts corrupted in libreoffice
message box fonts corrupted in libreoffice
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: libreoffice (Show other bugs)
23
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Caolan McNamara
Fedora Extras Quality Assurance
:
: 1287411 1293023 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-11-18 17:43 EST by Jan Vesely
Modified: 2015-12-26 06:38 EST (History)
10 users (show)

See Also:
Fixed In Version: libreoffice-5.0.4.2-2.fc23 libreoffice-5.0.4.2-3.fc23
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-12-24 19:25:21 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
dialog (9.13 KB, image/png)
2015-11-18 17:43 EST, Jan Vesely
no flags Details
license information (11.10 KB, image/png)
2015-11-19 10:35 EST, Jan Vesely
no flags Details
partial corruption (57.72 KB, image/png)
2015-11-19 10:38 EST, Jan Vesely
no flags Details

  None (edit)
Description Jan Vesely 2015-11-18 17:43:49 EST
Created attachment 1096359 [details]
dialog

Description of problem:
The text is unreadable. See attachment.


Version-Release number of selected component (if applicable):


How reproducible:
always (although not all dialogs, I have mostly seen it with calc)

Name        : libreoffice-calc
Epoch       : 1
Version     : 5.0.3.2
Release     : 4.fc23
Architecture: x86_64
Install Date: Tue 10 Nov 2015 10:42:24 AM CST
Group       : Applications/Productivity
Size        : 29978385
License     : (MPLv1.1 or LGPLv3+) and LGPLv3 and LGPLv2+ and BSD and (MPLv1.1 or GPLv2 or LGPLv2 or Netscape) and Public Domain and ASL 2.0 and Artistic and MPLv2.0 and CC0
Signature   : RSA/SHA256, Sat 07 Nov 2015 07:13:35 PM CST, Key ID 32474cf834ec9cba
Source RPM  : libreoffice-5.0.3.2-4.fc23.src.rpm
Build Date  : Thu 05 Nov 2015 02:28:23 PM CST
Build Host  : buildhw-06.phx2.fedoraproject.org
Relocations : (not relocatable)
Packager    : Fedora Project
Vendor      : Fedora Project
URL         : http://www.libreoffice.org/
Summary     : LibreOffice Spreadsheet Application
Comment 1 Caolan McNamara 2015-11-19 08:06:14 EST
Which dialog is the screen shot of ? The "Do you want to save" dialog is definitely rock solid for me with no corruption.
Comment 2 Jan Vesely 2015-11-19 10:35 EST
Created attachment 1096743 [details]
license information

I don't remember what dialog it was. however, the issue can be reproduced simply by displaying license information (help->license information).
This one is from oowriter (te same issue in oocalc).
Comment 3 Jan Vesely 2015-11-19 10:38 EST
Created attachment 1096745 [details]
partial corruption

sometimes only part of the dialog displays with corrupted fonts. The following happens every time I try to copy-paste text(with newlines and tabs/spaces) into oocalc.
Comment 4 Caolan McNamara 2015-12-14 09:03:21 EST
*** Bug 1287411 has been marked as a duplicate of this bug. ***
Comment 5 Caolan McNamara 2015-12-14 11:14:35 EST
gtk3 backend is unaffected, only the gtk2 one. Double checking with old versions of libreoffice 4.0.0 those are also affected if run on fedora 23, so seems that whatever the problem is is, its not a regression on our side. Either it was "always wrong, but worked", or some other component has broken. My money is on some XRendr problem.
Comment 6 Caolan McNamara 2015-12-14 16:10:40 EST
we're drawing the text with cairo, interestingly if I add an additional debugging draw + clear of a pixel via cairo_fill to that xlib surface before drawing the text, then it renders perfectly fine.

I'll try and extract a standalone demo unless the rings a bell with anyone.
Comment 7 Caolan McNamara 2015-12-15 06:40:36 EST
can't seem to create a standalone example. I can tell that if I build cairo with --enable-xlib-xrender=no then it also works fine, so the problem is in that direction
Comment 8 Caolan McNamara 2015-12-15 08:46:51 EST
I'll just bodge this to work for now. Still unsure what the core reason actually is.
Comment 9 Fedora Update System 2015-12-20 15:46:00 EST
libreoffice-5.0.4.2-3.fc23 has been submitted as an update to Fedora 23. https://bodhi.fedoraproject.org/updates/FEDORA-2015-98c92e275f
Comment 10 Fedora Update System 2015-12-22 19:11:18 EST
libreoffice-5.0.4.2-3.fc23 has been pushed to the Fedora 23 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2015-98c92e275f
Comment 11 Fedora Update System 2015-12-24 19:24:59 EST
libreoffice-5.0.4.2-3.fc23 has been pushed to the Fedora 23 stable repository. If problems still persist, please make note of it in this bug report.
Comment 12 Jan Vlug 2015-12-26 06:38:45 EST
*** Bug 1293023 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.