This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 1283566 - qupta/marker: backward compatibility with quota xattr vesrioning
qupta/marker: backward compatibility with quota xattr vesrioning
Status: CLOSED ERRATA
Product: Red Hat Gluster Storage
Classification: Red Hat
Component: quota (Show other bugs)
3.1
Unspecified Unspecified
unspecified Severity unspecified
: ---
: RHGS 3.1.2
Assigned To: Vijaikumar Mallikarjuna
Anil Shah
: ZStream
Depends On:
Blocks: 1260783 1283567 1283568
  Show dependency treegraph
 
Reported: 2015-11-19 05:20 EST by Vijaikumar Mallikarjuna
Modified: 2016-09-17 08:41 EDT (History)
8 users (show)

See Also:
Fixed In Version: glusterfs-3.7.5-7
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
: 1283567 (view as bug list)
Environment:
Last Closed: 2016-03-01 00:56:19 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Vijaikumar Mallikarjuna 2015-11-19 05:20:35 EST
quota-version features is implemented for 3.7.6
please see below patch for more details:
http://review.gluster.org/#/c/12386

Problem is when quota is already enabled,
we suffix 0 to contri xattr key.

This can cause backward compatibility issues when upgraded from 3.7.5 to 3.7.6 and can corrupt accounting information
Comment 2 Vijaikumar Mallikarjuna 2015-11-19 05:39:07 EST
upstream patch: http://review.gluster.org/#/c/12660
release-3.7 patch: http://review.gluster.org/#/c/12661/
Comment 4 Vijaikumar Mallikarjuna 2015-11-24 01:28:05 EST
downstream patch: https://code.engineering.redhat.com/gerrit/#/c/62064/
Comment 5 Anil Shah 2015-12-15 06:14:08 EST
Installed build glusterfs-3.7.5-5.el7rhgs.x86_64 .
Created volume , enabled quota and limit-usage.
Created some data. Checked quota list.

Updated system to build glusterfs-3.7.5-11.el7rhgs.x86_64.
Quota list displayed soft and hard limit same as before upgrade.

Hence marking this bug verified on build glusterfs-3.7.5-11.el7rhgs.x86_64.
Comment 7 errata-xmlrpc 2016-03-01 00:56:19 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2016-0193.html

Note You need to log in before you can comment on or make changes to this bug.