Bug 1283567 - qupta/marker: backward compatibility with quota xattr vesrioning
qupta/marker: backward compatibility with quota xattr vesrioning
Status: CLOSED CURRENTRELEASE
Product: GlusterFS
Classification: Community
Component: quota (Show other bugs)
mainline
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Manikandan
: ZStream
Depends On: 1283566
Blocks: 1283568
  Show dependency treegraph
 
Reported: 2015-11-19 05:22 EST by Vijaikumar Mallikarjuna
Modified: 2016-06-16 09:45 EDT (History)
3 users (show)

See Also:
Fixed In Version: glusterfs-3.8rc2
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: 1283566
: 1283568 (view as bug list)
Environment:
Last Closed: 2016-06-16 09:45:21 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Comment 1 Vijay Bellur 2015-11-19 05:23:09 EST
REVIEW: http://review.gluster.org/12660 (quota: fix backward compatibility of quota xattr version) posted (#1) for review on master by Vijaikumar Mallikarjuna (vmallika@redhat.com)
Comment 2 Vijay Bellur 2015-11-24 01:04:27 EST
COMMIT: http://review.gluster.org/12660 committed in master by Raghavendra G (rgowdapp@redhat.com) 
------
commit 5a06a9eef3f767c850e879ff87c72301e02fe137
Author: vmallika <vmallika@redhat.com>
Date:   Wed Nov 18 17:25:14 2015 +0530

    quota: fix backward compatibility of quota xattr version
    
    quota-version features is implemented for 3.7.6
    please see below patch for more details:
    http://review.gluster.org/#/c/12386
    
    Problem is when quota is already enabled,
    we suffix 0 to contri xattr key. for backward compatibility
    don't add suffix if quota-version is 0
    
    Change-Id: Id7d713b18d989e4e86019969eb511617848127f2
    BUG: 1283567
    Signed-off-by: vmallika <vmallika@redhat.com>
    Reviewed-on: http://review.gluster.org/12660
    Tested-by: Gluster Build System <jenkins@build.gluster.com>
    Tested-by: NetBSD Build System <jenkins@build.gluster.org>
    Reviewed-by: Raghavendra G <rgowdapp@redhat.com>
Comment 5 Niels de Vos 2016-06-16 09:45:21 EDT
This bug is getting closed because a release has been made available that should address the reported issue. In case the problem is still not fixed with glusterfs-3.8.0, please open a new bug report.

glusterfs-3.8.0 has been announced on the Gluster mailinglists [1], packages for several distributions should become available in the near future. Keep an eye on the Gluster Users mailinglist [2] and the update infrastructure for your distribution.

[1] http://blog.gluster.org/2016/06/glusterfs-3-8-released/
[2] http://thread.gmane.org/gmane.comp.file-systems.gluster.user

Note You need to log in before you can comment on or make changes to this bug.