Bug 1283568 - qupta/marker: backward compatibility with quota xattr vesrioning
qupta/marker: backward compatibility with quota xattr vesrioning
Status: CLOSED CURRENTRELEASE
Product: GlusterFS
Classification: Community
Component: quota (Show other bugs)
3.7.5
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Vijaikumar Mallikarjuna
: ZStream
Depends On: 1283566 1283567
Blocks:
  Show dependency treegraph
 
Reported: 2015-11-19 05:25 EST by Vijaikumar Mallikarjuna
Modified: 2016-05-11 18:47 EDT (History)
3 users (show)

See Also:
Fixed In Version: glusterfs-3.7.7
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: 1283567
Environment:
Last Closed: 2016-04-19 03:48:46 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Comment 1 Vijay Bellur 2015-11-19 05:25:45 EST
REVIEW: http://review.gluster.org/12661 (quota: fix backward compatibility of quota xattr version) posted (#1) for review on release-3.7 by Vijaikumar Mallikarjuna (vmallika@redhat.com)
Comment 2 Vijay Bellur 2015-11-24 01:04:50 EST
COMMIT: http://review.gluster.org/12661 committed in release-3.7 by Raghavendra G (rgowdapp@redhat.com) 
------
commit 99657b970855d9735a195e8ac19c8f1011d0d713
Author: vmallika <vmallika@redhat.com>
Date:   Wed Nov 18 17:25:14 2015 +0530

    quota: fix backward compatibility of quota xattr version
    
    This is a backport of http://review.gluster.org/#/c/12660/
    
    quota-version features is implemented for 3.7.6
    please see below patch for more details:
    http://review.gluster.org/#/c/12386
    
    Problem is when quota is already enabled,
    we suffix 0 to contri xattr key. for backward compatibility
    don't add suffix if quota-version is 0
    
    > Change-Id: Id7d713b18d989e4e86019969eb511617848127f2
    > BUG: 1283567
    > Signed-off-by: vmallika <vmallika@redhat.com>
    
    Change-Id: Id6e562b2cb6497f8205f13449b21a71c75bf343b
    BUG: 1283568
    Signed-off-by: vmallika <vmallika@redhat.com>
    Reviewed-on: http://review.gluster.org/12661
    Tested-by: NetBSD Build System <jenkins@build.gluster.org>
    Tested-by: Gluster Build System <jenkins@build.gluster.com>
    Reviewed-by: Raghavendra G <rgowdapp@redhat.com>
Comment 3 Kaushal 2016-04-19 03:48:46 EDT
This bug is getting closed because a release has been made available that should address the reported issue. In case the problem is still not fixed with glusterfs-3.7.7, please open a new bug report.

glusterfs-3.7.7 has been announced on the Gluster mailinglists [1], packages for several distributions should become available in the near future. Keep an eye on the Gluster Users mailinglist [2] and the update infrastructure for your distribution.

[1] https://www.gluster.org/pipermail/gluster-users/2016-February/025292.html
[2] http://thread.gmane.org/gmane.comp.file-systems.gluster.user

Note You need to log in before you can comment on or make changes to this bug.